none
Visual Studio 2013 "Setup Failed" when installing on Windows 8.1 Preview RRS feed

  • Question

  • Workaround:

    Using the web installer rather than the ISO seems not to have the same issue.  Installation via this method completed successfully.

    Original Post:

    I have Windows 8.1 Preview installed, and am trying to install Visual Studio 2013 Ultimate Preview from the ISO image.  I've tried restarting and installing it several times.  Windows is completely up to date, and I've tried disabling Windows Defender.  The installer stops saying that "Setup Failed: Install cannot continue because some required components failed."  The failed components are:

    • Microsoft Visual Studio 2013 VsGraphics Helper
    • Microsoft Visual C++ 2013 Core Libraries
    • Microsoft Visual C++ 2013 x86 Libraries
    • Microsoft Visual C++ 2013 x64 Libraries
    • Microsoft Visual C++ 2013 ARM Libraries
    • Microsoft Team Foundation Server 2013 Preview Object Model (x64)
    • Microsoft Team Foundation Server 2013 Preview Object Model Language Pack (x64) - ENU
    • Microsoft .NET Framework 4.5.1 Preview Multi-Targeting Pack (ENU)
    • Microsoft .NET Framework 4.5.1 Preview Multi-Targeting Pack for Windows Store Apps (ENU)
    • Microsoft .NET Framework 4.5.1 Preview Multi-Targeting Pack Language Pack - enu

    Here is the end of the install log:

    [0BB8:0758][2013-06-27T00:27:35]i351: Removing cached package: vs_preclean_vs, from path: C:\ProgramData\Package Cache\FF8908014EBD4DA9E2144C4A125C94A4C380B0D2\
    [0BB8:1508][2013-06-27T00:27:40]e000: Error 0x80070642: Failed to run maintanance mode for MSI package.
    [0BB8:1508][2013-06-27T00:27:40]e000: Error 0x80070642: Failed to execute MSI package.
    [0604:0CCC][2013-06-27T00:27:40]e000: Error 0x80070642: Failed to configure per-machine MSI package.
    [0604:0CCC][2013-06-27T00:27:40]i000: MUX:  Installation size in bytes for package: vc_librarycore86 MaxAppDrive: 0  MaxSysDrive: 3452928  AppDrive: 0  SysDrive: 0
    [0604:0CCC][2013-06-27T00:27:40]i000: MUX:  Return Code:0x80070642 Msi Messages:0 Result Detail:InstallFiles Restart:None
    [0604:0CCC][2013-06-27T00:27:40]w350: Applied non-vital package: vc_librarycore86, encountered error: 0x80070642. Continuing...
    [0BB8:1508][2013-06-27T00:27:40]i325: Registering dependency: {6a1d98e0-566d-4ac6-ac80-b64158a10907} on package provider: {F3F3AF09-90B6-3F8A-A1B2-6EC8468861C2}, package: vc_librarycore86
    [0BB8:1508][2013-06-27T00:27:40]i323: Registering package dependency provider: {7E130005-CD80-364B-8870-A4C4C573B27D}, version: 12.0.20617, package: vc_librarycore
    [0604:0CCC][2013-06-27T00:27:40]e000: Error 0x80070001: UX aborted execute MSI package begin.
    [0604:0CCC][2013-06-27T00:27:40]i000: MUX:  Installation size in bytes for package: vc_librarycore MaxAppDrive: 0  MaxSysDrive: 0  AppDrive: 0  SysDrive: 0
    [0604:0CCC][2013-06-27T00:27:40]i000: MUX:  Return Code:0x80070001 Msi Messages:0 Result Detail:0 Restart:None
    [0604:0CCC][2013-06-27T00:27:40]i319: Applied execute package: vc_librarycore, result: 0x80070001, restart: None
    [0604:0CCC][2013-06-27T00:27:40]e000: Error 0x80070001: Failed to execute MSI package.
    [0BB8:1508][2013-06-27T00:27:40]i351: Removing cached package: vc_librarycore, from path: C:\ProgramData\Package Cache\{7E130005-CD80-364B-8870-A4C4C573B27D}v12.0.20617\
    [0BB8:1508][2013-06-27T00:27:40]w353: Unable to remove cached package: vc_librarycore, from path: C:\ProgramData\Package Cache\{7E130005-CD80-364B-8870-A4C4C573B27D}v12.0.20617\, reason: 0x80070003. Continuing...
    [0BB8:1508][2013-06-27T00:27:40]i351: Removing cached package: vc_librarycore86, from path: C:\ProgramData\Package Cache\{F3F3AF09-90B6-3F8A-A1B2-6EC8468861C2}v12.0.20617\
    [0604:0CCC][2013-06-27T00:27:40]i000: MUX:  Apply Complete: Disk Space Used in bytes for Installation:  MaxAppDrive: 0  MaxSysDrive: 1257242624  AppDrive: 0  SysDrive: 256290816
    [0604:0CCC][2013-06-27T00:27:40]i000: MUX:  Free Disk Space after install:  SystemDrive C:\ 249215762432 bytes  AppDrive C:\ 249215762432 bytes
    [0604:0CCC][2013-06-27T00:27:40]i000: MUX:  Engine Restart's request: RestartRequired
    [0604:0CCC][2013-06-27T00:27:40]i000: MUX:  Go to Finished page.
    [0604:0CCC][2013-06-27T00:27:40]i399: Apply complete, result: 0x80070001, restart: Required, ba requested restart:  No



    • Edited by ntpeters Friday, July 5, 2013 11:42 PM Added workaround
    Thursday, June 27, 2013 5:39 AM

Answers

  • There seems to be a workaround by using the web installer instead of the ISO.  BobTabor discovered this in his thread over here: http://social.msdn.microsoft.com/Forums/vstudio/en-US/10cce939-b06e-4406-ab9a-36bbbddd342e/setup-failed-vs-2013-pro-beta-on-windows-81-pro-x64-beta-?prof=required
    Friday, July 5, 2013 11:45 PM

All replies

  • I still have had no luck getting VS 2013 Preview to install.  I've even tried repairing my VS 2012 installation, ensuring it was fully updated, and then re-installing VS 2013.  Does anyone have any ideas?

    It looks like this person is having the same issue:

    http://social.msdn.microsoft.com/Forums/vstudio/en-US/10cce939-b06e-4406-ab9a-36bbbddd342e/setup-failed-vs-2013-pro-beta-on-windows-81-pro-x64-beta-

    Friday, June 28, 2013 4:13 AM
  • I have file a bug report for this issue.  If anyone else is also experiencing this problem, please go to the following link.  Comment with your details and acknowledge that you can also reproduce this bug (in the upper right corner of the following post):
    https://connect.microsoft.com/VisualStudio/feedback/details/791407/visual-studio-2013-preview-installation-fails-on-windows-8-1-preview
    Friday, June 28, 2013 4:41 AM
  • Should I install Windows 8.1, if I want to install Visual Studio 2013 preview?

    崖山之後無中國,明亡之後無華夏

    Friday, June 28, 2013 8:39 AM
  • what else?

    Friday, June 28, 2013 11:18 AM
  • What do you mean by "what else?" ?
    Friday, July 5, 2013 2:56 PM
  • Hi ntpeters,

    this was an answer to Disleys question. Instead "what else" you can also read "why not". Your question is legitimate. imho MS pushes too much previews. Preview here, preview there, previews everywhere.

    regards

    Oliver

    Friday, July 5, 2013 7:22 PM
  • There seems to be a workaround by using the web installer instead of the ISO.  BobTabor discovered this in his thread over here: http://social.msdn.microsoft.com/Forums/vstudio/en-US/10cce939-b06e-4406-ab9a-36bbbddd342e/setup-failed-vs-2013-pro-beta-on-windows-81-pro-x64-beta-?prof=required
    Friday, July 5, 2013 11:45 PM
  • The bug report referred to by the above post (https://connect.microsoft.com/VisualStudio/feedback/details/791407/visual-studio-2013-preview-installation-fails-on-windows-8-1-preview) has a status of 'closed'.  I'm experiencing a similar problem (install stops at "Applying - Microsoft Visual Studio 2013 Express Prereqisites x64 - ENU'. Left it running overnight so it isn't a lack of patience)

    The install Also failed at the same step with VS 2012 Express.

    Clicking 'Cancel' hangs on 'Stopping current session...'. 

    This is on Windows 8.1 - recently upgraded.

    I'm going to retry using the ISO installer rather than the web installer.



    • Edited by wolfstevent Tuesday, August 13, 2013 1:05 PM
    Tuesday, August 13, 2013 1:02 PM
  • I had the same issue while installing RTM version. I replaced the files from the RC version I had downloaded earlier. This is what I did to fix the issue

    - Uninstall the failed version of 2013 from control panel -> Uninstall programs

    - Restart the computer

    - Extract the files from the ISO to a local folder

    - Replace the the folder "Packages/vsGragphics..." with the copy from RC version ISO.

    - Re-run the setup again from local folder.

    Tuesday, October 22, 2013 6:28 AM
  • I have same issue I am trying to install VS2013 Professional on windows 8.1. I have an ISO file. Please suggest some solution
    Saturday, March 1, 2014 7:12 PM
  • test
    Friday, September 26, 2014 3:05 AM