locked
asp.net page - button not working..... RRS feed

  • Question

  • Hi everyone.

    I'm trying to create a form, which i've done loads of times before, by putting a textbox on one page with a button and put the postback url to another page where there is a gridview and it displays the results.

    Anyway, i've gone to do this again today and when I preview it, when you click the button it remains on the same page instead of going to the next one.

    I have repeated my steps over and over incase I am doing something wrong but it's not working and when I pull up an old search page that used to work in preview before, it does exactly the same thing!

    I cant work out why the button is not working

    Any ideas???

    Wednesday, November 3, 2010 12:23 PM

All replies

  • You need to change the postBackUrl property of the button if you want it to go to another page.

     


    Jim Cheshire http://www.jimcobooks.com
    Wednesday, November 3, 2010 1:20 PM
    Moderator
  • yeah, thats my problem, i have changed the postback url to the name of the page i want it to go to but it doesnt change.
    Thursday, November 4, 2010 2:33 PM
  • yeah, thats my problem, i have changed the postback url to the name of the page i want it to go to but it doesnt change.
    Thursday, November 4, 2010 2:36 PM
  • Can you clarify what you mean by "it doesn't change"?

     


    Jim Cheshire http://www.jimcobooks.com
    Thursday, November 4, 2010 2:42 PM
    Moderator
  • Pin down where the problem is.  See if it works when you publish the page.  When you say a page that used to work no longer does in your local preview, something changed that affects both pages.

    Thursday, November 4, 2010 3:12 PM
  • Hi all, I found the problem, it just wasnt working in the preview, not sure why but its fine when I publish it.

    Thanks and sorry!!

     

    xx

    Monday, November 15, 2010 9:55 AM