Microsoft Account authentication for Windows Store Apps using Windows Azure Mobile Services RRS feed

  • Question

  • I have followed all the steps listed on the azure website and also checked the samples out. But I get this error. I cannot understand what is wrong. I am a novice regarding authentication services. I even reactivated the secret key.
    Thursday, March 20, 2014 3:39 PM


All replies

  • Can you give some more information on which Azure site are you referring to and how does the Authentication broker get displayed in your app?

    Windows Store Developer Solutions, follow us on Twitter: @WSDevSol|| Want more solutions? See our blog

    Thursday, March 20, 2014 10:56 PM
  • the official Azure site... well, I have already registered on the live SDK and created added the sample listed on the azure website. It works for facebook but not ms account
    Saturday, March 22, 2014 12:13 PM
  • Unfortunately I cannot reproduce the issue you have reported. I followed the steps as per: http://www.windowsazure.com/en-us/documentation/articles/mobile-services-windows-store-dotnet-get-started-users/ and added the redirect URL (the name of my website: <a href="https://<>.azure-mobile.net">https://<>.azure-mobile.net) in the "API settings" section of my Microsoft account.

    When do you see the error? When bringing up the login screen itself or does the Microsoft account sign-in page show up correctly and the error happens when you submit your username and password?

    Windows Store Developer Solutions, follow us on Twitter: @WSDevSol|| Want more solutions? See our blog

    Monday, March 31, 2014 8:42 PM
  • I'm getting the same error.  Facebook, Twitter and Google all work for me, but Microsoft does not.  In my situation, it seems like there's a problem with the redirect URL.  I've followed the documentation exactly, but still get the same error.  In the meantime, I have disabled enhanced redirection security so I can continue development.  It's the only workaround I've got thus far.
    Thursday, April 17, 2014 6:23 PM