locked
SQL Server 2008 R2 MDM - Transaction Record not Created RRS feed

  • Question

  • Hi,

    I use an SSIS package to load data from a source DB into Stage Tables (stgMember and stgMemberAttribute). Then I call The updStageSweep Stored Procedure and finally the udpValidateModel to validate the data. The data is correctly inserted into my Master Tables and Validation Succeeds.

    But members added by this approach does not seem to create a Transaction Record/History. However when members are added/modified in the MDM Web UI, transaction records are created.

    How do I make my MDM create these transaction history for members that were added/modified using the SSIS package (or via the Stagging Tables in general) ?


    • Edited by iUse Wednesday, December 21, 2011 8:59 AM
    Wednesday, December 21, 2011 6:33 AM

Answers

  • HiUse,

     

    I remember I've had something similar in the past. It could be that your configuration option

    'Log all staging transactions' needs to be turned on. You can do this by using the Configuration Manager application.

    http://msdn.microsoft.com/en-us/library/ff487028.aspx

    Hope that helps

    Cees


    Please remember to mark replies as answers or at least vote helpfull if they help and unmark them if they provide no help.
    • Marked as answer by iUse Wednesday, December 21, 2011 9:58 AM
    Wednesday, December 21, 2011 9:33 AM

All replies

  • HiUse,

     

    I remember I've had something similar in the past. It could be that your configuration option

    'Log all staging transactions' needs to be turned on. You can do this by using the Configuration Manager application.

    http://msdn.microsoft.com/en-us/library/ff487028.aspx

    Hope that helps

    Cees


    Please remember to mark replies as answers or at least vote helpfull if they help and unmark them if they provide no help.
    • Marked as answer by iUse Wednesday, December 21, 2011 9:58 AM
    Wednesday, December 21, 2011 9:33 AM
  • Thank you Cees, that solved my problem
    Wednesday, December 21, 2011 9:59 AM