none
[WHCK]System - PNP (disable and enable) with IO Before and After (Certification) failure as smart card reader RRS feed

  • Question

  • Hi all,

    When we run the system WHQL test, it will fail at system IO test.

    The failure WHCK test items as below:
    System - PNP (disable and enable) with IO Before and After (Certification)
    System - Sleep and PNP (disable and enable) with IO Before and After (Certification)
    System - Sleep with IO Before and After (Certification)
    And there are the same error, and the error message as below:
    WDTF_SIMPLE_IO : SMARTCARDREADERSimpleIO.SmartCardReader.1 SetTarget() ERROR : SmartCardReaderPlugin: SetTarget() - Failed to find a smart card reader with AthenaT0 test card inserted HRESULT=0x80040200 HRESULT=0x80040200

    Could you please help to check it?

    Thanks.



    • Edited by Jimmy i.k Tuesday, January 29, 2013 8:31 AM
    Tuesday, January 29, 2013 8:07 AM

All replies

  • The test requires an Athena T0 test card as documented on http://msdn.microsoft.com/en-us/library/windows/hardware/hh781398(v=vs.85).aspx.

    It can be obtained from: http://www.pcscworkgroup.com/specifications/newtestcards.php

    Thanks


    This posting is provided AS IS with no warranties, and confers no rights.

    Tuesday, January 29, 2013 8:15 PM
  • Hi Srepaka,

    Beacuse we run Win8 system WHCK test, but I only find the PC/SC Test Cards v.2.0 which is only supported on Win7 and VISTA as well as earlier platforms, not includes Win8.

    Could you please help me to confirm it? Thanks.


    • Edited by Jimmy i.k Wednesday, January 30, 2013 6:26 AM
    Wednesday, January 30, 2013 6:25 AM
  • The same cards can be used for Windows 8 testing as well. Thanks.

    This posting is provided AS IS with no warranties, and confers no rights.

    Wednesday, January 30, 2013 8:29 PM
  • Hello,

    We are experiencing the same problem when running the test in Windows 8 and Windows 8.1. The card is actually inserted but the error still occurs. What do you think can we do?

    Here are the errors:

    WDTF_SIMPLE_IO : SMARTCARDREADERSimpleIO.SmartCardReader.1 SetTarget() ERROR : SmartCardReaderPlugin: SetTarget() - Failed to find a smart card reader with AthenaT0 test card inserted HRESULT=0x80040200 HRESULT=0x80040200

    WDTF_SIMPLE_IO : SMARTCARDREADERSimpleIO.SmartCardReader.1 SetTarget() ERROR : CSmartCardReaderImpl::IsAthenaT0() - Could not open a handle to the Smart Card Reader device Win32=1 - Incorrect function. Win32=1 - Incorrect function. 

    Friday, April 17, 2015 8:03 AM