locked
Creating Dynamic Security group error RRS feed

  • Question

  • Hi there,

    I've been attempting to create a dynamic device security group in Azure AD with the query:

    (device.devicePhysicalIDs -any _ -contains "[ZTDId]")

    Every time I do this I get an error on creation:

    I also tried using simpler expressions, no matter what expression I put in there it always comes back with this error. However, If i utilize the powershell AzureADPreview module I can create the group no problem with the query above. If I had to guess it seems like the front end validation of the query string is not working the way its supposed to.

    Is this is a known issue? Why can't I create it in the Azure portal?


    • Edited by JoshuaMelo Monday, April 6, 2020 4:45 PM
    Monday, April 6, 2020 4:45 PM

All replies

  • But it does this with any value I put in.
    Monday, April 6, 2020 8:34 PM
  • Hello JoshuaMelo,

    I just tried creating a Dynamic Group using the same rule that you tried and I was able to successfully create the group using your rule.

    It looks like an error happening at your portal level. Can you help us in extracting the details (if any) for that error that pops up on the portal. You can select the "bell icon [notification icon]" on the top right hand of your Azure Portal and expand it, and it should show you the details for this error. Try sharing that details, lets see if that gives any more info about this failure.

    Thursday, April 9, 2020 6:59 AM
  • Is there any update? Please share the details as asked by SouravMishra-MSFT in the reply, so that he can assist you better.

    Monday, April 13, 2020 6:53 PM
  • Hello,

    Any update on the issue?

    Thanks.

    Thursday, April 16, 2020 2:17 PM