none
Windows 7 freeze when Debugging in VS 2013

    Question

  • I have following problem: Sometimes, when I debug a C++ project in VS 2013, my complete Windows freezes! This means:

    • GUI is updated (i.e. previous opened Task Manager is updating values)
    • Can not close VisualStudio
    • Can not close any program (i.e. firefox, the program which is been debugged, outlook, ...)
    • killing any process via Task Manager not working
    • Klicking Windows start button not working
    • Hitting Strg+Alt+Del not working
    • The only thing I can do is press and holding the I/O Hardware button at my Laptop

    The system is a Windows 7 Enterprise x64 with SSD, 16GB RAM and i7 CPU. Symantec Endpoint Protection is installed from our IT. Some of my collegues have the same problem. We think, that this problem only occures if mixed-Debugging with Managed-Code, Unmanged-Code and COM in code is used.

    Thanks for your Help!


    Friday, March 24, 2017 9:29 AM

All replies

  • Hi danielh2412,

    Not debug your app, just run your app using "start without debugging", how about the result?

    Please also check that whether it is related to the managed compatibility mode or Native compatibility mode under tools->options->debugging->general.

    Thanks,

    Jack


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Sunday, March 26, 2017 4:43 AM
    Moderator
  • Hi Jack,

    the error does not occure every time. The program is already released to many customers since years and this error never occured in field. I have run the program about 10-15 times from VisualStudio without debugging and the error nevver occured. But keep in mind, that this can be luck that the error not occures, because it is sporadically. The debugger-Settings for the Project is "Auto" for Debugger Type. In VisualStudio preferences, "Use Manged Compatibility Mode" is set. The other option, "Use Native Compatibility Mode" can not be found in the preferences window?

    Thanks

    Daniel


    Monday, March 27, 2017 4:53 AM
  • Hi Daniel,

    Actually this forum is to discuss the VS IDE, I just provide some suggestions for you to narrow down this issue.

    (1) Debug your app with step Into, and check that whether it is related to the specific line code.

    (2) Enable the Exception windows under Debug menu, and make sure that it doesn't have the unhandled exception.

    (3)As you said that "the error does not occure every time", I also have no direct solution for it, but if it has this issue again, one idea is that you could try to collect the crashed dump files, and then debug the dump files in your side, at least, it could provide much more information.

    Best Regards,

    Jack


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, March 27, 2017 10:53 AM
    Moderator