none
SP 2013 RSViewer on iPad/iOS RRS feed

  • Question

  • Hi All,

    We have bunch of reporting services (RS) reports posted on SharePoint 2013 (SQL Server 2012 Standard)

    Our remote users have iOS devices (iPAds and iPhones) and need to view these RS reports.

    The reports are configured via rsviewer webpart (not performancepoint webpart).

    Problems:

    1.When user access this reports via Chrome, Safari,FF on iPAd they get Loading loop: loading, autorefreshes, loading again, etc.

    2. If I uncheck "Asynchronous Rendering" rsviewer webpart property, the reports will display on iOS (Chrome, Safari,FF)  which seems to resolve # 1.

    BUT I CANNOT EXPAND ANY GROUPS in the report. If I click on '+' sign to expand a group, the page will try to refresh but remains the same and the group will not expand.

    (same reports work fine on Android devices and Windows)

    How to resolve it? Is it browser issue or iOS issue? Should the RS reports be uploaded or configured any differently? Need your advice.  

    Thank you.



    • Edited by BrBa Monday, January 23, 2017 2:13 PM
    Monday, January 23, 2017 2:10 PM

All replies

  • Hi,

    Please try to access the reporting service reports in iOS (Chrome, Safari,FF) directly, and check if the issue still exists.

    To adapt all the devices, as a workaround, we can customize a web part to show the report.

    Best Regards,

    Dennis


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Thursday, January 26, 2017 2:25 AM
    Moderator
  • 1. Same RDL Reports do work FULLY and COMPLETELY in iOS (Chrome, Safari, FF) directly, on stand-alone RS server via Report Manager (no SharePoint involved).

    2. Same RDL Reports uploaded on SharePoint in special rdl-content-permitted folder, if clicked, they keep refreshing.

    3. Same RDL Reports that used to work on SharePoint via RSviewer webpart (back in Dec, as per users) are no longer working (keep refreshing/groups not expanding).

    4. Refresh problem sort of resolved:If I uncheck "Asynchronous Rendering" rsviewer webpart property, the reports will display on iOS (Chrome, Safari,FF) 

    4. Problem remains: Users cannot expand any group-ings in the report. If I click on '+' sign to expand a group, the page will try to refresh but remains the same and the group will not expand. How to customize rsviewer webpart to expand any group-ings in the report?

    Here are the Logs from Chrome Dev Tools:

    Multiple 'X-Frame-Options' headers with conflicting values ('SAMEORIGIN, ALLOW-FROM http://cloud/sites/home') encountered when loading 'https://cloud.mycompany.com/sites/home/analytics/Reserved.ReportViewerWebPart.axd?OpType=Calendar&LCID=4105&selectDate=25%2f01%2f2017'. Falling back to 'DENY'.
    Reserved.ReportViewerWebPart.axd:1 Refused to display 'https://cloud.mycompany.com/sites/home/analytics/Reserved.ReportViewerWebPart.axd?OpType=Calendar&LCID=4105&selectDate=25%2f01%2f2017' in a frame because it set 'X-Frame-Options' to 'SAMEORIGIN, ALLOW-FROM http://cloud/sites/home'.
    Reserved.ReportViewerWebPart.axd:1 Multiple 'X-Frame-Options' headers with conflicting values ('SAMEORIGIN, ALLOW-FROM http://cloud/sites/home') encountered when loading 'https://cloud.mycompany.com/sites/home/analytics/Reserved.ReportViewerWebPart.axd?OpType=Calendar&LCID=4105&selectDate=25%2f01%2f2017'. Falling back to 'DENY'.
    Reserved.ReportViewerWebPart.axd:1 Refused to display 'https://cloud.mycompany.com/sites/home/analytics/Reserved.ReportViewerWebPart.axd?OpType=Calendar&LCID=4105&selectDate=25%2f01%2f2017' in a frame because it set 'X-Frame-Options' to 'SAMEORIGIN, ALLOW-FROM http://cloud/sites/home'. 

    Thursday, January 26, 2017 4:38 PM