none
Problems with custom shell in Windows Industry Pro 8.1 (Eval version)? RRS feed

  • Question

  • Hi all,

    I'm trying to launch a custom shell with no success. I have an admin account and guest account, the custom shell is meant for the guest. Following the instructions here

    first, I turned Shell Launcher on using the Control Panel.

    Then I used the Embedded Lockdown Manager to setup the shell which is a custom executable file, for the guest account.

    What I was expecting was that upon sign-in of the guest user, the application would be loaded. Instead, windows is booted normally.

    I have two questions:

    1. What possible reasons could cause the shell not to load? I saw Sean Liming's thread that seems related, but almost a year has passed so I'm hoping it may have been fixed. Could the problem be that I'm using the evaluation version of Windows Industry ?

    Also, checking the registry, I can see that 

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Embedded\Shell Launcher\

    is set to the custom shell, so I'm not sure why it isn't being launched...


    2. What is the behavior I should be expecting to see? Should the application load immediately after sign-in, full screen, without seeing any windows screen, taskbar, start logo , etc..? Or does it open in a window (not full screen) inside the regular windows environment?

    Thanks,

    Ron

     




    • Edited by RonM14 Wednesday, August 13, 2014 2:26 PM
    Wednesday, August 13, 2014 2:08 PM

All replies

  • I don't know if the WEI 8.1 Update solved the issue, but if you are using SIM to create an auto installer, then you might be running into the same problem. The book site has the script to fix this: http://annabooks.com/Book_SGSIM.html

    If you are using ELM to enable shell launcher then it should work. The guest account should see the custom application as the shell. Try setting the default shell to the custom application and see what happens.


    www.annabooks.com / www.seanliming.com / Book Author - Pro Guide to WE8S, Pro Guide to WES 7, Pro Guide to POS for .NET

    Wednesday, August 13, 2014 11:55 PM
    Moderator
  • I have used ELM to enable the shell launcher but nothing is being launched. ELM is working because I can use the keyboard filters for example.

    If I change the shell using the HKLM\Software\Microsoft\Windows NT\CurrentVersion\Winlogon\Shell

    registry key, the custom shell is launched- but then it is applied to all users including admin, so that doesn't seem like a good solution.

    Thursday, August 14, 2014 10:30 AM