locked
Cannot create a CDN endpoint RRS feed

  • Question

  • Hi there,

    I am trying to create a CDN endpoint and it is failing with the text: "Failed to create endpoint '(endpoint-name)'" on the CDN profile page. There is no possibility to click anywhere to get more info on the error. The notification area lists the error, however, the description is misleading: "This resource was not found, it may have been deleted. /subscriptions/(subs-id)/resourcegroups/(res-group-name)/providers/Microsoft.Cdn/profiles/(profile-name)/endpoints/(endpoint-name)".

    If I decide to create another CDN endpoint with a different name, it works. So it is probably connected to the fact that I was trying to create this particular endpoint while another one was being created.

    Just to add, the dialog to add the endpoint lets me enter all the info and proceed. The failure happens afterwards.

    Many thanks for any help,

    Jan

    Tuesday, July 10, 2018 1:41 PM

All replies

  • Azure should not let you make 2 resources with the same name in the same resource group. The error you give usually occurs if someone deletes the CDN while the endpoint is being created. 

    Have you tried to make the CDN Endpoint in Azure Powershell or the CLI? You might get different results or a better error message there. 

    Tuesday, July 10, 2018 6:15 PM
  • Hi Travis,

    Thank you for your reply. Unfortunately, I was not able to move on:(

    I tried listing all the resources in the resource group and the endpoint is not listed there. The same applies to listing all the endpoints of the CDN profile. By listing the deployments to the resource group I can just see the same error being repeated over and over again ({ "code": "Conflict", "message": "The resource name isn't available" }). Yet when trying to access the endpoint using its DNS name, my browser reports an unknown DNS name (which leads me to believe that the endpoint is non-existent).

    When trying to create the endpoint again using PowerShell, I just get a BadRequest response, without further explanation. When trying to create it with Azure CLI and allowing for --debug, I see a PUT request to create the endpoint and the HTTP result code is 409 (which again leads to the same error as stated above).

    The endpoint name I am trying to create is "divesoft-cdn-app-2".

    Are there any other means to discover whether I am really trying to create something used by someone else? This would be a great coincidence, given the name and the fact that the endpoint "divesoft-cdn-app-1" was created successfully.

    Many thanks for your help,

    Jan

    Thursday, July 12, 2018 9:19 AM
  • Hi, 

    I had the same problem. In my case, I delete the CDN, wait for a couple hours and tried to create again.

    Probably there was some issue with the DNS update time or someone else use the same name.

    Thursday, July 12, 2018 9:46 AM
  • Hi George!

    Do you mean deleting the whole CDN profile? Except for the work to be done again this is no problem for me, as still haven't started actually using it...

    Thursday, July 12, 2018 9:50 AM
  • Hi Honza, 

    Yes, that's what I mean.Αt least in my case that was the issue. Although the message you mentioned seems to be the same in yours too.

    Thursday, July 12, 2018 10:01 AM
  • Thanks,

    It is worth to try and to be honest, this all seems like some weird bug, so no obvious recovery option will be probably available anyway. Will let you know if it helped!

    Thursday, July 12, 2018 10:35 AM
  • Hello Honza,

    If you are still blocked I can look into this further. Could you please email your Subscription ID, CDN Name & the Endpoint Name you tried to create to AzCommunity@microsoft.com?

    Thursday, July 12, 2018 9:38 PM
  • Hello Travis,

    I have sent you an e-mail with the info, as you requested. Unfortunately, even deleting the CDN Profile and creating everything from the scratch did not help. This one particular endpoint name is simply not available, even if it does not really exist. Would be perfect to know why this happens and how to cope this for the future, however, the best solution for now seems to be naming the endpoint differently, as there will be a custom domain name anyway.

    Please let me know if you needed anything else!

    Friday, July 13, 2018 8:06 AM
  • Hello Honza,

    Because your problem seems to be interesting (from the troubleshooting side), can you please provide a detailed log of these errors?

    I would like to get more involved until I get to the edge

    Friday, July 13, 2018 10:20 AM
  • Hello George,

    Would love to and will, if you tell me where I can find something more than what I have already posted, e.g. ({ "code": "Conflict", "message": "The resource name isn't available" }). The portal shows me nothing meaningful, the same applies for PowerShell (here I probably miss something) and the JSON object I have sent is the output of AZ CLI.


    Friday, July 13, 2018 10:36 AM
  • Unfortunately, I see that if the deploy is not succeeded you can see only read this JSON object.

    Could you try to run the next Powershell to check the availability of the CDN name:

    Login-AzureRmAccount
    
    $EndpointName= 'yourEnpointName'
    Get-AzureRmCdnEndpointNameAvailability -EndpointName $EndpointName


    Results :

    NameAvailable Reason                 Message           
    ------------- ------                 -------           
            False Name is already in use Name not available






    Friday, July 13, 2018 11:28 AM
  • This starts to be very interesting, as calling this returns True. If I try any other, already created, endpoint, it returns exactly what you have sent. Really weird:(
    Friday, July 13, 2018 11:40 AM
  • I think that you should escalate the problem to Microsoft Azure Support, I cannot explain this, it's really weird!

    Probably something happens on the first time you tried to deploy the CDN service with this name, behind the scenes.


    Friday, July 13, 2018 11:59 AM
  • It seems like the only way to go, if there should be ever any explanation. I will wait for Travis now and then go for Azure Support.

    Thank you, George!

    Friday, July 13, 2018 1:10 PM
  • Hello Honza,

    Can you try to deploy the CDN Profile again? I tested it and created successfully.

    I removed all the resources. Go for it!


    Tuesday, July 17, 2018 11:48 AM
  • Hello George,

    This is even more interesting now and it leads me to believe that the problem is hidden somewhere in my resource group or subscription I am trying to deploy to, as otherwise you would not be able to create this endpoint name.

    I already tried deleting the CDN profile and deploying everything from scratch, I even waited for 12 hours before the attempt to redeploy it. Sadly, it failed immediately again.

    Travis has contacted me through e-mail, so I will now follow with Azure Support and let you know the result.

    Many thanks for all your help!

    Jan

    Tuesday, July 17, 2018 12:16 PM
  • Hello Jan, 

    Ιs there any progress with the problem you are experiencing?

    Tuesday, July 24, 2018 6:45 AM
  • Hello George,

    So far nothing, as I have to solve some pressing matters. I will inform you as soon as there is any development.

    Tuesday, July 24, 2018 6:54 AM
  • Hello Jan,

    Any update?


    Please, If you think your question has been answered click "Mark as Answer" if just helped click "Vote as helpful". This can be beneficial to other community members reading this forum thread.

    Friday, September 7, 2018 11:26 AM
  • Hello George,

    As I haven't reported it still, I tried to create the endpoint again a few minutes ago. And strangely, everything worked without any issues. To be honest, I am quite happy that I do not have to solve it anymore, as it became non-pressing and these types of problems tend to never be solved;)

    So, sadly, no explanation available, just the everlasting "time solves everything":(

    I am closing this and hope it will never happen again.

    Thanks for all your help! That of course counts for Travis as well.

    Friday, September 7, 2018 11:46 AM