locked
Is there any reason why the Publish wizard does not appear?

    Question

  • When you click Publish the build process starts and after a while the following error message appears,

    Error    1    The "SetConnectionString" task was not given a value for the required parameter "ConnectionString".    C:\Program Files\MSBuild\Microsoft\VisualStudio\LightSwitch\v1.0\Microsoft.LightSwitch.targets    442    10    TestDeploy2


    mysorian
    Monday, March 07, 2011 6:22 PM

All replies

  • Hi, have a look at this previous thread in case it is useful:

    http://social.msdn.microsoft.com/Forums/en/lightswitchgeneral/thread/b856d713-3b4c-4b41-99dd-7bf397aa059f

    By the way: did you install SP 1 Beta for Visual Studio 2010?


    Alessandro Del Sole
    Microsoft MVP - Visual Basic: development
    http://community.visual-basic.it/alessandro/
    Monday, March 07, 2011 7:01 PM
  • I have gone through the link mentioned in your post. All this on my Windows 7 Ultimate machine

    I did install recently an upgrade that installed upgraded Silverlight 4 tools shown here:

    http://hodentek.blogspot.com/2011/02/your-microsoft-lightswitch-program-may.html

    I have only the VS LightSwitch Beta 1 and Visual Web Developer Express on this machine and I am not sure if I installed SP1.

    Is SP1 needed for Beta1?

     

    --------------------------

    I have VS LightSwitch on the Windows XP SP3 machine and the Publish Wizard comes up promptly.


    mysorian
    Monday, March 07, 2011 8:15 PM
  • SP1 is not needed for Beta1.

    Jayaram, please could you verify by creating a new project and then try launching Publish Wizard.

    Monday, March 07, 2011 8:34 PM
  • I thought so reading the documentation of SP1.

    My observations are as follows:

    on the Windows 7 machine:

    For both Windows Authentication as well as Forms authentication I have not been able to bring up the wizard

    I have since repaired LS and tried again. Not successful, the same message-"SetConnectionString"

    -------------------------------------------------------------------------------------------

    In Windows XP with SP3:

    Authentication disabled 2 tier deployment works

    Forms Authentication 2 tier deployment works but in the IDE any attempt to manage users brings up this error message:

    An attempt to attach an auto-named database for file C:\...\DevelopmentDatabase.mdf failed. A database with the same name exists, or specified file cannot be opened,or it is located on UNC share.(Is this the default behavior?)

    Windows authentication: Specify authentication information page of the wizard, choosing deployment authentication credentials (full name/user name: same  as Windows login) the 'Publish' button is disabled but the other option let's you proceed but the deployed application fails to open (access error). Perhaps the SQL Server express may need to be set for mixed(sql and windows) mode.

    Any help on this is appreciated.

     

     


    mysorian
    Monday, March 07, 2011 10:27 PM
  • Finally removed Microsoft LightSwitch completly and reinstalled it.

    Tried to publish the error persists:

    The error message is pointing to this piece,

    <

     

     

    SetConnectionString ConfigFile="%(_ConfigFile.Identity)"

     

     

     

    Name="$(ConnectionStringName)"

     

     

     

    ConnectionString="$(_PublishConnectionString)"

     

     

     

    ProviderName="$(ConnectionProvider)"

     

     

     

    Condition=" '@(_ConfigFile)' != '' " />

    I am not sure if Windows 7 SP1 is responsible for this and I am wondering what next!

    Any suggestion will be appreciated.


    mysorian
    Tuesday, March 08, 2011 3:00 PM
  • Tried with Windows XP SP3 Compatibility settings and no success in waking up the Publish wizard.

     


    mysorian
    Wednesday, March 09, 2011 11:36 AM
  • I also had this problem with two of my machines.   I ended up reinstalling the OS on one machine and ran the VS reset on the other machine.

    http://msdn.microsoft.com/en-us/library/ms247075.aspx

    Making sure that everything is installed just right with Beta 1 has been very tough for me.  I have not touched anything with 5 of my LS computers for months now.

    I keep my fingers crossed and wait for Beta 2.

    Thursday, March 10, 2011 9:30 PM
  • I know you went about hunting a solution for this for almost a month last year. It's frustrating.

    mysorian
    Thursday, March 10, 2011 9:37 PM
  • I log this one as a definite bug. I did try in a 6 year old computer with Windows XP Media Center with SP3 and the publisher shows up although everything is painfully slow.
    mysorian
    Saturday, March 12, 2011 9:38 PM
  • Jayaram, The local SQL Express needs to have mixed SQL mode enabled.
    Friday, March 18, 2011 6:06 PM
  • Jayaram, Do you see the wizard pop up ? If yes, could you please let me know what is the connection string shown in the wizard ?

     

    Friday, March 18, 2011 6:07 PM
  • I wish I could ,but Beta 1 is now history, I will go after another wizard.

    Thanks


    mysorian
    Friday, March 18, 2011 6:19 PM
  • Jayaram, Please try out the Beta2 version and let me know if you are still running into the same problem.

     

    Friday, March 18, 2011 9:28 PM
  • Thanks

    In Beta 2 publishing a 2 -tier  worked without a problem, but installing Beta 2 presented quite a challenge.

    Also re-publishing a 2-tier application did not work as expected. I have another post on this in the forum.


    mysorian
    Monday, March 21, 2011 2:28 PM