locked
Thread pool settings: Dash board Vs Registry RRS feed

  • Question

  • I ran the BPA against BizTalk 2010 environment, it suggested/warning the thread pool settings of host instance.

    I changed these values on the dash board(Settings\Host Instance\.NET CLR tab\Threading Settings group), and restarted the host instance, ran the BPA again, but still it showed up the same warning again, and also registry didn't have these settings.

    I expected that once I made changes in the dash board,it is going to write to registry, and BPA will not show up this warning, but it didn't happen.

    So, are these two things differnt or am I missing something else?

    Thanks

    Tuesday, January 10, 2012 6:27 PM

Answers

  • Hello gentlemen -

    Two things:

    1. In BizTalk 2010, the registry is no longer used. For host instance settings (like these .Net CLR values), Settings Dashboard updates the adm_HostInstanceSetting table in the BizTalkMgmtDb database. You can return the rows of this table to see your configured values.

    2. You're not crazy :). I can reproduce the issue with BPA. In Settings Dashboard, I changed the .Net CLR thread settings for a host instance and restarted the host instance. The BPA report shows the same warning.


    I am looking into this and am following up with the BizTalk product group. I will keep you posted.


    Thanks!

    Mandi Ohlinger [MSFT]

    • Proposed as answer by Biztalk-learner Thursday, January 12, 2012 4:37 AM
    • Marked as answer by Bhava Friday, January 13, 2012 5:56 PM
    Thursday, January 12, 2012 1:24 AM
    Moderator

All replies

  • What was the exact error you got in BBPA?

    There are numoures thread settings you can modify in BizTalk, BBPA will not give you warnings on a default setup. However you might have changed some settings, and that is why you are getting this error. look at my attached screenshot to see default settings:

    These settings are modifyed under the host, and not the host instance.

    If you however have more information in the error from BBPA I can assist you some more.

    Best regards

    Tord Glad Nordahl
    Bouvet ASA, Norway
    http://www.BizTalkAdmin.com |@tordeman

    Please indicate ”Mark as Answer” if this post has answered the question.

    Tuesday, January 10, 2012 6:50 PM
  • Thank you for the response.

    Here is the screen shot of warning I was referring above. These for host instance,not the host.

    Thanks

    Tuesday, January 10, 2012 7:31 PM
  • Ahh, I see. you can change these settings, read the topic called Define CLR Hosting thread values for BizTalk Host instances you can edit these settings simply from the admin console, you should not try to modify these in the registry. If you get errors on these try to restore them back to basic, check this link for updated information. The default view is like this:

    remember to restart the host for the changes to take effect.

    Hope this helps you out a bit.

    Best regards

    Tord Glad Nordahl
    Bouvet ASA, Norway
    http://www.BizTalkAdmin.com |@tordeman

    Please indicate ”Mark as Answer” if this post has answered the question.

    Tuesday, January 10, 2012 7:51 PM
  • Yes, as I mentioned in my first post, I changed these values using GUI itself.

    I'm trying to find out why does BPA shows again even after the changes (and what registry setting does this effect)?

    Tuesday, January 10, 2012 8:40 PM
  • Did you restart your Host Instance?

    The settings should take affect after the restart. However I am not sure where this data is stored now, on the page i linked to it states the following as a note:

    noteNote
    If BizTalk is upgraded from a previous version, the values in the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\BTSSvc$hostname\CLR Hosting registry key will be set in Settings Dashboard.

     

    but I cant seem to find them there in 2010. Allthough they may be stored there somewhere. If none of the tips above helps try rebooting the machine to see if that works, then you might want to create a ticket towards Microsoft if this is a problem causing issues in your environment

    Best regards

    Tord Glad Nordahl
    Bouvet ASA, Norway
    http://www.BizTalkAdmin.com |@tordeman

    Please indicate ”Mark as Answer” if this post has answered the question.

    Tuesday, January 10, 2012 8:51 PM
  • ok,

    I already restarted host instances and rebooted 1 of the 2 servers, still there is no change. I verified the registry on the server rebooted.
    Ticket, ok, let me look into it.

    Thanks

    Tuesday, January 10, 2012 9:03 PM
  • Hello gentlemen -

    Two things:

    1. In BizTalk 2010, the registry is no longer used. For host instance settings (like these .Net CLR values), Settings Dashboard updates the adm_HostInstanceSetting table in the BizTalkMgmtDb database. You can return the rows of this table to see your configured values.

    2. You're not crazy :). I can reproduce the issue with BPA. In Settings Dashboard, I changed the .Net CLR thread settings for a host instance and restarted the host instance. The BPA report shows the same warning.


    I am looking into this and am following up with the BizTalk product group. I will keep you posted.


    Thanks!

    Mandi Ohlinger [MSFT]

    • Proposed as answer by Biztalk-learner Thursday, January 12, 2012 4:37 AM
    • Marked as answer by Bhava Friday, January 13, 2012 5:56 PM
    Thursday, January 12, 2012 1:24 AM
    Moderator
  • Thank you Mandi for your response.
    Please update once you find it out.

    Thanks
    Kishore

    Friday, January 13, 2012 5:56 PM
  • Hi Kishore -

    This behavior may be fixed in BizTalk 2010 R2. If you need this fixed in BizTalk 2010, it's best to open a support case for additional information. There will be a charge but it should be refunded; this is clearly a bug.

    Thanks!

    Mandi Ohlinger [MSFT]

    Sunday, June 3, 2012 8:52 PM
    Moderator