locked
Get-AzMetric sporadically refuses to return results RRS feed

  • Question

  • Executing request below expected to return total BlobCapacity which is available in UI is failing to return via Azure powershell

    Running request below refuses to return data even though this data is available in UI and expected to be available

    PS /home/admgregory_a> (Get-AzMetric -ResourceId '/subscriptions/5f***********4db790171/resourceGroups/KoreaCentralCommVault/providers/Microsoft.Storage/storageAccounts/commvaultna/blobServices/default' -MetricName 'BlobCapacity').Data
    
    
    TimeStamp : 4/5/19 10:28:00 PM
    Average   :
    Minimum   :
    Maximum   :
    Total     :
    Count     :

    After a couple of minutes it will just start working on it's own

    PS /home/admgregory_a> (Get-AzMetric -ResourceId '/subscriptions/5f5**************b790171/resourceGroups/KoreaCentralCommVault/providers/Microsoft.Storage/storageAccounts/commvaultna/blobServices/default' -MetricName 'BlobCapacity').Data
    
    
    TimeStamp : 4/5/19 10:31:00 PM
    Average   : 190807593709626
    Minimum   :
    Maximum   :
    Total     :
    Count     :





    Friday, April 5, 2019 11:30 PM

All replies

  • Apologies for the delayed response!

    @artisticcheese, I have tested at my end and this is a known issue when using the Get-Azmetric cmdlet to get the details of storage metrics will give you the delayed output sometimes.

    You may leave your feedback here. All the feedback you share in these forums will be monitored and reviewed by the Microsoft engineering teams responsible for building Azure.

    Kindly, let us know if you need any further assistance on this.


    Tuesday, April 9, 2019 8:46 AM
  • The Powershell cmdlet is owned by Azure Monitor. Please file a support ticket for the investigation and fix.
    • Edited by FrancisMS Thursday, April 11, 2019 10:46 PM
    Thursday, April 11, 2019 10:46 PM