none
Creating Project site failed | Project server 2013 RRS feed

  • Question

  • Hi Team,

    I am unable to create a new project in project server 2013, there is not creating project site and giving some site create failed message like:

    CreateWssSiteContent: Creating project site failed! Project Uid=f3701e23-690d-47ce-a47e-52c597664675, site URL=https://sites/PWA/LCT, site name=LCT. Microsoft.SharePoint.SPException: The site template requires that the Feature {bcdf4375-56b2-4fc6-badb-55aecedf93c0} be installed in the farm or site collection.   at Microsoft.SharePoint.Utilities.SPUtility.ThrowSPExceptionWithTraceTag(UInt32 tagId, ULSCat traceCategory, String resourceId, Object[] resourceArgs)   at Microsoft.SharePoint.SPWebTemplateElement.VerifyFeatures(XmlNodeList xmlNodeFeatures, SPWeb applyTemplateToThisWeb, SPFeatureScope featureScope, SPFeatureDependencyErrorBehavior featureDependencyErrorBehavior, List`1& featureDependencyErrors)   at Microsoft.SharePoint.SPWebTemplateElement.VerifyFeaturesInWebTemplate(SPWeb applyTemplateToThisWeb, SPFeatureDependencyErrorBehavior featureDependencyErrorBehavior, ICollection`1& featureDependencyErrors)   at Microsoft.SharePoint.SPWeb.LoadFeatureWebTemplateContent(SPFeatureWebTemplate featureWebTemplate, SPFeatureDependencyErrorBehavior featureDependencyErrorBehavior, ICollection`1& featureDependencyErrors)   at Microsoft.SharePoint.SPWeb.ProvisionWebTemplate(SPWebTemplate webTemplate, String webTemplateToUse, SPFeatureWebTemplate featureWebTemplate, Page page, SPFeatureDependencyErrorBehavior featureDependencyErrorBehavior, ICollection`1& featureDependencyErrors)   at Microsoft.SharePoint.SPWeb.ApplyWebTemplate(SPWebTemplate webTemplate, Page page, SPFeatureDependencyErrorBehavior featureDependencyErrorBehavior, ICollection`1& featureDependencyErrors)   at Microsoft.SharePoint.SPSite.CreateWeb(String strUrl, String strTitle, String strDescription, UInt32 nLCID, String strWebTemplate, Boolean bCreateUniqueSubweb, Boolean bConvertIfThere, Guid webId, Guid rootFolderId, Boolean createSystemCatalogs, Guid appInstanceId, String appWebDomainId)   at Microsoft.SharePoint.SPSite.SPWebCollectionProvider.CreateWeb(String strWebUrl, String strTitle, String strDescription, UInt32 nLCID, String strWebTemplate, Boolean bCreateUniqueSubweb, Boolean bConvertIfThere, Guid appInstanceId)   at Microsoft.SharePoint.SPWebCollection.Add(String strWebUrl, String strTitle, String strDescription, UInt32 nLCID, String strWebTemplate, Boolean useUniquePermissions, Boolean bConvertIfThere, Guid appInstanceId)   at

    Microsoft.Office.Project.Server.BusinessLayer.AdminProjectSiteAllocator.CreateSPWeb(ProjectSiteConfigurationInfo configInfo, SPSite topSite):
      • WSSCreateSiteFailure (16400). Details: id='16400' name='WSSCreateSiteFailure' uid='cdbe7f15-ce10-e811-8191-005056a12815' projectUID='f3701e23-690d-47ce-a47e-52c597664675' workspaceUrl='https://site/PWA/LCT' projectWorkspaceName='LTC'.
    • Queue:
      • GeneralQueueJobFailed (26000) - CreateWssSite.CreateWssSiteMessage. Details: id='26000' name='GeneralQueueJobFailed' uid='cebe7f15-ce10-e811-8191-005056a12815' JobUID='b2b9e40c-ce10-e811-8191-005056a12815' ComputerName='ca844884-2bef-41ce-8f50-0ee81fae78b3' GroupType='CreateWssSite' MessageType='CreateWssSiteMessage' MessageId='1' Stage='' CorrelationUID='781d4a9e-35f8-a001-02d8-02b12f1d9161'. For more details, check the ULS logs on machine ca844884-2bef-41ce-8f50-0ee81fae78b3 for entries with JobUID b2b9e40c-ce10-e811-8191-005056a12815.

    Request you to please help me where I am doing wrong and what should required to do for the resolution.


    Harjinder kumar SharePoint Developer


    Wednesday, February 14, 2018 1:24 PM

Answers

  • Ahh.  Fun with Project Sites.

    So - here are my suggestions.

    1. Always ensure that you start your project site templates from the Microsoft default Project Site.  NO other site will do.

    2. do not remove any of the out of the box content.

    3. If you are copying this template from one environment to another, then all the active "features" must match in both environments.

    you may use PowerShell to determine the feature that is being referenced.

    Get-SpFeature -Identity <paste guid here from error:> Feature {bcdf4375-56b2-4fc6-badb-55aecedf93c0} 

    You can attempt to activate this feature if it is found on the current env.

    Enable-SPFeature -Identity <same>

    This however, is not the best method to troubleshoot. 

    Go back to the Default template, make your mods, carefully, and save as template again, test the new template and see where you may have gone awry.

    Hope this helps,

     


    Thanks, Eric S. Pcubed

    Thursday, April 5, 2018 8:35 PM