locked
Run .net 2.0 setup in .net 1.1, 2.0, 3.5, 4.0 framwork RRS feed

  • Question

  • I have created the windows based application using VS 2008 (3.5 framework).

    When I try to setup the exe in the client machine, I found different frame work in client machine... facing problem here...

    Many of my clients have only 1.1

    Few clients have 1.1 and 2.0 framework

    Few clients have only 2.0

    Few clients have 3.5 only ( only 3.5 so I have installed my exe)

    Few clients have 3.5 and 4.0

    Few clients have 4.0 only

    Few clients have 2.0, 3.5 and 4.0

    Can you please help to solve this problem?

    Wednesday, August 17, 2011 11:19 AM

Answers

  • If your application requires .NET Framework 3.5, you need to add a conditional step to your installer (deployment project) in your solution to check for .NET Framework 3.5 and install it if not found.

    http://support.microsoft.com/kb/324733

    The complication is that .NET Framework 3.5 is not a full framework. It is an extension of .NET Framework 2.0.

    So, what your users need to support your app is .NET Framework 2.0 (the base, full, framework), and .NET Frameworks 3.0 and 3.5 (extensions to .NET Framework 2.0).

    You have no clients that have 3.5 only, as 3.5 CANNOT be installed unless 2.0 and 3.0 are already present. You should also be aware that Windows 7 installs .NET Framework 2.0/3.0/3.5 as part of the OS, so no framework install is needed for your app on Win 7 systems.

    Other framework versions, 1.0, 1.1 and 4.0 are separate and independent full frameworks. They have no bearing on your issue at all.

    Fortunately, there is a cumulative update available from Microsoft to make your life easier. It will detect what frameworks are installed (2.0, 3.0 and 3.5 only) and add those pieces needed to bring a machine up to .NET Framework 3.5 SP1 (what your app needs).

    Here is the download you need:

    http://download.microsoft.com/download/2/0/e/20e90413-712f-438c-988e-fdaa79a8ac3d/dotnetfx35.exe

    If you have further questions, please post back.

     



    • Marked as answer by Gopi R Thursday, August 18, 2011 1:51 AM
    Wednesday, August 17, 2011 1:33 PM

All replies

  • If a client has .Net frame work 4 this means that he has all of them (.net framework 2.0 - 4.0 ).

    take an example

    If you create a application in .net framework 3.5 it will work on .net framework 3.5 and all the frameworks above 3.5 ( 4.0 ) but not below 3.5.

    Basically the .net framework3.5 and 4 are the extension of 2.0. so if your application uses 2.0 and your client have 2.0 or above .net framework then you will not have any problem of .net framework in installation or running application


    Please mark those posts as answer which answers your question. Faraz
    • Proposed as answer by Esref Durna Wednesday, August 17, 2011 12:26 PM
    Wednesday, August 17, 2011 11:40 AM
  • If your application requires .NET Framework 3.5, you need to add a conditional step to your installer (deployment project) in your solution to check for .NET Framework 3.5 and install it if not found.

    http://support.microsoft.com/kb/324733

    The complication is that .NET Framework 3.5 is not a full framework. It is an extension of .NET Framework 2.0.

    So, what your users need to support your app is .NET Framework 2.0 (the base, full, framework), and .NET Frameworks 3.0 and 3.5 (extensions to .NET Framework 2.0).

    You have no clients that have 3.5 only, as 3.5 CANNOT be installed unless 2.0 and 3.0 are already present. You should also be aware that Windows 7 installs .NET Framework 2.0/3.0/3.5 as part of the OS, so no framework install is needed for your app on Win 7 systems.

    Other framework versions, 1.0, 1.1 and 4.0 are separate and independent full frameworks. They have no bearing on your issue at all.

    Fortunately, there is a cumulative update available from Microsoft to make your life easier. It will detect what frameworks are installed (2.0, 3.0 and 3.5 only) and add those pieces needed to bring a machine up to .NET Framework 3.5 SP1 (what your app needs).

    Here is the download you need:

    http://download.microsoft.com/download/2/0/e/20e90413-712f-438c-988e-fdaa79a8ac3d/dotnetfx35.exe

    If you have further questions, please post back.

     



    • Marked as answer by Gopi R Thursday, August 18, 2011 1:51 AM
    Wednesday, August 17, 2011 1:33 PM