none
How are targeted versions affected in new Framework Support Lifecycle Policy Change starting April 2011 RRS feed

  • Question

  • Hopefully this is the right forum, I searched and wasn't really sure where to put this.

    In about a month the Support Lifecycle changes for the .NET Framework as referenced here http://support.microsoft.com/gp/lifeandotnet

    We are trying to determine if we need to upgrade our applications or not and have gotten quite confused.

    We have a number of web applications that target the 2.0 framework.  We also have Framework 3.5 SP1 installed on our web server.  3.5 SP1 uses the same CLR version 2.0 as Framework 2.0.  Because we have 3.5 SP1 installed, does that mean our applications that target 2.0 will still be covered under the new support lifecycle? 

    Would the same apply to a web application that targets 3.5 that references a class library DLL that targets 2.0?

    Thank You.

    Friday, March 11, 2011 6:58 PM

All replies