locked
Unable to Publish - Integrated Security = True RRS feed

  • Question

  • I am unsuccessfully trying to remotely publish LS app to a web server configured with Web Deploy and other requirements as I understand them from Visual Studio 2012 IDE. However, that server config is of little interest at this point since I am stuck on my development machine with a build error for Integrated Security.

    The LS v2 Publish Application Wizard has a built in mouse over icon that states 'Connection string must not use integrated security'.  Unfortunately my app build string resulting from my build has Integration Security = True.   At this time I am new enough to LS that I do not know what I have configured or set up to that results in my disallowed integrated security attribute. Because of this I am stuck and can not deploy (have not tried to deploy by Package yet).

    This puzzles me because I see in the MS videos (Beth Massi) that she has integrated security used without issue, in fact I could not find any videos that did not have integrated security in them (they are all older than my v2 w/HTML upgrade Visual Studio).

    If integrated security is not allowed for User Connection string then does someone happen to know what a connection string looks like that is allowed?

    Thanks much for any assistance.

    znjohn

     
    Monday, June 3, 2013 10:23 PM

All replies

  • For remote publish to IIS, I suggest you to use SQL Authentication in connection string. You may use Integrated Authentication too. But that would require some changes to IIS. Please see the discussion at: Integrated Security=True on Database connection not allowed?

    You mentioned about a build error. Is this error about a connection string for an attached datasource? Please could you provide more detail about the error?

    Thanks,

    Ravi

    Tuesday, June 4, 2013 3:12 AM
    Moderator
  • Thank you Ravi for the reply and your suggestion. I had already read the link you provided and concluded that it involved security db requirements that my build did not have and thus the answer did not seem to apply.

    I think your other thought about using SQL Authentication is probably what I will need to do as a work around. I will report back here on my results in a day or two. I had not tried this so far because I understood that the security on this type connection would not be as strong.

    I am still a bit puzzled about the Publish Wizard seems to lead a regular web app build like mine directly to Integrated Security and then does not allow it. Because of that I suspected that it was something that I was configuring incorrectly.

    Regardless of this issue, I am very impressed by the design and functionality of LS and I'm more than willing to wade through these issues as the tool matures.

    Kind regards,

    Tuesday, June 4, 2013 4:21 AM
  • I have an update on my issue.

    I have not yet been able to publish remotely but I was successful in publishing locally and I used Windows Authentication. Strangely enough, the local connection string uses integrated security.

    This is a big step forward on this issue and I will again try SQL Authentication for remote.

    Thanks again for your thoughts on this problem.

    Thursday, June 6, 2013 3:22 AM