none
Mouse pointer not moving after installing QFE 2013 RRS feed

  • Question

  • Hello All, 

    I installed QFE  cumulative 2013 and rebuilt the project successfully (VIA x86). After transferring the image to the target device the mouse pointer (arrow) appears in the top left corner and doesn't move when the actual mouse moves.

    If I right-click on the mouse, the menu appears on the screen at different locations, which means that the mouse is working (it is just that the pointer doesn't follow).

    Any idea would be highly appreciated.

    Thanks!

    Monday, April 21, 2014 4:09 AM

All replies

  • check whether SYSGEN_CURSOR is enabled in your OSDesign solution.

    Some display controllers/driver support hardware cursor.Also check whether your display driver supports hardware cursor and which you may required to enable it (through registry or something else depend on the BSP)


    Please mark as answer, if it is correct.
    Please vote,if it is helpful post.
    Vinoth.R

    http://vinoth-vinothblog.blogspot.com
    http://www.e-consystems.com/windowsce.asp


    Monday, April 21, 2014 9:02 AM
  • Hello,

    Yes, SYSGEN_CURSOR is enabled. I also disabled it to see if the mouse cursor would go away but it still shows up. Prior to the QFE update, the same BSP was handling correctly the mouse.

    I also tried moving the cursor outside the screen area or hiding through the API but nothing works.

    Thanks!

    Monday, April 21, 2014 2:27 PM
  • I also tried adding touch support and disabling the cursor.

    SYSGEN_TOUCH =1

    SYSGEN_CURSOR = 0

    and 

    [HKEY_LOCAL_MACHINE\System\GDI\Drivers]
    "Cursor"=dword:0 ;0 for disabling mouse cursor and 1 for enabling cursor

    Clean sysgen, but the mouse pointer still shows up.

    Any ideas?

    Monday, April 21, 2014 6:51 PM
  • SYSGEN_CURSOR should be enabled, the registry is "Cursor"=dword:1. Try this and let me know

    Please mark as answer, if it is correct.
    Please vote,if it is helpful post.
    Vinoth.R

    http://vinoth-vinothblog.blogspot.com
    http://www.e-consystems.com/windowsce.asp

    Tuesday, April 22, 2014 5:39 AM