none
Metro Causing certain tests to fail RRS feed

  • Question

  • I have noticed that certain tests fail if the metro interface/start screen is up.  A quick test to run and see this happening is under the Display adapter category "DXGI Gamma Ramps" (takes about 15 seconds to run) it seems there is a preparation sub test that runs before that is supposed to show desktop but is not working.  The Sub test is called ShowDesktop.  This sub test simply runs and passes but does not actually show the desktop.  It runs an executable called "HCKShowClassicDesktop.exe".  Running this sub test on it's own without the parent also does not show the desktop on a metro showing system.

      We have noticed other tests that also have this issue since the show desktop is part of the sub tests and does not do what it is supposed to do.

    Please help.

    Wednesday, January 30, 2013 7:54 PM

Answers

  • Are you running the final released version of the Win8 OS?   This could be caused by signing issues.  Though you usually get a cryptic error dialog for signing problems.  It'll read:

       "A referral was returned form the server"

    Another possibly...

    If you have disabled UAC (LUA) via group policy, re-enable it. Set it to "Never Notify" mode if you must run your tests with UAC disabled.

      • Set HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System\EnableLUA = 1 to turn UAC on
      • Set HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System\ConsentPromptBehaviorAdmin = 0 to turn on "Never Notify" mode.

    The HCKShowClassicDesktop.exe tool does have restrictions placed on it.   It will only work if properly signed.  Which if you are running an official OS and HCK build, it will be.   It must be run from a Windows folder.  The HCK job will do the right thing here, but if you explore running it by hand you'll need to be aware of this.   It also requires that the HCK client software be running on the machine, which of course, it will be when from the HCK.

    Olan Hanley

    Developer Experience - Graphics

    Microsoft Corporation

    • Marked as answer by JB-Matrox Friday, February 1, 2013 1:40 PM
    Thursday, January 31, 2013 9:31 PM

All replies

  • Of course I failed to mention when in Desktop mode the test passes and in Metro mode the test fails.  I am running HCK version 8.59.29757 (QFE Update 007).

    We can't be the only ones seeing this??

    Wednesday, January 30, 2013 8:16 PM
  • Are you running the final released version of the Win8 OS?   This could be caused by signing issues.  Though you usually get a cryptic error dialog for signing problems.  It'll read:

       "A referral was returned form the server"

    Another possibly...

    If you have disabled UAC (LUA) via group policy, re-enable it. Set it to "Never Notify" mode if you must run your tests with UAC disabled.

      • Set HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System\EnableLUA = 1 to turn UAC on
      • Set HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System\ConsentPromptBehaviorAdmin = 0 to turn on "Never Notify" mode.

    The HCKShowClassicDesktop.exe tool does have restrictions placed on it.   It will only work if properly signed.  Which if you are running an official OS and HCK build, it will be.   It must be run from a Windows folder.  The HCK job will do the right thing here, but if you explore running it by hand you'll need to be aware of this.   It also requires that the HCK client software be running on the machine, which of course, it will be when from the HCK.

    Olan Hanley

    Developer Experience - Graphics

    Microsoft Corporation

    • Marked as answer by JB-Matrox Friday, February 1, 2013 1:40 PM
    Thursday, January 31, 2013 9:31 PM
  • I had UAC disabled.  I enabled it and presto it works now.  I had disabled UAC so that we could install our drivers via scripts via the HCK.  I have never used the Never notify of the "ConsentPromptBehaviorAdmin" key.  What happens if we try to launch a script?   Will it just not let it launch and not notify? 

    Why does the show desktop need UAC to be enabled?

    JB

    Friday, February 1, 2013 1:44 PM
  • I'm glad that fixed things.  I think this is the second time someone has run into this.  I'll see if there's a reasonable means for adding this to the HCK documentation.

    Disabling UAC turns off all the security stuff, so every process runs with the same level of privilege. HCKShowClassicDesktop.exe MUST run with higher privileges to work correctly. The "Never Notify" option leaves the UAC checks in place, but just stops that dialog from appearing.   I think that's all you need to keep your scripts fully automated.

    Apologies for the trouble.

    Olan Hanley

    Developer Experience - Graphics

    Microsoft Corporation

    Friday, February 1, 2013 9:39 PM