locked
HTTP SSL service? RRS feed

  • Question

  • User-1315876141 posted

     I got SSL-sertificate from my hosting support. 3 files .crt .csr .key

     I tried to install it and now.

     On IIS Default Web Site -> Properties -> Directory Security -> Secure communications -> View Certificate -> Shows certificate fine

    But how do I configure SSL service. It may be installed, but it doens't seem to work at all.

     http://host,com shows pages like before, but when I use https://host,com I just get error.

    Support suggested that I check, if HTTP SSL service is runnig, but I can't even find it. Those tutorials I found doesn't even mentioned HTTP SSL service, so how I enable and use it.

     I followed tutorials, like:
    http://www.petri.co.il/configure_ssl_on_your_website_with_iis.htm

    http://www.windowsecurity.com/articles/Client-Certificate-Authentication-IIS6.html
    http://www.rapidssl.com/ssl-certificate-support/install-ssl-certificate/microsoft_IIS_5.htm
     

    Monday, February 11, 2008 10:20 AM

Answers

  • User989702501 posted

    Try
    PRB: Error "Page Cannot Be Displayed" When You Connect Through HTTPS
    http://support.microsoft.com/?id=290391

    HOW TO: Determine If SSL Connectivity Is Not Working on the Web Server or on
    an Intermediate Device
    http://support.microsoft.com/?id=290051

    "Cannot find server" or "DNS" Errors When Using SSL (Q & A)
    http://support.microsoft.com/?id=292296

    at command prompt, enter
    "netstat -an", see anything binding on port 443 ?

    anything in event log ?

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Tuesday, February 12, 2008 10:32 PM
  • User209782248 posted

    You can mark your web site to require SSL (using inetmgr, select site, directory security, edit ..., require SSL checkbox), .  It sounds like you already did that for the root of the site, but you have a different setting for login.htm (and possibly other parts of your site). 

    Check login.htm to make sure it is also set to require SSL.

    You can optionally also remove the port 80 binding from your site, so that it is only available via the SSL binding on port 443. This way your users will just get a "server not found" error when they try to access your site over the non-SSL channel.

    Thanks,

    Mike Volodarsky

    Program Manager
    IIS Core Server
    Visit mvolo.com for more IIS 7.0 posts, tools, and info

     

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Thursday, February 14, 2008 2:03 PM

All replies

  • User209782248 posted

    Hi Masso,

    You need to create a binding that uses port 443 on your web site, and assign the SSL certificate there.

    If you have further problems, can you indicate what version of IIS you are running? 

    Thanks,

    Mike Volodarsky

    Program Manager
    IIS Core Server
    Visit mvolo.com for more IIS 7.0 posts, tools, and info

    Tuesday, February 12, 2008 1:20 PM
  • User-1315876141 posted

     IIS version is 6.0, can you tell more about how to make that binding.

    On default web site properties, SSL  port is set to 443.

    Tuesday, February 12, 2008 3:12 PM
  • User989702501 posted

    Try
    PRB: Error "Page Cannot Be Displayed" When You Connect Through HTTPS
    http://support.microsoft.com/?id=290391

    HOW TO: Determine If SSL Connectivity Is Not Working on the Web Server or on
    an Intermediate Device
    http://support.microsoft.com/?id=290051

    "Cannot find server" or "DNS" Errors When Using SSL (Q & A)
    http://support.microsoft.com/?id=292296

    at command prompt, enter
    "netstat -an", see anything binding on port 443 ?

    anything in event log ?

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Tuesday, February 12, 2008 10:32 PM
  • User-1315876141 posted

     Well, now it works partly.

     
    http://domain.com/

    Shows: The page must be viewed over a secure channel

     http://domain.com/login.htm

    Shows: Page normally, while there sould be that secure channel message

     https://domain.com/login.htm

    Shows: Page normally, there is that mini-long on bottom of browser.

     

    So, SSL-works, but while user can access same site without SSL-it doesn't do much security.
     

    Wednesday, February 13, 2008 7:57 AM
  • User209782248 posted

    You can mark your web site to require SSL (using inetmgr, select site, directory security, edit ..., require SSL checkbox), .  It sounds like you already did that for the root of the site, but you have a different setting for login.htm (and possibly other parts of your site). 

    Check login.htm to make sure it is also set to require SSL.

    You can optionally also remove the port 80 binding from your site, so that it is only available via the SSL binding on port 443. This way your users will just get a "server not found" error when they try to access your site over the non-SSL channel.

    Thanks,

    Mike Volodarsky

    Program Manager
    IIS Core Server
    Visit mvolo.com for more IIS 7.0 posts, tools, and info

     

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Thursday, February 14, 2008 2:03 PM