locked
This access control list is not in canonical form and therefore cannot be modified. error message when publishing LightSwitch web app RRS feed

  • Question

  • Hi,

    I am getting the error:

    Error 1 Web deployment task failed. (This access control list is not in canonical form and therefore cannot be modified.) C:\Program Files (x86)\MSBuild\Microsoft\VisualStudio\v11.0\Web\Microsoft.Web.Publishing.targets 4436 6

    when I attempt to publish my LightSwitch application to IIS 8 on my machine.  I am under Windows 8 and using VS 2012 professional. I installed web deploy 3 from web platform installer 4.

    The application publishes fine in two tier windows app. But either windows app from web server or web app from web server the above message occurs.

    Anyone know what causes this?

    Thanks

    Saturday, December 8, 2012 6:18 PM

Answers

  • This is probably that your account doesn't have permissions to the folder you're trying to publish to.  Try publishing to a different folder.
    • Marked as answer by Angie Xu Thursday, December 20, 2012 12:55 AM
    Tuesday, December 18, 2012 1:25 AM

All replies

  • This is probably that your account doesn't have permissions to the folder you're trying to publish to.  Try publishing to a different folder.
    • Marked as answer by Angie Xu Thursday, December 20, 2012 12:55 AM
    Tuesday, December 18, 2012 1:25 AM
  • Thanks. Will play around further with that
    Tuesday, December 18, 2012 4:34 AM
  • I fixed this by going into the IIS web server admin and seeing a node that the deployment started to make. I right-clicked on it and selected Edit Permissions, then I clicked on the Security tab. I then clicked the edit button and it came up with a message telling me to click ok to reorder the permissions. After it was done I right-clicked on the root node and selected refresh. I then closed Visual studio and tried the publish again.


    Unleash the Power - Get the LightSwitch HTML Client book

    http://LightSwitchHelpWebsite.com


    • Proposed as answer by ADefwebserver Thursday, February 6, 2014 6:52 PM
    • Edited by ADefwebserver Saturday, August 16, 2014 8:39 PM
    Thursday, January 16, 2014 7:30 AM
  • Had the same problem and your solution worked! Thanks!
    Thursday, February 6, 2014 6:40 PM
  • It worked for me too!!!!!
    Friday, June 20, 2014 2:16 AM
  • This was helpful! Thanks!!!

    Thursday, February 12, 2015 11:47 PM
  • Once again, you fixed my problem. Many thanks Michael!
    Wednesday, January 27, 2016 9:08 PM
  • Thanks. Having same problem and now its worked with your tip.

    Muhammad Idrees

    Tuesday, November 15, 2016 7:07 AM
  • Thanks, that worked for me.

    Thursday, July 6, 2017 11:34 AM