none
Exchange ActiveSync - SmartForward RRS feed

  • Question

  • Hi

    I use this command 'SmartForward' to forward a meeting request.

    I can get the forward mail with calendar sucessfully, but the 'Accept','Tentative','Decline',''Propse New Time' has not any option in the email of forwarding.

    So i do not response to organizer.

    Any answer is appreciated.

    Thanks!



    • Edited by MarkXie Tuesday, May 8, 2012 8:08 AM
    Tuesday, May 8, 2012 7:59 AM

Answers

  • Hi MarkXie,

    Based on the log you sent, you are using Exchange ActiveSync (EAS) 12.0 which is not covered by the Open Specification (i.e. [MS-ASCMD]).  One thing you are missing from this request, however, is iCalendar content.  This is required for supported versions of EAS 12.1 and greater. I don’t know if that will resolve the problem for version 12.0 but you might give it a try.

    Best regards,
    Tom Jebo
    Escalation Engineer
    Microsoft Open Specifications

    Tuesday, May 15, 2012 5:32 PM
    Moderator
  • The Exchange 2007 only has this problem, the Exchage 2010 is correct.
    • Marked as answer by MarkXie Friday, May 18, 2012 5:09 AM
    Friday, May 18, 2012 5:09 AM

All replies

  • Hi MarkXie,

    Thank you for your question.  A colleague will follow up with you to investigate this issue.

    Regards,

    Mark Miller | Open Specifications Support Team

    Tuesday, May 8, 2012 11:48 AM
  • Hi MarkXie,

    I'll look into this and get back to you shortly.

    Best regards,
    Tom Jebo
    Escalation Engineer
    Microsoft Open Specifications

    Wednesday, May 9, 2012 3:35 AM
    Moderator
  • Hi MarkXie,

    SmartForward or SmartReply do what Forward and Reply do to a meeting request.  The person receiving the forwarded or replied to meeting request becomes an "Optional Attendee" and because of that does not have the power to accept, decline or propose new time etc...   That power still lies with the original recipient of the meeting request.  Also, the originator of the meeting request gets notified that the new optional attendee is added to the attendee list.  So, this is by design.

    Tom

    Wednesday, May 9, 2012 5:03 AM
    Moderator
  • Hi Tom,

    Thank you for your reply quickly.

    But in my case I saw this person is 'Required Attendee' in the mail of the forwarded.

    My case is i received a meeting request from organizer and then forward this meeting request to another mailaccount by SmartForward of Exchange ActiveSync, but this mail of forwarding in the another mailaccount do not 'Edit the response before Sending','Send the response now' or 'Do not Send a response' of  the 'Accept','Tentative','Decline',''Propse New Time' in the outlook, because it has not any option for these functions in this mail.

    I forward this meeting request in the smartphone, the another mailaccount work on the Outlook 2010.

    Buf if i do the same things , forward this same meeting request from Outllook 2010, everything is ok all options can be choose in the another mailaccount in the Outlook 2010.

    So i do not know how to do it to make these functions can be used by 'SmartForward' .

    Thanks,

    Mark

    Wednesday, May 9, 2012 7:00 AM
  • Mark,

    Thanks for the additional information.  I'll look into this and get back to you.

    Tom

    Wednesday, May 9, 2012 4:29 PM
    Moderator
  • Mark,

    could you provide the XML request and response for me?  If you'd like, send it to dochelp at microsoft dot com and I will pick it up there.  Just reference this thread URL and my name.

    Tom Jebo

    Thursday, May 10, 2012 5:07 PM
    Moderator
  • Hi Tom,

    Below is Log which is use this command to forward a meeting request.

    -----------------
     Log Entry: 0
    -----------------

    RequestTime :
    05/03/2012 20:30:58

    ServerName :
    OOEEX2010

    AssemblyVersion :
    14.00.0694.000

    Identifier :
    2384CB8C

    RequestHeader :
    POST /Microsoft-Server-ActiveSync/default.eas?Cmd=SmartForward&User=ooe%5C2k10easunittest2&DeviceId=android1329896730712&DeviceType=Android&ItemId=5:2&CollectionId=5&SaveInSent=T HTTP/1.1
    Connection: keep-alive
    Content-Length: 296
    Content-Type: message/rfc822
    Authorization: ********
    Host: ooeex2010.ooe.qagood.com
    User-Agent: Android/0.3
    MS-ASProtocolVersion: 12.0


    RequestBody :
    Date: Fri, 04 May 2012 11:30:56 +0800
    Subject: Fwd: Test5046
    Message-ID: <d8e68cl4r40hhns796d9aw98.1336102256214@email.android.com>
    From: 2k10easunittest2@xxx.com
    To: 2k7ali100@xxx.com
    Content-Type: text/plain; charset=utf-8
    Content-Transfer-Encoding: base64

    MTExMjIyDQo=


    AccessState :
    Allowed

    AccessStateReason :
    Global

    ResponseHeader :
    HTTP/1.1 200 OK
    MS-Server-ActiveSync: 14.0


    ResponseBody :
    [No XmlResponse]

    ResponseTime :
    05/03/2012 20:30:58

     

    Thanks,

    Mark

    Friday, May 11, 2012 8:03 AM
  • Hi MarkXie,

    Based on the log you sent, you are using Exchange ActiveSync (EAS) 12.0 which is not covered by the Open Specification (i.e. [MS-ASCMD]).  One thing you are missing from this request, however, is iCalendar content.  This is required for supported versions of EAS 12.1 and greater. I don’t know if that will resolve the problem for version 12.0 but you might give it a try.

    Best regards,
    Tom Jebo
    Escalation Engineer
    Microsoft Open Specifications

    Tuesday, May 15, 2012 5:32 PM
    Moderator
  • The Exchange 2007 only has this problem, the Exchage 2010 is correct.
    • Marked as answer by MarkXie Friday, May 18, 2012 5:09 AM
    Friday, May 18, 2012 5:09 AM
  • Just to expand a little more: Check the properties on the calendar item to make sure that you have set them appropriately on the SmartForwarded message to avoid setting it when it's not meant to be set. Because EAS versions lower than 14.0 of EAS were just sending raw MIME, you would need to find a way to encapsulate the desired meeting properties within MIME, and iCal is likely the best way to do that.  The property that you are likely interested in setting isPidTagResponseRequested & make sure that the organizer is set to the original organizer to have new attendee send response to the right person.

    This property is referenced by example in [MS-OXCICAL] 2.1.3.1.1.20.2.5 (http://msdn.microsoft.com/en-us/library/ee218052(EXCHG.80).aspx)

    Tom

    Monday, May 21, 2012 3:09 AM
    Moderator
  • Hi Tom,

    Even i'm facing the same problem on Exchange 2007 mobile client(iOS) and below is my event forwarding request using sendMail command, but the problem is forwarded attendee will have accept/decline/tentative option, but if he respond to that event it will notify to the one who's  if forwarding than original attendee rather original organizer. Here is my request format. Please let me know if i'm missing

    URL: 
    https://host/Microsoft-Server-ActiveSync?Cmd=SendMail&User=optest2k7-06&DeviceId=528c8e6cd4a3c6598999a0e9df15ad32&DeviceType=Spectrum&SaveInSent=T


    Request Headers:
        Authorization = "Basic base64EncodedData...";
        "Content-Length" = 2287;
        "Content-Type" = "message/rfc822";
        "MS-ASProtocolVersion" = "12.1";
        "User-Agent" = "Spectrum/3.0.76BB107E";
        "X-MS-PolicyKey" = 3478028381;

    Request Body:
    From: =?UTF-8?B?b3AgdGVzdDJrNy0wNQ==?= <optest2k7-06@pim2k7.cbbcps.com>
    To: user3@domain
    Reply-To: user1@domain
    Sender: user2@domain
    Message-Id: <iOSd4f89b44a15b266b1e76add9b255b010@pim2k7.cbbcps.com>
    Subject: =?UTF-8?B?MTg3ODEtT1dBOQ==?=
    MIME-Version: 1.0
    Content-Transfer-Encoding: 7bit
    Content-Type: multipart/mixed; boundary=WjZWu1Kc3pryp7NCtzNpvoycq6N4

    --WjZWu1Kc3pryp7NCtzNpvoycq6N4
    Content-Type: text/html; charset=UTF-8
    Content-Transfer-Encoding: base64

    QmVnaW5zOiBEZWMgMjQsIDIwMTQsIDEyOjMwIFBNIA0KRW5kczogRGVjIDI0LCAyMDE0LCAxOjMw
    IFBNIA0KDQpJbnZpdGVlczogb3AgdGVzdDJrNy0wNiAob3B0ZXN0Mms3LTA2QHBpbTJrNy5jYmJj
    cHMuY29tKSwgIChvcHRlc3QyazctMDdAcGltMms3LmNiYmNwcy5jb20pDQo=
    --WjZWu1Kc3pryp7NCtzNpvoycq6N4
    Content-Type: text/calendar; charset=UTF-8; method=REQUEST
    Content-Dis
    Content-Transfer-Encoding: base64

    QkVHSU46VkNBTEVOREFSDQpWRVJTSU9OOjIuMA0KUFJPRElEOi0vL0NhbGVuZGFyLy9DYWxlbmRh
    ciBBcHAvL0VODQpDQUxTQ0FMRTpHUkVHT1JJQU4NCk1FVEhPRDpSRVFVRVNUDQpCRUdJTjpWVElN
    RVpPTkUNClRaSUQ6QXNpYS9Lb2xrYXRhDQpCRUdJTjpTVEFOREFSRA0KRFRTVEFSVDoyMDE0MTIy
    NFQxMjMwMDANClRaT0ZGU0VURlJPTTorMDUzMA0KVFpPRkZTRVRUTzorMDUzMA0KRU5EOlNUQU5E
    QVJEDQpFTkQ6VlRJTUVaT05FDQpCRUdJTjpWRVZFTlQNCk9SR0FOSVpFUjtDTj1vcHRlc3Qyazct
    MDVAcGltMms3LmNiYmNwcy5jb207U0VOVC1CWT0ibWFpbHRvOm9wdGVzdDJrNy0wNg0KIEBwaW0y
    azcuY2JiY3BzLmNvbSI6bWFpbHRvOm9wdGVzdDJrNy0wNUBwaW0yazcuY2JiY3BzLmNvbQ0KQVRU
    RU5ERUU7UlNWUD1UUlVFO1JPTEU9UkVRLVBBUlRJQ0lQQU5UOk1BSUxUTzpvcHRlc3QyazctMDdA
    cGltMms3LmNiYmNwDQogcy5jb20NCkxPQ0FUSU9OO0xBTkdVQUdFPWVuX1VTOkJhbmdhbG9yZQ0K
    U1RBVFVTOkNPTkZJUk1FRA0KRFRTVEFSVDtUWklEPUFzaWEvS29sa2F0YToyMDE0MTIyNFQxMjMw
    MDANCkRURU5EO1RaSUQ9QXNpYS9Lb2xrYXRhOjIwMTQxMjI0VDEzMzAwMA0KVFJBTlNQOk9QQVFV
    RQ0KU0VRVUVOQ0U6MA0KVUlEOjA0MDAwMDAwODIwMEUwMDA3NEM1QjcxMDFBODJFMDA4MDAwMDAw
    MDBBNEI4N0QxQjQ1MUZEMDAxMDAwMDAwMDAwMDAwDQogMDAwMDEwMDAwMDAwNjBCNzkyQkJFNUI0
    NkE0N0IxRDIwRDgxQzQzRDE2NzANCkRUU1RBTVA6MjAxNDEyMjRUMDY0NDQ2Wg0KQ1JFQVRFRDoy
    MDE0MTIyNFQwNjQ0NDZaDQpTVU1NQVJZOjE4NzgxLU9XQTkNCkJFR0lOOlZBTEFSTQ0KVFJJR0dF
    UjtSRUxBVEVEPVNUQVJUOi1QVDE1TQ0KQUNUSU9OOkRJU1BMQVkNCkRFU0NSSVBUSU9OOjE4Nzgx
    LU9XQTkgaW4gMTUgbWludXRlcw0KRU5EOlZBTEFSTQ0KRU5EOlZFVkVOVA0KRU5EOlZDQUxFTkRB
    Ug0K
    --WjZWu1Kc3pryp7NCtzNpvoycq6N4--


    • Edited by Pavan-iOS Wednesday, February 25, 2015 7:11 AM
    Thursday, December 25, 2014 4:21 AM