locked
Getting an "unable to Load the tables in the power pivot window" error RRS feed

  • Question

  • Hello,

    I have 2 worksheets in a excel file and would like to load both into a power pivot table. When I click the 'create linked table' in the pwer pivot ribbon, The powerpivot window open and looks like its about to load the data but then I get a popup dialogue box with the following error:

    Unable to load the tables in the powerpivot window 

    ============================
    Error Message:
    ============================

    The given key was not present in the dictionary.

    ============================
    Call Stack:
    ============================

       at System.ThrowHelper.ThrowKeyNotFoundException()
       at System.Collections.Generic.Dictionary`2.get_Item(TKey key)
       at Microsoft.AnalysisServices.Modeler.SheetTabs.PopulateSheetList(String selKey)
       at Microsoft.AnalysisServices.Modeler.SheetTabs.SetSelectedSheet(String key)
       at Microsoft.AnalysisServices.Modeler.ClientWindow.RefreshClientWindow(String tableName)

    ============================

     

    When I try again, there is a meesage saying the table is already linked but I dont see any data.

    has Anyone seen this error before and know what to do?

    Thanks,

    Nathan

    Wednesday, July 6, 2011 9:12 PM

Answers

  • Hi Nathan,

    The error occurs when you've created a new calculated field but have input an incorrect formula which gives an error (#ERROR), and have subsequently saved and exited the file.

    When you open the PowerPivot window the error will appear without the table showing. Go to the Diagram View and look for any (and all) table(s) which have a field with an error (or with an "!" symbol next to it). Right click and delete this field, save the file and exit the PowerPivot window. Reopen you're PowerPivot window and the error will be gone.

    Hope this helps.

    Hayden

    • Proposed as answer by Hayden E Friday, September 20, 2013 12:59 AM
    • Marked as answer by Olaf HelperMVP Monday, October 14, 2013 7:36 AM
    Friday, September 20, 2013 12:46 AM

All replies

  • Nathan,

    Could you provide a little more info on what version of PowerPivot you're using? If you could file a bug with Microsoft Connect at https://connect.microsoft.com/SQLServer/Feedback along with your workbook, we'd be happy to take a look at your issue.

    Best,

    Mark

    Monday, October 31, 2011 11:53 PM
  • Mark,

    Thanks for responding. It has been a while since I worked on this but I will try to recreate this issue and follow the steps you suggested and get back to you.

    In the meantime, I am running powerpivot version 10.50.1747.0

     

    Thanks!

    Nathan


    nmss18
    Tuesday, November 1, 2011 7:46 PM
  • Hi Nathan,

    The error occurs when you've created a new calculated field but have input an incorrect formula which gives an error (#ERROR), and have subsequently saved and exited the file.

    When you open the PowerPivot window the error will appear without the table showing. Go to the Diagram View and look for any (and all) table(s) which have a field with an error (or with an "!" symbol next to it). Right click and delete this field, save the file and exit the PowerPivot window. Reopen you're PowerPivot window and the error will be gone.

    Hope this helps.

    Hayden

    • Proposed as answer by Hayden E Friday, September 20, 2013 12:59 AM
    • Marked as answer by Olaf HelperMVP Monday, October 14, 2013 7:36 AM
    Friday, September 20, 2013 12:46 AM
  • Hi

    I get first the same error as above but after I look into the details I see the following error message:

    in translation the error message is: There is already a item with the same key added.

    I can open the power pivot window in diagram view. And after I refresh the data in one of the tables I can open it in the table view. I have already searched for "!" signs in the calculations and searched for calculations with same name but that is not the problem.

    Also I can't open the synonym window. I think this has something to do with it because I've made changes in the synonyms.

    ============================
    Foutbericht:
    ============================

    Er is al een item met dezelfde sleutel toegevoegd.

    ============================
    Aanroepstack:
    ============================

       bij System.Collections.Generic.Dictionary`2.Insert(TKey key, TValue value, Boolean add)
       bij Microsoft.AnalysisServices.Common.LinguisticModeling.SynonymModel.AddSynonymCollection(Tuple`2 measure, SynonymCollection synonyms)
       bij Microsoft.AnalysisServices.Common.LinguisticModeling.LinguisticSchemaLoader.DeserializeSynonymModelFromSchema()
       bij Microsoft.AnalysisServices.Common.SandboxEditor.LoadLinguisticDesignerState()
       bij Microsoft.AnalysisServices.Common.SandboxEditor.set_Sandbox(DataModelingSandbox value)
       bij Microsoft.AnalysisServices.XLHost.Modeler.ClientWindow.RefreshClientWindow(String tableName)

    ============================

    Thanks,

    Leo

    Thursday, January 29, 2015 12:43 PM