locked
Failed to deploy metro on tablet machine

    Question

  • I am trying to deploy my app to  anon development machine and I get the following error

    (BTW vs did not built appx for me,i needed to do it manually)

    Add-AppxPackage : Deployment failed with HRESULT: 0x800B010A, A certificate chain could not be built to a trusted root
    authority
    Opening package from location file:///C:/Users/myusername/Documents/ServiceCLNC.appx failed with 0x800B010A
    NOTE: For additional information, look for [ActivityId] ee0e7ce4-2e92-0000-d8e8-10ee922ecd01 in the Event Log or use
    the command line Get-AppxLog -ActivityID ee0e7ce4-2e92-0000-d8e8-10ee922ecd01
    At line:1 char:1
    + add-AppxPackage C:\Users\myusername\Documents\ServiceCLNC.appx
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : NotSpecified: (C:\Users\myusername\...erviceCLNC.appx:String) [Add-AppxPackage], Exception
        + FullyQualifiedErrorId : DeploymentError,Microsoft.Windows.Appx.PackageManager.Commands.AddAppxPackageCommand

    PS C:\Users\myusername>

    Wednesday, May 23, 2012 1:59 PM

All replies

  • Hello NoundaDee,

    I am trying to involve someone familiar with this topic to further look at this issue.

    Thanks.


    Vicky Song [MSFT]
    MSDN Community Support | Feedback to us

    Thursday, May 24, 2012 9:35 AM
    Moderator
  • I am also interested in this topic. How to deploy metro app to my tablet?

    VS package and deploy metro app, but target tablet shows "could not install the developer certificate" while the deployment works on win8 x86.

    Any tricky on tablet?

    Wednesday, June 13, 2012 9:14 AM
  • Did you create the app package using VS? Are you using the PS script to install the app package on the tablet?

    Also, is your project migrated from Beta to Release Preview or a new project created using Release Preview?

    Monday, June 18, 2012 9:59 PM
  • Even I m facing the same problem while deploying my application in the win8 tablet. I have migrated the application from Beta to Release preview. I am getting an error saying "could not install the developer certificate". Are they any specific steps to be followed for migration from beta to release preview ??? whether the developer certificated needs to be changed from Beta to RP. Please let me know
    Tuesday, July 10, 2012 3:32 PM
  • Yes. The test certificate requirements have changed from Beta to Release Preview. You need to re-generate the test certificate and rebuild the package. To re-generate the test certificate, see the "Renewing a certificate" section in this topic: http://msdn.microsoft.com/en-us/library/windows/apps/br230260(v=vs.110).aspx.

    Tuesday, July 10, 2012 6:30 PM
  • I am getting the same error even after re-generating the certificate. The application is working fine when I install the package in the simulator.

    Wednesday, July 11, 2012 5:08 AM
  • I solved the error by creating a new application manifest file for my application in VS2012 RC and created a new .pfx file. I copied the newly created  .pfx file to my application after migrating from VS2011 Express Beta. Then packaged the application. Its now working fine. I guess the error was because of  VS2012 not able to update the old certificate with regenerated certificate in pfx file.
    • Proposed as answer by mailmugu Wednesday, July 11, 2012 6:19 AM
    Wednesday, July 11, 2012 6:18 AM
  • Glad it's working for you now. Was your old certificate a *_Storekey.pfx or *_TemporaryKey.pfx? If the first, the replacement does not happen automatically, you will have to delete the .pfx from the project and re-package (which will automatically re-generate the .pfx).

    Thanks.

    Wednesday, July 11, 2012 10:11 PM