none
How to fix this error: "Failed to deploy the manifest file to the Exchange server. The caller has not assigned any of the RBAC roles requested in the management role header."? RRS feed

  • Question

  • Hi All,

    I had signed up for a O365 developer account.
    Was trying out the mail app example for both VS2012 and NAPA.
    However, was not able to deploy the app to the exchange server with this error message:
    Failed to deploy the manifest file to the Exchange server.  The caller has not assigned any of the RBAC roles requested in the management role header.

    Will someone advice me if I have missed out a step or 2?

    Thanks.
    /NG

    Thursday, August 16, 2012 8:02 AM

Answers

  • How to manually assign the RBAC role required to install mail apps via NAPA or Visual Studio

    (Update -- you will need to use PowerShell to make this configuration change.  The Admin GUI may not work for this until all of the servers in the site have been fully upgraded).

    PowerShell instructions:

    1. Open remote powershell and connect to your O365 Exchange tenant (see instructions here)
    2. Then run this:
      New-ManagementRoleAssignment -Role "My Custom Apps" -Policy "Default Role Assignment Policy"

      (note: if you see an error about organization customizations needing to be enabled first, then first run the command as recommended by the error, "Enable-OrganizationCustomization". After it completes, you can run the new-managementroleassignment task again)

    After doing this, you should now have the RBAC assignment needed for NAPA or Visual Studio 2012 to deploy your app to your mailbox. 



    Friday, August 17, 2012 4:14 AM

All replies

  • There is an issue in the new Exchange build being deployed to O365, in which the default (admin) user in your O365 dev tenant is missing the RBAC role assignment needed to install the mail app via NAPA.  We are working on a fix.  The work around for now is to use EAC or PowerShell to manually assign the "my custom apps" role to the "Default Role Assignment Policy".   We will post up detailed instructions for this soon.

    -Steve Clagg

    Thursday, August 16, 2012 10:43 PM
  • How to manually assign the RBAC role required to install mail apps via NAPA or Visual Studio

    (Update -- you will need to use PowerShell to make this configuration change.  The Admin GUI may not work for this until all of the servers in the site have been fully upgraded).

    PowerShell instructions:

    1. Open remote powershell and connect to your O365 Exchange tenant (see instructions here)
    2. Then run this:
      New-ManagementRoleAssignment -Role "My Custom Apps" -Policy "Default Role Assignment Policy"

      (note: if you see an error about organization customizations needing to be enabled first, then first run the command as recommended by the error, "Enable-OrganizationCustomization". After it completes, you can run the new-managementroleassignment task again)

    After doing this, you should now have the RBAC assignment needed for NAPA or Visual Studio 2012 to deploy your app to your mailbox. 



    Friday, August 17, 2012 4:14 AM
  • When I follow the first step, I got the error. Any idea?

    1. Open remote powershell and connect to your O365 Exchange tenant (see instructions here)

    PS C:\Users\di> $Session = New-PSSession -ConfigurationName Microsoft.Exchange -ConnectionUri https://ps.outlook.com/powershell/ -Credential $LiveCred -Authentication Basic -AllowRedirection
    WARNING: Your connection has been redirected to the following URI:
    "https://pod51030psh.outlook.com/PowerShell-LiveID?PSVersion=3.0 "
    New-PSSession : [pod51030psh.outlook.com] PowerShell client does not support the protocolversion 2.2 negotiated by the
    server. Make sure the server is compatible with the build 6.2.8158.0 and the protocol version 2.103 of PowerShell.
    At line:1 char:12
    + $Session = New-PSSession -ConfigurationName Microsoft.Exchange -ConnectionUri ht ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : OpenError: (System.Manageme....RemoteRunspace:RemoteRunspace) [New-PSSession], PSRemotin
       gDataStructureException
        + FullyQualifiedErrorId : PSSessionOpenFailed


    anerky


    • Edited by anerky Friday, August 24, 2012 12:48 AM
    Friday, August 24, 2012 12:45 AM
  • Are you using PowerShell V2?

    The workaround must be applied through PowerShell V2 (which is the default on Win 7 or Server 2008 R2). You could also download it for older versions of Windows from - http://support.microsoft.com/kb/968930

    Thanks


    Friday, August 24, 2012 1:16 AM