locked
azurestack tp3 initial install failed, succeded after -rerun RRS feed

  • Question

  • Hello!

    I attempted tp3 with local adfs:

    .\InstallAzureStackPOC.ps1 -Verbose -AdminPassword $adminpass -UseADFS -NatIPv4Subnet 10.1.1.0/22 -NatIPv4Address 10.1.1.69 -NatIPv4DefaultGateway 10.1.1.254

    It failed with the following error at the bottom:

    COMPLETE: Step 60.120.122 - (Katal) Configure WAS VMs
    VERBOSE: 1> 1> Step: Status of step '60.120.122 - (Katal) Configure WAS VMs' is 'Success'. - 3/9/2017 6:40:12
    PM
    VERBOSE: 1> 1> Action: Action plan 'Deployment-Phase4-IdentitySystemAndWASBootstrap' completed. - 3/9/2017
    6:40:12 PM
    COMPLETE: Action 'Deployment-Phase4-IdentitySystemAndWASBootstrap'
    VERBOSE: 1> 1> Action: Status of 'Deployment-Phase4-IdentitySystemAndWASBootstrap' is 'Success'. - 3/9/2017
    6:40:12 PM
    COMPLETE: Task Cloud - Deployment-Phase4-IdentitySystemAndWASBootstrap
    VERBOSE: 1> 1> Task: Status of action 'Deployment-Phase4-IdentitySystemAndWASBootstrap' of role 'Cloud' is
    'Success'. - 3/9/2017 6:40:12 PM
    VERBOSE: 1> Step: Status of step '60.120 - Phase 4 - ConfigureVMs-Part2' is 'Error'. - 3/9/2017 6:40:12 PM
    Invoke-EceAction : 1> Action: Invocation of step 60.120 failed. Stopping invocation of action plan. -
    3/9/2017 6:40:12 PM
    At line:5 char:2
    +  Invoke-EceAction -RolePath Cloud -ActionType Deployment -Start 0.17  ...
    +  ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidOperation: (:) [Invoke-EceAction], Exception
        + FullyQualifiedErrorId : Unspecified error,CloudEngine.Cmdlets.InvokeCmdlet
    
    VERBOSE: 1> Action: Status of 'Deployment-Phase2-ConfigureStack' is 'Error'. - 3/9/2017 6:40:12 PM
    COMPLETE: Task Cloud - Deployment-Phase2-ConfigureStack
    VERBOSE: 1> Task: Status of action 'Deployment-Phase2-ConfigureStack' of role 'Cloud' is 'Error'. - 3/9/2017
    6:40:12 PM
    VERBOSE: Step: Status of step '60 - Phase 2 - ConfigureVMs' is 'Error'. - 3/9/2017 6:40:12 PM
    Invoke-EceAction : Action: Invocation of step 60 failed. Stopping invocation of action plan. - 3/9/2017
    6:40:12 PM
    At line:5 char:2
    +  Invoke-EceAction -RolePath Cloud -ActionType Deployment -Start 0.17  ...
    +  ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidOperation: (:) [Invoke-EceAction], Exception
        + FullyQualifiedErrorId : Unspecified error,CloudEngine.Cmdlets.InvokeCmdlet


    In the powershell window history there was an earlier error too (which didn't stop the install):

    WARNING: 1> 2> Task: Invocation of interface 'Prerequisite' of role 'Cloud\Fabric\FabricRingServices\SRP'
    failed:
    
    Function 'SRP:Prerequisite' in module 'Classes\SRP\SRP.psm1' raised an exception:
    
    Create SRP DB failed
    at <ScriptBlock>, <No file>: line 41 - 3/9/2017 6:37:14 PM
    Invoke-EceAction : 1> 2> Task: Invocation of interface 'Prerequisite' of role
    'Cloud\Fabric\FabricRingServices\SRP' failed:
    Function 'SRP:Prerequisite' in module 'Classes\SRP\SRP.psm1' raised an exception:
    Create SRP DB failed
    at <ScriptBlock>, <No file>: line 41 - 3/9/2017 6:37:14 PM
    At line:5 char:2
    +  Invoke-EceAction -RolePath Cloud -ActionType Deployment -Start 0.17  ...
    +  ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : NotSpecified: (:) [Invoke-EceAction], Exception
        + FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorException,CloudEngine.Cmdlets.InvokeCmd
       let
    
    VERBOSE: 1> 2> Step: Status of step '60.120.124 - (FBI) Deploy Azure Stack Fabric Ring Controller Services -
    Prerequisite For SRP' is 'Error'. - 3/9/2017 6:37:14 PM
    Invoke-EceAction : 1> 2> Action: Invocation of step 60.120.124 failed. Stopping invocation of action plan. -
    3/9/2017 6:37:14 PM
    At line:5 char:2
    +  Invoke-EceAction -RolePath Cloud -ActionType Deployment -Start 0.17  ...
    +  ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidOperation: (:) [Invoke-EceAction], Exception
        + FullyQualifiedErrorId : Unspecified error,CloudEngine.Cmdlets.InvokeCmdlet
    
    VERBOSE: 1> 2> Action: Status of 'Deployment-Phase4-DeploySRPControllerServices' is 'Error'. - 3/9/2017
    6:37:14 PM
    COMPLETE: Task Cloud - Deployment-Phase4-DeploySRPControllerServices

    I was able to successfully install TP3 using -rerun, but looking for ideas what might have happened and how to troubleshoot similar cases.


    Friday, March 10, 2017 10:20 PM

Answers

  • Hello,

    The error that you didn’t stop the deployment was at step 60.120.124 which configures Azure Stack with Azure AD.  Since your performing an ADFS configuration, the deployment was able to skip the step 60.120.124 and complete the deployment successfully.

    Thanks,


    Gary Gallanes

    Monday, March 13, 2017 4:00 PM