locked
Why is my Extension Manager entry missing after re-installing PostSharp RRS feed

  • Question

  • I was wondering if anyone could help with this VS2010 Extension Manager issue I'm experiencing.
     
    I am running Visual Studio 2010 on Windows 7 Professional 64-bit.
    I recently uninstalled an old version of PostSharp (2.1.5.1) using Control Panel add/remove programs.
    I  also selected the PostSharp entry listed in VS2010 Extension Manager and picked uninstall.
    I shutdown VS2010 and installed the new version of PostSharp (2.1.7.12) using the setup program.

    Now when I bring up VS2010, I no longer have the PostSharp entry in the Extension Manager list (although PostSharp seems to be working). Where did the entry go and how do I get it back?

    PostSharp forum suggested I run vs2010 with the /log switch . I ran with /log and I did find an entry in the log for PostSharp that said "Extension will not be loaded because it is marked for deletion." The extension folder and files seem to be there at "C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE\Extensions\SharpCrafters\PostSharp\2.1\". However, I was seeing two files that have an extension '.deleteme'.
     
    PostSharp forum suggested I try uninstalling PostSharp,  remove the folder C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE\Extensions\SharpCrafters\PostSharp\2.1, re-install PostSharp and restart Visual Studio. I did that but the PostSharp entry that used to be in the Extension Manager list still does not appear.
     
    What happened to the PostSharp entry in the Extension Manager list and how do I get it back?
     
    Thanks in advance for any assistance ....

    Monday, October 1, 2012 4:44 PM

Answers

  • Aaron,

    That seems to have fixed the problem.

    Thank you so much for your help!

    • Marked as answer by dev1953 Tuesday, October 9, 2012 2:09 PM
    Tuesday, October 9, 2012 2:09 PM

All replies

  • Hi dev1953,

    Did you install the PostSharp by VSIX or other install packages?

    Visual Studio continues to support deployment technologies such as the Visual Studio Content Installer (VSI) and the Microsoft Installer (MSI), but not through Extension Manager.

    More information you can refer to:

    http://msdn.microsoft.com/en-us/library/dd293638(VS.100).aspx

    Best regards,


    Ego [MSFT]
    MSDN Community Support | Feedback to us

    • Proposed as answer by WillSullivan Monday, October 15, 2012 3:16 PM
    Tuesday, October 2, 2012 7:02 AM
  • I am not sure how to answer that.
    Here are the install instructions from the PostSharp site - I just executed the .exe per the instructions.

    • Download this file.
    • Close all instances of Visual Studio.
    • Execute the file PostSharp-2.1.7.18.exe and follow the instructions of the setup program.
    • If PostSharp 2.0 is installed on your computer, the setup program may uninstall the PostSharp 2.0 Visual Studio Extension (VSX) and replace it by the PostSharp 2.1 VSX, since both cannot co-exist. Do not forget to reinstall the PostSharp 2.0 VSX if you uninstall PostSharp 2.1. The PostSharp 2.1 VSX is backward compatible with PostSharp 2.0.
    Tuesday, October 2, 2012 12:43 PM
  • Do you have any entries related to PostSharp in the registry under HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\10.0\ExtensionManager\PendingDeletions?

    http://blogs.msdn.com/aaronmar

    Tuesday, October 2, 2012 3:49 PM
  • Yes, I found a PostSharp related entry in the Registry location you specified - see screenshot I've included below.

    Since I am running in 64-bit environment will there be more than one entry?
    Please advise how I should proceed.

    thanks


    • Edited by dev1953 Tuesday, October 2, 2012 5:36 PM
    Tuesday, October 2, 2012 5:30 PM
  • No, 64-bt Windows shouldn't make a difference.

    Please go ahead and delete the value. You should start seeing PostSharp appear again in Extension Manager.


    http://blogs.msdn.com/aaronmar

    Wednesday, October 3, 2012 8:55 PM
  • Aaron,

    That seems to have fixed the problem.

    Thank you so much for your help!

    • Marked as answer by dev1953 Tuesday, October 9, 2012 2:09 PM
    Tuesday, October 9, 2012 2:09 PM