attempt to open results in error message saying "A connection with the server could not be established".


  • I am trying to open a new Asp.Net application using Visual Studio.Net 2003 on my stand alone home machine.  I am opening it in HTTP://localhost/webnewapp.  Each attempt to open results in an error message saying "A connection with the server could not be established".   I am using Windows XP SP 2, IE 6.0 ASP.net version 1.1.4322.  Have run aspnet_regiis.exe with the -i switch, the -enable switch, the -ir switch and the -r switch.  Have checked the application mappings in the configuration of IIS and they all point to the v1.1.4322 directory.  IIS is running.  VS 6.0 Interdev project can be established and opened just fine.  I have seen many requests for help on this issue and other than the basic items listed above, no one has made any legitimate suggestions.  Someone suggested searching MSDN and technet for an answer as if that wasn't the first place one would look for an answer.  The only article I could find stated that one needed to go get the latest service pack for WindowsXP, Service Pack 1(!!!???).  At the devconnections conference in Orlando, none of the Microsoft reps could provide an answer beyond the ones listed above.  A co-worker is having the same issues on his laptop.

    While stepping through procedure to answer question concerning steps raised in other Thread, I ended up going through procedure while connected to CompuServe.  The project was able to complete creation.  As soon as dial-up disconnected, same error crops up when either creating or trying to open already created project.  I don't have enough minutes (or money) to remain connected for the entire period I am working on projects.  Interdev 6.0 in VS 6.0 does not behave this way, so it does not seem to be an IIS setting.

    Since the orignal submission of this question suggestion concerning adding localhost to hosts file was implemented and failed.

    Sunday, May 01, 2005 3:18 AM


  • Hi,

    I had the same problem, but fixed it by allowing the "Internet Information Service"
    to act as a server in the firewall. I am using ZoneAlarm.

    Monday, October 03, 2005 10:29 PM

All replies

  • How are you connecting to your web server? Using Frontpage or Fileshare? If you place an aspx or html page into the root of your web server, can you browse the page using your internet Browser? 
    Wednesday, May 18, 2005 7:09 PM
  • Does anyone knows a solution to this? I am having the same problem.
    Friday, September 02, 2005 3:12 PM
  • I was facing the exact problems as above and nothing was working. I did the following:

    1) I uninstalled SQL desktop engine. You may avoid this step  I had done this only to see if it might be the cause of the problem and now that it works.. I have no way to know if this was a part of the solution.

    2) I remembered I had changed the port of my IIS from 80 to 81. I brought it back to 80

    3) Make sure that the IP address column in IIS manager is set to *All Assigned* and not your computer ip address.

     Well I did this and it worked. Hope it works for you too.
    Sunday, September 18, 2005 10:24 AM
  • Hi,

    I am having EXACTLY the same problem and don't seem to be getting ANY answers.

    I had the same version of .NET framework, and ran through all the instructions to check that it was looking at the right .dll's in the right directories.

    I have also checked that it is using port 80 and have looked at the ip (though mine is set to "all unassigned" not "assigned"????????)

    If I installed the tomcat server and run it at port 80 .NET could find it but obviously tomcat did not know what to do with an ASP.NET Mobile app.   I have since removed tomcat.

    I cant seem to get IIS to do anything (can't start it, connect to it or anything)  I have done a reinstallation of the .NET framework sdk, and reinstalled Visual Studio.NET from scratch so everything is clean.

    ANYONE OUT THERE WHO CAN POINT ME IN THE RIGHT DIRECTION???????   I am having to develop cross platform (Windows and Linux) with two different development environments at the moment (Eclipse and Visual Studio.NET) and the complexity is big enough without having search for months on end to fix this!!!!!


    (Needing caffeine on a drip and a night out to forget this lot!)

    Tuesday, September 20, 2005 11:00 AM
  • Hi,

    I had the same problem, but fixed it by allowing the "Internet Information Service"
    to act as a server in the firewall. I am using ZoneAlarm.

    Monday, October 03, 2005 10:29 PM
  • Ah mine was as simple as removing Skype from my operating system!!!!!!

    It was pinching port 80.


    Monday, October 17, 2005 1:39 PM
  • weren't using Skype by any chance were you?

    Monday, October 17, 2005 1:42 PM
  • I am not sure why Mr.  Sorenson was given credit for finding the answer.  My machine does not have a firewall set up because the XP version of Norton Anti virus will not allow the MS firewall to be set up.  I also do not have SKYPE.  Nor does that machine have an IP address assigned.  I am not getting notified of postings to my threads so I didn't know anything about these various suggestions.  I eventually found the answer on another forum in about June 2005.  Unfortunately I had forgotten the answer when it came time to set up VS 2003 on my new computer in January 2007.  This is also necessary for building VC 2005 web services with my VS 2005 install. (C# and VB both use the built in web server.)  If anyone has resolved this issue please repond.  Tak skall de hej in advance for your assistance.

    Tuesday, August 14, 2007 7:12 PM