none
Missing namespaces in a new project

    Question

  • I have a fresh install of Visual Studio 2015. I created a new project and the following namespaces are missing.

    using Windows.ApplicationModel;
    using Windows.Foundation.Collections;
    using Windows.UI.Xaml.Data;
    using Windows.UI.Xaml.Input;
    using Windows.UI.Xaml.Navigation;

    Screenshot: http://imgur.com/9wR5m8D

    I've rerun the installer and it didn't help.



    • Edited by monkeyhoop Sunday, January 10, 2016 9:02 AM
    Sunday, January 10, 2016 8:51 AM

Answers

  • I just finished running the 'Repair' option from the installer executable and I'm no longer missing the name spaces. Thanks for your help, I really appreciate it.
    • Marked as answer by monkeyhoop Sunday, January 10, 2016 2:33 PM
    Sunday, January 10, 2016 2:33 PM

All replies

  • Looks like you are writing an Universal Windows App...

    Therefore the question: have you installed the packages for developing Universal Apps?

    (https://msdn.microsoft.com/en-us/library/windows/apps/dn609832.aspx)


    Cyrille Precetti
    Bonne Année! Happy New Year!

    Sunday, January 10, 2016 9:48 AM
  • Yes, they have been installed.

    http://imgur.com/B1Z2G00

    I ran the installer and clicked 'Modify'. Each component appeared with a ticked checkbox and the update button grayed out. But if you select them individually there's an option to remove.

    Sunday, January 10, 2016 10:25 AM
  • Then, have you selected an emtpy Universal App project? (not sure if that would be necessary but the msdn detail shows that)...

    How about the extensions in the project Reference Manager like this:

    Also the NuGet packages may be missing: Tools -> NuGet Package Manager -> choose console or "manage packages for solutions"

    There are also some hints that I forward here:

    "It may also be that you have wrong target framework version in your project. Try set Target Framework: https://msdn.microsoft.com/en-us/library/bb398202.aspx to 4.5.1 => You can double check in control panel -> add/remove programs that you actually have the targeted framework installed in you system.

    If everything looks ok, go to your assemblies under "References", click on the reference that is unable to load, and make sure that "Specific Version" is set to false."


    Cyrille Precetti
    Bonne Année! Happy New Year!


    Sunday, January 10, 2016 10:33 AM
  • I just finished running the 'Repair' option from the installer executable and I'm no longer missing the name spaces. Thanks for your help, I really appreciate it.
    • Marked as answer by monkeyhoop Sunday, January 10, 2016 2:33 PM
    Sunday, January 10, 2016 2:33 PM
  • No problem.

    Mark my answer if it helped.

    Thanks


    Cyrille Precetti
    Bonne Année! Happy New Year!

    Sunday, January 10, 2016 2:47 PM