locked
Deployment of Rule Fails with MS BRE only installation RRS feed

Answers

  • Is this machine that you are working on a  part of Biztalk Group ?? If not can you please confirm the values of the following registry keys ??

    HKLM\Software\Microsoft\BusinessRules\3.0\DeploymentDriverAssembly = "Microsoft.RuleEngine, Version=3.0.1.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"

    HKLM\Software\Microsoft\BusinessRules\3.0\DeploymentDriverClass = "Microsoft.RuleEngine.RuleSetDeploymentDriver"


    If not please set them accordingly.

    By doing this you will be using the rules only deployment driver and hence wont be able to track policies in orchestrations.
    Friday, May 29, 2009 5:55 AM
  • From an older post (http://blogs.msdn.com/kerreybpi/archive/2007/07/31/biztalk-error-associated-with-the-deployment-driver-does-not-match-the-database.aspx)

    Resolution:  Within Business Rule Composer, click the Menu "Rule Store"->"Load", this poped the window "Open Rule Store", check the value of SQL Server, if it's a IP address, change the IP address to a SQL Server name


    Regards
    Bindu Thota
    Senior Program Manager
    BizTalk Team


    Senior Program Manager, BizTalk RFID
    Wednesday, May 27, 2009 11:08 AM

All replies

  • I haven't tried this myself yet. However, I wanted to ask, whether you did configure BRE via the configuration utility?
    If so, does that point to your SQL Server instance? Did the RuleEngineDB got created?

    This posting is provided "AS IS" with no warranties, and confers no rights.

    Wednesday, May 27, 2009 9:22 AM
  • From an older post (http://blogs.msdn.com/kerreybpi/archive/2007/07/31/biztalk-error-associated-with-the-deployment-driver-does-not-match-the-database.aspx)

    Resolution:  Within Business Rule Composer, click the Menu "Rule Store"->"Load", this poped the window "Open Rule Store", check the value of SQL Server, if it's a IP address, change the IP address to a SQL Server name


    Regards
    Bindu Thota
    Senior Program Manager
    BizTalk Team


    Senior Program Manager, BizTalk RFID
    Wednesday, May 27, 2009 11:08 AM
  • Is this machine that you are working on a  part of Biztalk Group ?? If not can you please confirm the values of the following registry keys ??

    HKLM\Software\Microsoft\BusinessRules\3.0\DeploymentDriverAssembly = "Microsoft.RuleEngine, Version=3.0.1.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"

    HKLM\Software\Microsoft\BusinessRules\3.0\DeploymentDriverClass = "Microsoft.RuleEngine.RuleSetDeploymentDriver"


    If not please set them accordingly.

    By doing this you will be using the rules only deployment driver and hence wont be able to track policies in orchestrations.
    Friday, May 29, 2009 5:55 AM
  • Thanks Raghuram. That worked very well. BTW, I also noticed that I could get to this entry only by using the "Find.." dialog on the Registry Editor and I looked for "BusinessRules". Otherwise, when I expand the tree it does not appear.

    Could you please let me know why the installation does not place the right values in these registry keys?

    Regards,
    JK
    Wednesday, June 3, 2009 1:53 AM
  • The database "<server>:<database>" associated with the deployment driver does not match the database ":" specified during product configuration

    The first server:db entry refers to the one you configured on the client machine the second db reference would be pointing the <group>:<db> but since the group is not configured during a BRE only install it is blank.  For some reason this has only recently become an issue as we encountered when reinstalling the BRE on clients who received new laptops and opened a case with MS.  MS will be adding to kb article.

    Wednesday, July 22, 2009 8:55 PM
  • After some research, I found a works solution, I post it here.

    http://xhinker.com/2009/09/04/BizTalk2009DeployBusinessRuleErrorAssociatedWithTheDeploymentDriverDoesNotMatchTheDatabaseSpecifiedDuringProductConfiguration.aspx

    Hope it helps

    Regards
    Microsoft Online Community Support
    Friday, September 4, 2009 6:35 AM
    Moderator
    • Proposed as answer by sboman73 Wednesday, October 20, 2010 9:18 PM
    Wednesday, October 20, 2010 8:54 PM