Service Pack 2 (SP2) Configuration Wizard Fails - An exception of type Microsoft.SharePoint.PostSetupConfiguration.PostSetupConfigurationTaskException was thrown. RRS feed

  • Question

  • One particular VM of mine is being troublesome with the upgrade to SP2.  I installed the WSS upgrade followed by the MOSS upgrade.  I've followed all of the usual installation instructions, however during the Configuration Wizard it fails on step 8 or 9. 

    Failed to upgrade SharePoint Products and Technologies.  Further information regarding this failure can be found at C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\LOGS\Upgrade.log.
    An exception of type Microsoft.SharePoint.PostSetupConfiguration.PostSetupConfigurationTaskException was thrown.  Additional exception information: Failed to upgrade SharePoint Products and Technologies.
    Microsoft.SharePoint.PostSetupConfiguration.PostSetupConfigurationTaskException: Exception of type 'Microsoft.SharePoint.PostSetupConfiguration.PostSetupConfigurationTaskException' was thrown.
       at Microsoft.SharePoint.PostSetupConfiguration.UpgradeTask.Run()
       at Microsoft.SharePoint.PostSetupConfiguration.TaskThread.ExecuteTask()

    Examing the log, I find the error:

    The B2B upgrader timer job failed

    So far, I have tried reconfiguring search as suggested here as well as detaching my content databases and then running the configuration wizard.  I've also believe I've tried everything from this SP1 thread.  So if anyone else out there has any ideas, please let me know.

    Corey Roth blog: www.dotnetmafia.com twitter: twitter.com/coreyroth
    Thursday, April 30, 2009 6:17 PM

All replies

  • You are not alone, I have tried the same steps and have been unsuccessful. I may try opening a ticket tomorrow, although I am sure that support is a bit busy right now.

    Thursday, April 30, 2009 11:54 PM
  • Hi Corey,

    I got the same message when I tried to upgrade. When I looked in the Upgrade.log file it said that it couldn't modify the ACLs on one of my web.config files. That was correct, because it wanted to modify the ACLs on a web.config file in a wpresources folder that I deleted (the web.config, not the wpresources folder). Could it be the same problem for you?

    Also: make sure you got the right SP2 files and not the Language Packs...it's only a 2 letter difference...I started out using the wrong one myself..

    If this doesn't help try checking out the upgrade.log in more detail, that helped me out.

    Good luck!


    Mirjam --http://www.sharepointblogs.com/mirjam
    Friday, May 1, 2009 3:04 PM
  • I have successfully resolved the issue with Microsoft support's help. In my case the error indicated above regarding the B2B upgrade timer job was not the whole story. The upgrade.log file which has been updating since the initial installation held the key to the problem. The upgrade log shows three types of errors [DEBUG], [INFO], and [ERROR], in my case the only [ERROR] was indicating a failure to activate a site feature (siteslist) with the GUID of the feature as the only indication, this has been a problem from the initial install. Back when service pack 1 came out, I was having the exact same message and failure at step 8/9. I had placed at least 5 different support incidents with Microsofton that issue with no resolution. It was not a debilitating issue since my server was completely functional and indeed all file versions showed the correct service pack 1 file versions. I ran the following command "stsadm -o activatefeature -name siteslist -url http://sharepoint.company.com/SiteDirectory -force" and then ran the configuration wizard successfully. Hope this helps some others.

    Tuesday, May 5, 2009 8:59 PM
  • Unfortunately, that doesn't look like it is going to be the fix for me.  I checked the upgrade log and the B2B upgrader timer error is the first ERR in the log file.  Everything else relates to this error occurring.  I've tried some additional steps such as making the Cental Admin AppPool account an administrator and running psconfig with it.  I also tried clearing the SharePoint configuration cache and nothing still works.


    Corey Roth blog: www.dotnetmafia.com twitter: twitter.com/coreyroth
    Tuesday, May 5, 2009 9:05 PM
  • Hi Corey,


    I agree with Badger, the cause should be 3rd party features or something else in the site collection.


    I suggest you to detach all the content databases of all the web applications you created (not include the Central administration web application) and run the psconfig again.


    If successful, attach the content databases back one by one.


    You could narrow down the issue with this method.


    Let me know the result if possible.


    Lambert Qin | Microsoft Online Support Engineer
    How to ask a question in the forum (http://support.microsoft.com/kb/555375)
    Posting is provided "AS IS" with no warranties, and confers no rights.
    Wednesday, May 6, 2009 2:50 AM
  • Yeah, I actually did detach my content databases and try it.  The MOSS installation is actually pretty clean.  There is not much on it as I just use it for the occasional demo.

    Corey Roth blog: www.dotnetmafia.com twitter: twitter.com/coreyroth
    Wednesday, May 6, 2009 1:41 PM
  • Even I had the same problem.In my case the problem is with the content database. I have one of the web application whose content database is deleted.
    While running the Configurationj wizard it is trying to connect to the deleted content database and it is whre the configuration wizard is failing.
    As usual the PSCDiagnostics....log did not provide any relevant info on this.
    The  [ERROR] section in Upgrade.log  is helpful in my case.


    Tuesday, May 19, 2009 1:37 PM
  • Saturday, August 29, 2009 5:29 AM
  • Check the SharePoint web config file whether is there any custom settings apart from SharePoint default settings.
    For my case, I have added location path="." in heritInChildApplication="false" in web config and I got the same error.
    After I have commented this line and try the Wizard, it works.

    what is understood need not be discussed
    Wednesday, September 23, 2009 5:06 AM
  • Corey, did you ever find a fix for this.   I'm having the same problem so if so, please post.  Thanks.

    -- huddie71 ~~If you~re not seeking help or offering it, you probably shouldn~t be here.~~

    Tuesday, February 17, 2015 3:26 PM