none
ActiveSync: not using SmartReply and SmartForward RRS feed

  • Question

  • Hi guys,

    this is my first question in this forum and it is a heavy one..

    Is there any way to force Outlook 2013 to use the SmartReply and SmartForward commands in ActiveSync connections?

    Outlook 2013 is always just using the normal "SendMail" command instead of using the "SmartReply" or "SmartForward"..

    Sadly OL looses the threading between messages and the customers comply they don't see if a message was replied or forwared or just read..

    Thanks!

    Tuesday, December 2, 2014 5:51 PM

All replies

  • Hello Patrick,

    You can use the ExecuteMso method of the CommandBars class (see corresponding Explorer and Inspector class members) to run built-in controls programmatically.

    Also see Office 2013 Help Files: Office Fluent User Interface Control Identifiers for built-in control IDs.

    Tuesday, December 2, 2014 5:59 PM
  • Hello Patrick,

    You can use the ExecuteMso method of the CommandBars class (see corresponding Explorer and Inspector class members) to run built-in controls programmatically.

    Also see Office 2013 Help Files: Office Fluent User Interface Control Identifiers for built-in control IDs.


    I am a developer of an ActiveSync Server component wich is handling/emulating a complete ActiveSync server instead of using Exchange.

    I'm not searching how to add Buttons or something like that, I have to go deeper in programming details of Outlook 2013. In fact, every ActiveSync software implementation of version EAS 14.1 have to be able to use the special commands: "SmartReply" and "SmartForward"; they are not "Buttons"!

    They are functions in Outlook 2013 sourcecode..

    So maybe is there someone how could give me some detailed and VERY deep informations on the implementation of EAS 14.1 conformity in Outlook 2013?

    Thanks!

    Tuesday, December 2, 2014 6:19 PM