none
WACK tool results different from local

    Question

  • Hi,

    An app I pushed to the store yesterday failed certification.

    Error: Debug configuration - the binary x.dll is built in debug mode.

    When I run WACK locally everything passes fine. I've rechecked the settings and all dll's should be released in release mode.

    As I don't have the error locally it's really hard to know if next submission would work / how to fix the issue to get the app submitted.

    Points I've checked:
    - all dll's in project set to <optimize>true</optimize>
    - no 'DEBUG' in DefineConstants
    - usedotnetnative set to true

    Are there any other reasons the app could fail on 'debug mode'?

    Can I test this differently to get the same error as online certification?

    How best to proceed from here to avoid 'blindly' submitting to the store with the hopes it will work this time

    Thanks,

    Michiel

    Tuesday, December 8, 2015 2:59 PM

All replies

  • Hello Michiel,

    If you are still experiencing this issue, please create a request with us here through your developer account so we may assist you appropriately and provide me with the ticket number so I may monitor the case. Thank you!

    Wednesday, December 16, 2015 7:03 PM