locked
500 - Internal server error, when browsing .asp pages on server 2008 server core RRS feed

  • Question

  • User1439936796 posted

    hi, plzzzzzzzz anybody cn help me???????

    I've fallowing error massage on browser when requesting .asp pages of my test website, which is run on server 2008 server core sysytem.

    "500 - Internal server error"

    bt i can browse .htm pages on same web site.

    problem occures only browsing .asp pages.

    (pls help me, i've already go through the book of "administering windows server 2008 server coree" too.......)

    Tuesday, June 23, 2009 5:31 AM

All replies

  • User-1853252149 posted

    Did you configure ASP Classic on your server?  See:

    http://learn.iis.net/page.aspx/559/running-classic-asp-applications-on-iis-70-and-iis-75/

    Jeff

    Tuesday, June 23, 2009 7:02 PM
  • User1439936796 posted

    **************system run on windows server 2008 server core environment**********

    i configured

    as this way

    Start /w pkgmgr /iu:IIS-WebServerRole;IIS-WebServer;IIS-CommonHttpFeatures;IIS-StaticContent;IIS-DefaultDocument;IIS-DirectoryBrowsing;IIS-HttpErrors;IIS-ApplicationDevelopment;IIS-ASP;IIS-ISAPIExtensions;IIS-HealthAndDiagnostics;IIS-HttpLogging;IIS-LoggingLibraries;IIS-RequestMonitor;IIS-Security;IIS-RequestFiltering;IIS-HttpCompressionStatic;IIS-WebServerManagementTools; WAS-WindowsActivationService;WAS-ProcessModel

    start /w pkgmgr /iu:IIS-WebServerRole;IIS-WebServer;IIS-CommonHttpFeatures;IIS-StaticContent;IIS-DefaultDocument;IIS-DirectoryBrowsing;IIS-HttpErrors;IIS-HttpRedirect;IIS-ApplicationDevelopment;IIS-ASP;IIS-CGI;IIS-ISAPIExtensions;IIS-ISAPIFilter;IIS-ServerSideIncludes;IIS-HealthAndDiagnostics;IIS-HttpLogging;IIS-LoggingLibraries;IIS-RequestMonitor;IIS-HttpTracing;IIS-CustomLogging;IIS-ODBCLogging;IIS-Security;IIS-BasicAuthentication;IIS-WindowsAuthentication;IIS-DigestAuthentication;IIS-ClientCertificateMappingAuthentication;IIS-IISCertificateMappingAuthentication;IIS-URLAuthorization;IIS-RequestFiltering;IIS-IPSecurity;IIS-Performance;IIS-HttpCompressionStatic;IIS-HttpCompressionDynamic;IIS-WebServerManagementTools;IIS-ManagementScriptingTools;IIS-IIS6ManagementCompatibility;IIS-Metabase;IIS-WMICompatibility;IIS-LegacyScripts;IIS-FTPPublishingService;IIS-FTPServer;WAS-WindowsActivationService;WAS-ProcessModel

    above succesfully (error level 0; and show oclist all are installed)

    appcmd.exe set config "Contoso" -section:system.webServer/asp /enableParentPaths:"False" /commit:apphost
    appcmd.exe set config "Contoso" -section:system.webServer/asp /bufferingOn:"True" /commit:apphost
    appcmd.exe set config "Contoso" -section:system.webServer/asp /session.allowSessionState:"True" /commit:apphost

    ??????????? bt still having problem

    is there any problem in asp configuration?

    note; path was succesfully configured.

    and .htm can view

    Wednesday, June 24, 2009 2:25 AM
  • User744767459 posted

    Hi,

    The 500 error is an general error. Please run the following commands, the test again to get more detailed error information:

    appcmd.exe set config "Contoso" -section:system.webServer/httpErrors  /errormode:"Detailed" /commit:apphost
    appcmd.exe set config "Contoso" -section:system.webServer/asp /scriptErrorSentToBrowser:"true" /commit:apphost

    Also, make sure the "Show friendly HTTP error messages" is disabled.

    Thursday, June 25, 2009 1:59 AM
  • User1439936796 posted

    ok thankx

    i checked it problem was;

    ******

    ADODB.Connection error '800a0e7a'

    Provider cannot be found. It may not be properly installed.

    ******

    i will check it

     

    Thursday, June 25, 2009 5:18 AM
  • User1439936796 posted
    now commen asp pages cn view bt when callig .jet fallowing error occured "ADODB.Connection error '800a0e7a' " then i enter fallowing on command line: REGSVR32 "c:\PROGRMFILE\COMMENFILES\SYSYTEM\OLEDB\MSDASQL.DLL" THEN I GIVES FALOOWING ERROR MGS; "......... WAS LOADED, BUT ERROR 0X80004005" WTS THE CASE HERE????????? NOTE: SYSYTEM RUNS ON WINDOWS SERVER2008 SERVER CORE ENVIRONMENT
    Monday, June 29, 2009 4:47 AM
  • User1439936796 posted
    when i'm going to instal "Jet40SP8_WMe.exe" For computers that are running Microsoft Windows Millennium Edition: then it gives following error ???????????? error creating <C:\windows\system32\sucatreg.exe /D:jet8USA.cat> Reason, system cannot file specified ?????????????? i also tries to install " jetcu40.exe" ; it can extract but cannot install it says .dll error there already i install odbc through "VPODBC.msi" it was properly installed.
    Tuesday, June 30, 2009 12:25 AM
  • User1439936796 posted
    this is the full scenario; , I'm running test web site on windows server 2008 server core environment (windows x32). then I've a problem of requesting .asp pages from it. with the help of iis,net forums i've found that the problem was my db's microsoft.jet adodb connection error. so according to iis forums there is registration problem so then i've tried for fallowing command when that gives fallowing error; then most of Microsoft related forums says problem wad permissions to dll and have to log as administrator on cmd prompt. bt already i've logged as administrator still having problems. ??????????????????????? note: already i tried to update server 2008 with ,jet40 but i couldn't found compatible version for it ????????????? plz help me to do this.............................
    Tuesday, June 30, 2009 5:17 AM
  • User1439936796 posted
    hey i didnt have solution yet. regards to above post and regarding forums; i run the command "regsvr32 jscript" ; then i show the success; bt still having above mentioned error massage when try fallowing command; =====regsvr32 "C:\program file\ common files\system\oledb\msdasql.dll"======== ?????????????????
    Tuesday, June 30, 2009 11:25 PM