none
Bluetooth Keyboard - Asking for Passcode RRS feed

  • Question

  • Hi all,

    I had the keyboard paired and working yesterday, but today it wouldn't connect. I removed it and tried to re-add it, but now its asking me for a passcode. I tried 0000 but that didn't work...

    Any thoughts?

    Saturday, September 17, 2011 4:29 AM

Answers

All replies

  • pbounaix,

    Let's start with something easy.  Check the batteries and replace with new ones.  A few people unboxed to find near dead batteries and that can cause problems.

    The next thing is to launch System Restore and pick a point where the keyboard was working fine.  That old chestnut of support that often works.

    Let us know the results,

    Charles

    Saturday, September 17, 2011 7:19 AM
  • I'm having a similar issue, in that I am getting prompted for a passcode, but this is the first time I've tried pairing the keyboard (I didn't take the keyboard out of the box while I was at Build). How do I find out what the passcode is?
    Sunday, September 18, 2011 2:21 AM
  • The PC should generate the passcode during the "Add Device" interaction and then you enter the passcode on the keyboard.  It sounds like the PC is expecting the keyboard to generate the passcode (or have a fixed one)? 

    Did you get a copy of the flyer with instructions for pairing the keyboard?  I don't have a scanner handy, but here are the steps from the flyer...

    1. Press and hold the power button on the right hand side of the keyboard for ~3 seconds until the blue LED starts to flash slowly (alternating two flashes and a pause).
    2. Tap "Control Panel" on the Start Menu.
    3. Scroll down and tap "Devices" in the left panel.
    4. Tap the "Add a device" icon in the right panel.  You should see the Samsung Bluetooth keyboard appear in the device list.
    5. Select the keyboard.  You will be presented with a passcode.
    6. Type the passcode as shown on the keyboard and press Enter.
    7. Your keyboard is now ready for use.

    The flyer also emphasises that, when turning the keyboard off and on, the power button should only be pressed for ~2 seconds until the blue LED comes on and should be released immediately after the LED comes on (otherwise the keyboard may end up back in pairing mode).

    There's also a troubleshooting section in the flyer...

    If you have previously paired your Windows system with the keyboard, but it does not seem to function, follow these steps to troubleshoot the issue (you can also refer to the release notes for any further issues you may encounter).

    1. First check the batteries and make sure they are fresh.
    2. If the batteries are good, go to the "Devices and Printers" folder (you can do this by typing "Device and printers in the Start menu and selecting the "Settings" tab).
    3. Select the Samsung Bluetooth keyboard from the "Devices" portion of the list.
    4. Select "Remove Device" from the top menu.
    5. Click "Yes" to remove the device.  The Samsung Bluetooth keyboard will disappear from the list.
    6. Follow the steps in Discovering and associating the keyboard with Windows section above to re-associate your keyboard.

    The release notes can be found here (pdf).


    Sunday, September 18, 2011 3:32 AM
  • Hi,

    If the keyboard is asking for a passcode, you can enter "0000"+Enter on the UI, and then "0000"+Enter on the physical keyboard. It should then work.

    Thanks,

    Eric Li [MSFT]

    • Proposed as answer by EricLi [MSFT] Sunday, September 18, 2011 5:43 AM
    Sunday, September 18, 2011 5:42 AM
  • Hi Eric,

    I tried the "0000" passcode but it didn't work.  Any other ideas?

    I have connected this keyboard before but that time it prompted me with what digits to type on the keyboard.  This time it is the reverse, it want's me to enter the keyboard key onto the screen (using the Soft touch screen keyboard).  However, as mentioned, I don't know what the correct keyboard key is.

    Thanks,

    Mark

    Monday, September 19, 2011 3:22 AM
  • I'm having the same issue. The first time I tried to add the device the tablet displayed an 8 digit passcode. I entered it and it did not connect to the device. I didn't write the passcode down because I expected to see it the 2nd time I tried to connect but now I just see a message prompting me to "enter a passcode" with a tooltip indicating it might be on my keyboard (which it's not) or in the documents that came with it (checked and it's not in those either). Regular USB keyboards work fine.
    Monday, September 19, 2011 7:25 PM
  • When it prompted you for the password, were you in bluetooth pairing mode? That is, did you hold down the power button until the blue light on the keyboard repeatedly flashed? If so, did you remember to enter it on the computer first? On the soft keyboard, type 0000, press enter. Then on the physical keyboard, type 0000, press enter.

    Monday, September 19, 2011 7:46 PM
  • Hi, did you enter "0000" on both the UI and also in the physical keyboard. It should pair only if you do that.

    Thanks,

    EricLi [MSFT]

    Monday, September 19, 2011 7:52 PM
  • That worked. On the UI keyboard it was "0000" then clicking the "Add" button (Enter wasn't wired up to it for some reason). Entering "0000" + Enter on the physical keyboard connected the devices.

    Thanks guys!

    Monday, September 19, 2011 8:21 PM
  • Thanks all, I have the same trouble. I fixed that with the following sequence.

    Power on keyboard with 5 seconds button on. Keyboard will start with LED slow two flash mode.

    Go to Device menu and "Add a device". Select Keyboard.

     

    On the UI keyboard, input "0000" (no enter), and touch "add".

    Then on the physical keyboard, input "0000" + Enter.

    It should make start connecting.

    The UI changes into connecting view. But it already connected.

    You can test with pushing "Windows Key" on the physical keyboard.   

    After connected, both LED on keyboard was automatically turned off. It is still working normally.

     

    Tuesday, September 20, 2011 12:09 AM
  • Yup... that did it.  Thanks!

    Mark

    Tuesday, September 20, 2011 2:23 AM
  • Tuesday, September 20, 2011 2:58 PM
  • Thanks, Frank and Tim! I had to go through the removal procedure you outlined in your answer (through "Devices and Printers") and then I could pair the keyboard again...

     

    Do you know why it went in that 'zombie' mode? What did I do that caused this and how can I prevent that from happening again?

    Wednesday, September 28, 2011 1:25 AM
  • This does not work when using Windows 7 Ultimate.

    Anyone have a solution to connect the device when using Windows 7 instead of the Windows 8 Preview build?

    Friday, November 18, 2011 7:11 PM
  • Screwba,

    same for me. I just successfully paired the keyboard with another machine, so it really must be the Win 7 Bluetooth driver.

    Will try with the one from Samsung web site, and keep you posted.

    Regards,

    Stefan

    Monday, November 21, 2011 7:54 PM
  • Indeed: the Bluetooth driver from the Samsung website does the trick, the keyboard pairing works.

    Download it here: http://www.samsung.com/us/support/downloads/tablet-pcs/XE700T1A-A03US

    It's the "Bluetooth (Driver) (ver.2.0.0.0)" download, 156.52MB.

     

    Regards,

    Stefan

    Monday, November 21, 2011 11:03 PM
  • Alright, I'm afraid I still need assistance here... like everyone the first pairing worked like a charm, then I had to go through the procedures outlined above (i.e. remove the keyboard from the standard control panel, use the 0000 passcode trick...) because the pairing would break from time to time (why??)

     

    Now I am at the point where neither the Metro-style "Add a Device" nor the classic one will even find/list the keyboard as an available device (and believe me, the keyboard is in pairing mode and the batteries are good).

     

    If I go the good old Device Manager, however, I can see SAMSUNG Keyboard under the Bluetooth category. But as you know, you cannot enter pairing settings  from here. So I tried uninstalling the keyboard from here and rebooting, so that the "Add a Device" can "re-detect" it... without success.

     

    Any other idea??? Will anybody from Microsoft and/or Samsung ever publish a complete troubleshooting guide for this? Or better yet: fix it through Windows Update? Thanks in advance...

    Tuesday, November 29, 2011 5:36 AM
  • Stefan,

    I had this driver installed already but for giggles tried to pair it again and it worked.  Go figure...I fought with this for 2 days so I decided it must just not be working on my tablet...

    Needless to say, I am a happy camper now.

    This is now my primary computer.  I am not worried about the GSM support as I am in Canada and everywhere I go has wireless which I can connect to or I can tether using my Android phone.  When this device gets released in Canada, I will probably look at getting some plan for it though.

    Thanks all.

    -S


    -S
    Friday, December 9, 2011 4:14 PM
  • Ugh ... I'm hit with this problem too.  The 0000 trick isn't working, reinstalling the driver isn't working ... this has been my biggest issue with the DP so far.. 
    Saturday, January 14, 2012 10:09 PM
  • exactly same for me

    After bluescreen, I can not get the pairing back. Wasted 4 h for that

    Sunday, June 10, 2012 9:29 AM
  • I'd tried this on the RTM version and it didn't work with a code of  0000 until I used an 8 digit code.. in my case  12345678

    Also there is no "add" button, so I used  the "next" button

    Friday, August 17, 2012 7:13 PM
  • I had the same problem and none of these solutions worked for me so I took the batteries out of the keyboard for like 15 seconds and then put them back in and tried the pairing again and it worked like brand new prompting me with a new passcode

    Saturday, November 10, 2012 2:17 PM
  • Thanks! I just solved my bluetooth mouse issue on windows 8.1 system following your steps :)
    Thursday, November 14, 2013 5:52 AM
  • Yes, still works for getting the iHome keyboard to work, running the iHome  Mac Bluetooth keyboard with keypad on my new Dell Venue 11 Tablet.  Works great.
    Thursday, November 20, 2014 9:22 PM
  • I'm having the same problem. What wireless keyboard do u have, I have a accessorize two tune keyboard. I"ve tried 000, 1234. Nicole came with keyboard.
    Saturday, December 27, 2014 4:34 AM
  • (Sorry I had to put links to the photos. Microsoft wouldn't let me post photos)

    **Basic info - I'm running an ASUS Essentio with windows 10 (same process on 8.1 and 7 also if I recall)

    I have a wired keyboard set up presently -- makes it much easier.

    My PC didn't come with bluetooth for some reason, so I am connecting using one of those $2 adapters.(which works just fine if you ever need one)

    And the Keyboard I am setting up is an old Apple Bluetooth Keyboard. (1st gen bluetooth keyboard from 2003- if mine works, yours will too)

    :::NOW::::

    Easiest way to solve this:

    1. Go into Bluetooth settings. 

    2. Make bluetooth keyboard discoverable

    3. Find your keyboard that you would like to pair and click it. --It should say ready to pair.

    4. Click Pair and you should see this::

    https://social.msdn.microsoft.com/Forums/getfile/756112

    NOTE: If this screen does not pop up, what worked for me was to press the space bar followed by the enter key and it popped right up.

    5. Now, on your BLUETOOTH keyboard, press the numbers 0000, followed by the Enter key.

    https://social.msdn.microsoft.com/Forums/getfile/756112

    --Nothing will change on the screen.

    https://social.msdn.microsoft.com/Forums/getfile/756117

    6. Immediately after, on your wired keyboard that you have plugged in (or OSD keyboard) press the same numbers 0000, followed by the Enter key.

    https://social.msdn.microsoft.com/Forums/getfile/756118

    Don't touch anything (especially either keyboard) and in about 15-30 seconds you will see this:

    https://social.msdn.microsoft.com/Forums/getfile/756121

    and SUCCESS!

    https://social.msdn.microsoft.com/Forums/getfile/756122

    The first few times I did this it took several tries...so don't give up..it'll work.




    • Edited by BradKCulp Wednesday, December 9, 2015 6:52 AM
    • Proposed as answer by BradKCulp Wednesday, December 9, 2015 6:52 AM
    Wednesday, December 9, 2015 6:43 AM
  • Im using my Macbook Pro & Mac Keyboard ( AKA HID Keyboard ) - 0000 wouldn't work for me, but using 8 0's then pressing enter worked perfectly ( I entered the code on the screen first using my built in keyboard - then entered the 8 0's on the bluetooth keyboard and pressed enter) 

    Hope this works for someone else too! 

    • Proposed as answer by K_S_Q Sunday, January 28, 2018 9:47 PM
    Monday, December 14, 2015 8:10 PM
  • I had exaclty the same issue.

    I had the keyboard paired and now is asking me a passcode.

    I entered 0000 'enter' on the tablet, and when it started charging, I typed 0000 'enter' on the keyboard and suddenly the devices got connected to the tablet.

    cheers,

    *i know i respond to an old message, but i hope this will help other people to find a solution

    • Proposed as answer by RebelNC Friday, January 18, 2019 9:11 PM
    Monday, May 9, 2016 9:09 PM
  • Perfect!!  Thanks

    Saturday, July 30, 2016 12:59 AM
  • Yes that did it.   Thanks..  I know it may seem obvious to some but with out clear instructions from either apple or MSFT, how the hec is a user suppose to know to take the next step and enter same code in keyboard and then enter again.  Thanks again.

    jp

    Monday, August 29, 2016 6:39 PM
  • Thank.  It works.

    You need to enter same passcode into two devices (keyboard to connect and computer).  It is not necesary to be "0000".

    Thanks a lot Mark Michaelis.

    Regards

    Wednesday, December 7, 2016 1:01 AM
  • Just joined to say Thanks, Asus support was actually going to have me do a clean install to fix.

    This did it :)

    Thursday, February 9, 2017 9:30 PM
  • Short story:  It has to be done in a certain order and fairly quickly or it times out with the error message to try your passcode again.  If you get this error you have to change the passcode and try again.  

    Long Story:  On mine, with the keyboard in paring mode, I typed in 0000 (could be any number but that one was easy) on my tablet in the Windows 10 bluetooth settings (Settings/ Devices/ Bluetooth and other devices/ Add Bluetooth/ Bluetooth-Mice, Keyboard etc.). Once I clicked the connect button on the tablet I only had 3 seconds to enter the same passcode on my Kensington keyboard and hit enter.  If you fail to enter your passcode with in the allotted time you have to choose anther passcode and try again.  That is where it was messing me up.  

    First I typed too slowly (messed up on the timing). I was using the same 0000 and it kept saying incorrect passcode even though I knew I was typing it in correctly and within correct timing but got same error (needed new passcode).  I changed passcode to 1234 but failed again because I typed 1234 in the keyboard before I clicked on Connect (messed up on the certain order).  I finally changed passcode to 0000 again, clicked on connect in windows and quickly typed 0000 on the Kensington keyboard and hit enter......  success.  All of this trial and error took about 2 1/2 hours.  Hope it is less for the rest of you.  

    Tuesday, May 23, 2017 3:49 PM
  • Thank you so much! This worked! I just had to press 'or try typing it on your keyboard' and it gave me a passcode and I typed it correctly and voila! It worked!

    The problem came because I typed the passcode wrong 3 times before. -_-

    Friday, June 9, 2017 12:40 AM
  • On the UI keyboard, input "0000" (no enter), and touch "add".

    Then on the physical keyboard, input "0000" + Enter.

    Legend, Thank You
    Monday, June 12, 2017 10:34 AM
  • I'm struggling with this one. I know I've been through this before, and gotten it to work, but I think that was when I was still using Win7.

    In Windows 10, there is no "add" button. My Dell Bluetooth keyboard was paired fine for a couple of years, but this afternoon, it decided to unpair. Fresh batteries installed.

    Any suggestions welcome. I find the keyboard on my laptop barely usable and downright painful to my wrists.

    Help, please!

    Saturday, July 22, 2017 11:29 PM
  • Works with Win10. THANK YOU !!!
    Sunday, August 13, 2017 11:59 AM
  • Thanks I had the same problem followed your suggestion and Bam...Thxs again.
    Thursday, September 14, 2017 12:08 PM
  • None of these suggestions worked for me.  I noticed my Belkin keyboard has a "pair" key on it.  I kept pushing it until I generated a passcode on the Amazon Fire.  I entered that passcode on the Fire and the keyboard.  Viola!!! It worked!

    Hope this helps someone who was not successful with all the other suggestions!

    Saturday, November 4, 2017 10:53 PM
  • Thank you very much for this info. It really worked. i have been battling with my keyboard pairing but now it is working.

    Tuesday, November 28, 2017 5:10 PM
  • This worked for me, thanks
    Saturday, December 30, 2017 12:31 AM
  • "Hope this works for someone else too!"

    Man, you made my day, 2 actually.

    Pairing apple keyboard to windows 10, when windows driver is not showig passkode works exacy as described above : put any 8 digit passcode in driver field asking for keyboard PIN, using build in or any other working keyboard, then click pair, after driver starts process of pairing put the same 8 digit passcode on your Apple keyboard and hit enter. It sould say paired now and you are all set.

    Nikp thank you again for this hint.

    BTW I have another macbook with the same release of windows installed and on this second one driver is first showing passcode that you have to enter on apple keyboard .... ;-0


    • Proposed as answer by K_S_Q Sunday, January 28, 2018 9:46 PM
    • Edited by K_S_Q Sunday, January 28, 2018 9:48 PM
    Sunday, January 28, 2018 9:46 PM
  • That worked for me too! I just now hooked up my Anker bluetooth keyboard to my computer, which is wired to diplay on my tv. I needed something wireless, so I dug out this old thing. The trick with entering 0000 on both the windows user interface and the keyboard seems to be universal to all these kinds of glitches. Maybe the root problem is on windows' end?

    Thanks for the help Eric! Who I think was the first one to say that Idea.

    Saturday, February 17, 2018 3:32 AM
  • this worked for me too!

    Tuesday, March 6, 2018 7:29 PM
  • Worked like a charm.  0000 on the pc, 000 on the Bluetooth.  Make sure the Bluetooth keyboard is in paring mode.

    By the way, I am typing this on the Bluetooth Keyboard.

    Thanks

    Saturday, March 10, 2018 10:31 PM
  • Ich liebe euch, es hat funktioniert! <3

    Wollte meine kleine MINI Bluetooth Tastatur von Sansun schon wegschmeißen !!!

    1. einfach bei dem TV "0000" eingeben, auf Enter klicken

    2. innerhalb 3 Sekunden auf der Tastatur (vorheriger Kopplungs-Modus an) auch "0000" und Enter

    3. SOFORT IST DIE TASTATUR GEKOPPELT UND EINSATZBEREIT- YEEEES ;-))))))


    • Edited by Glücklich Tuesday, March 13, 2018 2:22 PM
    Tuesday, March 13, 2018 2:19 PM
  • Obrigada.

    Funcionou comigo. Está a trabalhar perfeitamente.

    Tuesday, March 27, 2018 8:40 AM
  • I did as you said but it would not work.

    So I tried the following and it worked for me.

    8 zeros on the UL keyboard And clicked connect

    Then did 8 zeros on the apple keyboard and hit enter.. 

    It work..

    Thanks for the direction,

    Wednesday, March 28, 2018 6:23 PM
  • Eric You solved a problem that the Microsoft technician could not do in 45 minutes he even tried by remote, thank you so much for your recommendation worked perfectly in seconds much appreciated, and to all you guys with this problem here is your answer try it and then thank Eric
    Tuesday, April 10, 2018 5:32 PM
  • Thanks for the tip as the method actually work
    Monday, April 16, 2018 9:02 AM
  • yeah it worked ...thanks

    Thursday, May 31, 2018 7:49 PM
  • II followed your directions and it worked.  The key was to make sure you do not miss any of the steps.  In particular, it is important to use the tablet keyboard to enter the four zero's "0000", then use the keyboard to enter the same.

    Thank you, Bill

    7-16-18

    Tuesday, July 17, 2018 3:32 AM
  • that's the only thing that worked, thanks for saving the day :)
    Saturday, September 1, 2018 3:49 PM
  • "Hope this works for someone else too!"

    Man, you made my day, 2 actually.

    Pairing apple keyboard to windows 10, when windows driver is not showig passkode works exacy as described above : put any 8 digit passcode in driver field asking for keyboard PIN, using build in or any other working keyboard, then click pair, after driver starts process of pairing put the same 8 digit passcode on your Apple keyboard and hit enter. It sould say paired now and you are all set.

    Nikp thank you again for this hint.

    BTW I have another macbook with the same release of windows installed and on this second one driver is first showing passcode that you have to enter on apple keyboard .... ;-0


    This one did the trick for me - thx!
    Saturday, October 20, 2018 12:15 AM
  • You can also use the Bluetooth device pairing wizard to connect your devices. Click Start, type: devicepairingwizard then hit Enter. Ensure Bluetooth is enabled on your device, so it is discoverable by the wizard. Select the device in the Add a device window, then click Next to begin pairing. Once your device is paired, it will be displayed in the Devices and Printers window.

    This link below is where I got the information from and has more instructions with pictures and diagrams as well.

    Hopes this works for any one who has this problem after 11/07/2018 and googled the words "anker a7726 pin"

    https://www.groovypost.com/howto/pair-a-bluetooth-device-with-windows-10/

    Wednesday, November 7, 2018 3:14 PM
  • Thanks! This solved my problem.

    Shine on!


    Sasa

    Tuesday, December 4, 2018 11:19 AM
  • This worked. Thanks.
    Friday, December 7, 2018 2:58 PM
  • I have paired this Keyboard to many computers and it always autogenerated a Key to type on the keyboard. I tried what you said and it worked. SO I guess it has changed now and I am defining my own key. 

    Genius.

    Thanks so much. I was losing my mind.

    Thursday, December 13, 2018 3:26 PM
  • Thank you so mutch!

    i was having the same problem with my Trust Wireless Keyboard.

    I entered first in the windows popup 000+ connect button

    and then right after that pressed 000+enter on my wireless keyboard and spammed it.

    It made a connection!

    Thanks a lot.!

    Sem van de Beld

    The Netherlands

    Wednesday, December 26, 2018 8:06 AM
  • Thank you! this has been driving me nuts - can't believe that worked but am happy it did!!!!
    Saturday, January 5, 2019 4:29 PM
  • turn keyboard on

    press connect on keyboard

    connect to device

    do not type on screen,

    type on physical keyboard: 0000 hit Enter

    now go to your devise that you are connecting you keyboard to

    now type on the device touch keyboard: 0000 hit enter it should connect

    if not restart all devices

    make sure keyboard is fully charged as it may not want to connect first time

    Thursday, January 10, 2019 10:44 AM
  • It works!  Thanks!
    Friday, January 25, 2019 3:52 PM
  • I had the keyboard paired and working yesterday, but today it wouldn't connect. I removed it and tried to re-add it, but now its asking me for a passcode. I tried 0000 but that didn't work...


    Saturday, January 26, 2019 11:43 AM
  • What did it?  Can you provide the answer
    Saturday, June 29, 2019 10:01 PM
  • What worked?

    Saturday, June 29, 2019 10:02 PM
  • This worked for my older Samsung BT keyboard.  It has never asked me for a pairing id for the keyboard to date, but I suppose a driver was updated and behaviour changed.  Eric's suggestion is correct.  Enter a 4 digit id on the UI, then on the keyboard.  I had to, for some reason, used 1234, first on the UI (with enter) then on the keyboard (with enter), in that sequence.

    Thanks all.

    Tuesday, February 4, 2020 3:49 PM