none
Kinnect runtime 1.6 Install error RRS feed

  • Question

  • i've got window with something like this

    "Install Failed, An error occurred during installation. Please check the setup log for more infromation".

    but no error infromation in this window.
    it seems that SpeechPlatformRuntime_x86.msi and SpeechPlatformRuntime_x64.msi intalling correctly (because there is no errors in it logs) so error occure when MSKinectLangPack_enUS.msi installing.
    I tried install with adminitstrative privileges but there is still the same.

    There is a log file:
    Setup_20121129171058_2_enUSLangPack.txt
    === Verbose logging started: 29.11.2012  17:11:05  Build type: SHIP UNICODE 5.00.7600.00  Calling process: F:\Install\KinSDK\KinectSDK-v1.6-Setup.exe ===
    MSI (c) (7C:48) [17:11:05:224]: Resetting cached policy values
    MSI (c) (7C:48) [17:11:05:224]: Machine policy value 'Debug' is 0
    MSI (c) (7C:48) [17:11:05:224]: ******* RunEngine:
               ******* Product: C:\ProgramData\Package Cache\{8AAA44BB-487E-4D01-AF76-484ACB90DBFE}v11.0.7400.336\MSKinectLangPack_enUS.msi
               ******* Action:
               ******* CommandLine: **********
    MSI (c) (7C:48) [17:11:05:225]: Client-side and UI is none or basic: Running entire install on the server.
    MSI (c) (7C:48) [17:11:05:225]: Grabbed execution mutex.
    MSI (c) (7C:48) [17:11:05:227]: Cloaking enabled.
    MSI (c) (7C:48) [17:11:05:227]: Attempting to enable all disabled privileges before calling Install on Server
    MSI (c) (7C:48) [17:11:05:227]: Incrementing counter to disable shutdown. Counter after increment: 0
    MSI (s) (00:20) [17:11:05:230]: Running installation inside multi-package transaction C:\ProgramData\Package Cache\{8AAA44BB-487E-4D01-AF76-484ACB90DBFE}v11.0.7400.336\MSKinectLangPack_enUS.msi
    MSI (s) (00:20) [17:11:05:230]: Grabbed execution mutex.
    MSI (s) (00:4C) [17:11:05:231]: Resetting cached policy values
    MSI (s) (00:4C) [17:11:05:231]: Machine policy value 'Debug' is 0
    MSI (s) (00:4C) [17:11:05:231]: ******* RunEngine:
               ******* Product: C:\ProgramData\Package Cache\{8AAA44BB-487E-4D01-AF76-484ACB90DBFE}v11.0.7400.336\MSKinectLangPack_enUS.msi
               ******* Action:
               ******* CommandLine: **********
    MSI (s) (00:4C) [17:11:05:231]: Note: 1: 2219
    MSI (s) (00:4C) [17:11:05:232]: MainEngineThread is returning 1620
    MSI (s) (00:20) [17:11:05:232]: User policy value 'DisableRollback' is 0
    MSI (s) (00:20) [17:11:05:232]: Machine policy value 'DisableRollback' is 0
    MSI (s) (00:20) [17:11:05:232]: Incrementing counter to disable shutdown. Counter after increment: 0
    MSI (s) (00:20) [17:11:05:232]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\Rollback\Scripts 3: 2
    MSI (s) (00:20) [17:11:05:232]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\Rollback\Scripts 3: 2
    MSI (s) (00:20) [17:11:05:233]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\InProgress 3: 2
    MSI (s) (00:20) [17:11:05:233]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\InProgress 3: 2
    MSI (s) (00:20) [17:11:05:233]: Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied.  Counter after decrement: -1
    MSI (s) (00:20) [17:11:05:233]: Restoring environment variables
    MSI (c) (7C:48) [17:11:05:233]: Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied.  Counter after decrement: -1
    MSI (c) (7C:48) [17:11:05:234]: MainEngineThread is returning 1620
    === Verbose logging stopped: 29.11.2012  17:11:05 ===

    maybe key of problem is that i have russian localization of Windows?

    i tried this recipes, but still the same
    http://social.msdn.microsoft.com/Forums/en-US/kinectsdk/thread/08353919-7372-41ed-82d3-007dd525ab95
    • Edited by brachistochron Thursday, November 29, 2012 1:46 PM i forget some information
    Thursday, November 29, 2012 1:44 PM

All replies

  • I see:

    ERROR_INSTALL_PACKAGE_ INVALID 1620 This installation package could not be opened. Contact the application vendor to verify that this is a valid Windows Installer package.

    Have you tried re downloading the install package?

    Tuesday, December 4, 2012 5:39 AM
  • Trying to re-download the file would help a lot as Todd has suggested as corrupt files usually cannot be opened correctly.

    Once you eliminate the impossible, whatever remains, no matter how improbable, must be the truth. - "Sherlock holmes" "speak softly and carry a big stick" - theodore roosevelt. Fear leads to anger, anger leads to hate, hate leads to suffering - Yoda. Blog - http://www.computerprofessions.co.nr


    • Edited by The Thinker Thursday, December 6, 2012 7:53 PM
    Thursday, December 6, 2012 7:53 PM
  • Yep, three times
    it seems that speech packet installs correctly, and error raised on next step
    Wednesday, March 13, 2013 7:52 AM

  • please, check my answer
    Wednesday, March 13, 2013 7:53 AM
  • i found solution
    there are problem in ProgramData\Package Cache\
    it seems that it was broken
    i just delete all files from "Package Cache" folder and problem was solved!
    • Proposed as answer by The Thinker Wednesday, March 13, 2013 6:55 PM
    Wednesday, March 13, 2013 1:28 PM
  • i found solution
    there are problem in ProgramData\Package Cache\
    it seems that it was broken
    i just delete all files from "Package Cache" folder and problem was solved!

    disk cleanup also has an interface for cleaning up temporary files too but glad you got it solved! (Not just temporary internet files but other temporary files too).

    Once you eliminate the impossible, whatever remains, no matter how improbable, must be the truth. - "Sherlock holmes" "speak softly and carry a big stick" - theodore roosevelt. Fear leads to anger, anger leads to hate, hate leads to suffering - Yoda. Blog - http://www.computerprofessions.co.nr

    Wednesday, March 13, 2013 6:54 PM