none
Customer can't install app from store because "x64 required" has a red X RRS feed

  • Question

  • Our app is published in the Windows 10 app store and has been downloaded and successfully installed a few times.  One new customer has a new PC, and on our app store page it won't install.  The screen says:

    "See 'Available on' below for devices this product runs on.  It won't run on this one."

    In the "Minimum" section, for "Architecture" it says "X64 required" (which is correct) but it has a red "X" next to it, instead of a green check mark.  Everything else is green check marks.

    They sent me a screenshot of the Windows "System Information" screen, and for "System Type" it says "x64-based PC".  It's a Windows 10 OS, and that requirement has the green check mark.  For reference, this is the computer: http://www8.hp.com/us/en/products/desktops/product-detail.html?oid=15287510 

    I see no way to troubleshoot this issue!  Also I see no way to work around it since that requirement seems to be hard-coded and unchangeable in the store.

    What can we do?

    JB

    Friday, August 4, 2017 12:17 AM

All replies

  • Hi JB,

    Does the red "X" also happens to other x-64 based machine?

    If so, you could create a support ticket through your developer account so that support can review your specific scenario.

    If not, only that customer has this issue, please have that customer contact consumer support or post a question at answers forum so that he will be assisted appropriately. 

    Thanks you.

    Best regards,

    Mattew Wu


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, August 4, 2017 6:40 AM
    Moderator