none
Help .NET 4.5 Framework Installation Not Working!! RRS feed

  • Question

  • Hi , I am trying to instal .NET 4.5 Framework. It is not installing at all. It's been saying 'Downloading Windows6. 1-KB858488-V6001-x64.msu' for the past hour. I'm on Windows 7.

    Also this is the error log:

    Number of applicable items: 12
    Applicability Result Count
    Action: System Requirement Checks
    Action: Disk space check for items being downloaded
    Action complete
    Action: Enumerating incompatible processes
    Action complete
    Action: Enumerating incompatible services
    Action complete
    Action complete
    Action: Downloading and/or Verifying Items
    C:\7eaa936070f51fe215afb2d75e4c56\SetupUtility.exe: Verifying signature for SetupUtility.exe
    C:\7eaa936070f51fe215afb2d75e4c56\SetupUtility.exe Signature verified successfully for SetupUtility.exe
    C:\7eaa936070f51fe215afb2d75e4c56\SetupUtility.exe: Verifying signature for SetupUtility.exe
    C:\7eaa936070f51fe215afb2d75e4c56\SetupUtility.exe Signature verified successfully for SetupUtility.exe
    C:\7eaa936070f51fe215afb2d75e4c56\SetupUtility.exe: Verifying signature for SetupUtility.exe
    C:\7eaa936070f51fe215afb2d75e4c56\SetupUtility.exe Signature verified successfully for SetupUtility.exe
    C:\7eaa936070f51fe215afb2d75e4c56\SetupUtility.exe: Verifying signature for SetupUtility.exe
    C:\7eaa936070f51fe215afb2d75e4c56\SetupUtility.exe Signature verified successfully for SetupUtility.exe
    Action: Downloading Item
    Action: Downloading http://go.microsoft.com/fwlink/?LinkId=249118&clcid=0x409 using BITS
    Error from JobError Callback : hr= 0x80072efe Context=5 Description=The connection with the server was terminated abnormally . Percentage downloaded = 0
    Error from JobError Callback : hr= 0x80072efe Context=5 Description=The connection with the server was terminated abnormally . Percentage downloaded = 0
    Error from JobError Callback : hr= 0x80072efe Context=5 Description=The connection with the server was terminated abnormally . Percentage downloaded = 0
    Error from JobError Callback : hr= 0x80072efe Context=5 Description=The connection with the server was terminated abnormally . Percentage downloaded = 0
    Action complete
    Action: Downloading http://go.microsoft.com/fwlink/?LinkId=249118&clcid=0x409 using WinHttp
    WinHttpDetectAutoProxyConfigUrl failed with error: 12180
    WINHTTP_CALLBACK_STATUS_REQUEST_ERROR error: error=12030, result= 1. Percentage downloaded=-2147483648
    Action complete

    Wednesday, January 30, 2013 12:27 AM

Answers

  • If you got a repair option, 4.5 may be (partially, at least) installed.

    Verify your 4.5 with this tool:

    http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

    Run the tool with 4.5 selected, then post the first 15 lines AND the LAST 15 lines of the tool log here.

    Try downloading the standalone installer here:

    http://download.microsoft.com/download/b/a/4/ba4a7e71-2906-4b2d-a0e1-80cf16844f5f/dotnetfx45_full_x86_x64.exe

    The link from Barry's reference.

    After you download it, check the SHA1 and MD5 checksums against these values:

    MD5 = d02dc8b69a702a47c083278938c4d2f1

    SHA1 = b2ff712ca0947040ca0b8e9bd7436a3c3524bb5d

    If your values match, run the installer.

    Wednesday, January 30, 2013 5:57 PM

All replies

  • Hi ishuvaibhav,

    Thanks for your post.

    Your issue may due to your network.

    ERROR_WINHTTP_AUTODETECTION_FAILED
    12180

    Returned by WinHttpDetectAutoProxyConfigUrl if WinHTTP was unable to discover the URL of the Proxy Auto-Configuration (PAC) file.

    Please refer to this thread for a standalone installer http://social.msdn.microsoft.com/Forums/en/netfxsetup/thread/5fe0d9d9-420d-473d-976e-b079aefc0505

    Or check your network and reinstall again.

    Regards,


    Barry Wang
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Wednesday, January 30, 2013 7:06 AM
    Moderator
  • Ok,I still can't install it. It stops right at Downloading Windows6. 1-KB858488-V6001-x64.msu.

    But. it gave me an option to remove .net 4.5 or to repair .net 4.5

    I chose repair. Please help. Also I rebooted my router. I then speed tested it on speedtest.net I got 4.83mb/s and it said 99% faster than all of Canada. So I don't think I have a network problem.

    Wednesday, January 30, 2013 4:31 PM
  • If you got a repair option, 4.5 may be (partially, at least) installed.

    Verify your 4.5 with this tool:

    http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

    Run the tool with 4.5 selected, then post the first 15 lines AND the LAST 15 lines of the tool log here.

    Try downloading the standalone installer here:

    http://download.microsoft.com/download/b/a/4/ba4a7e71-2906-4b2d-a0e1-80cf16844f5f/dotnetfx45_full_x86_x64.exe

    The link from Barry's reference.

    After you download it, check the SHA1 and MD5 checksums against these values:

    MD5 = d02dc8b69a702a47c083278938c4d2f1

    SHA1 = b2ff712ca0947040ca0b8e9bd7436a3c3524bb5d

    If your values match, run the installer.

    Wednesday, January 30, 2013 5:57 PM