none
Kinect service shutting down RRS feed

  • Question

  • I have been developing Kinect v2 applications over the last year. Last week, while working on the latest version of the app, I found out the Kinect service was shutting down and then turning back up, at which point my Windows 10 PC notified me that a Kinect device had been plugged in. After these 10-15 seconds in which the sensor is not available, my application resumes and everything is fine. This seems to happen quite randomly and not too often.

    After debugging my code and not being able to find anything wrong with it I tried with Kinect Studio and I saw that the same bug occurred. The difference is that Kinect Studio can't recover from the crash so you have to restart it to have it running again... 

    Any thoughts on what might be causing this? By the way it happens on several machines and randomly. And keep in mind that the app I'm talking about has been around for a while and this is the first time I'm running into this issue.

    Thanks,

     
    Thursday, September 1, 2016 8:59 PM

All replies

  • Might the sensor be overheating? Honestly if it happens on a variety of machines and randomly, it hints at a sensor problem.

    Tuesday, September 6, 2016 10:13 AM
  • It happens with two different sensors. No, they are not overheating. It sometimes happens right away.
    Wednesday, September 7, 2016 4:24 PM
  • Are we talking about desktops? If not, make sure you have the high performance power plan selected with USB Link State disabled.

    I can confirm Windows 10 is compatible,as I'm running my Kinect app on my home laptop.Might be a dumb question but I'll ask anyway, you do have the 64bit version of Win10 right?

    Are you sure it's a USB3 port you are connecting to? Also, are there any other devices in the same bus?

    Do you have any antivirus installed? Can you check if it's flagging KinectService as malicious somehow and create an exception?

    PS: I just noticed you mentioned Win10 PC, so at least one is a desktop. USB Link State is a global setting though, so please check if its disabled in the Advanced Settings of you current power plan.


    PS2: Please check this link prior to replying here. It's an official troubleshooting guide. Check out the last post. I think it might be similar to your case, or exactly it. Let me know.
    Wednesday, September 7, 2016 6:01 PM
  • Same problem to me, but a different situation. The same problem happens when I try to run my Kinect app attached a different matchine using the Windows Remote Desktop app. Interestingly, if I run the Kinect app directly, I mean, from the machine Kinect is attached to, then the message never appears. I have checked that the same problem happens for the Kinect studio provided by SDK. Windows 10 on all the machines...I really want to block the message when I run my Kinect app on a remote machine. Is there any solution to avoid the problem? Thanks.
    Sunday, September 11, 2016 11:10 AM
  • I have to say, NPatch, my hat is off to you. You totally fixed this exact issue for me.  I've been porting my K4W2 app ( http://holofunk.com ) off of SharpDX, because Win10 finally left DX10 behind (ironically enough) and my app was using the SharpDX XNA layer built on DX10. 

    Ported everything to FNA and finally tried running it tonight, and the Kinect was starting up and shutting down over and over as my app tried to run.  My app was also getting an E_FAIL from MultiSourceFrameRefereence.AcquireFrame().

    Having never seen this before, I was gloomy, but I saw your post and whammo. Under Advanced Power Options, my PCI State > Link State Power Management was "Off" already. But my USB Settings > USB selective suspend seting was "Enabled". That seemed very fishy, so I set it to "Disabled"... and my app started working, or at least got past the E_FAIL condition.  Running into other issues, but still, getting unblocked on the Kinect problem this quickly is a huge win. Thanks!  I would offer to buy you a beer, but you seem to be in Greece and I am in Seattle :-)


    Friday, September 16, 2016 6:19 AM
  • Awesome! Honestly though, Documentation around Kinect v2 is frustrating. I did nothing extravagant. Carmine has compiled a nice troubleshooting thread but this damn forum lacks stickies(I've submitted a suggestion but I doubt it's gonna go far).

    I think it used to be a link on the Documentation Overview page, but some of the helpful links there are broken.

    Otherwise you'd have found it much easier.

    PS: Cool application, followed you on twitter. as for the beer, drink one more for me and we're even.Glad you found a solution to your problem. :)

    Friday, September 16, 2016 7:31 AM
  • Thanks for your post.

    Unfortunately as I said before, the issue began popping up all of a sudden on multiple machines. It wasn't a configuration issue or wrong USB settings... The funniest thing is that on almost all of the computers we use, changing the settings as recommended in your reply seemed to have fixed the problem for now, but we have had a machine that drove us crazy... it turned out that on this specific machine we had to disinstall 3D Scan in order to have our Kinect app running correctly. Even funnier, this computer is the exact same model of another laptop we use and this problem only afflicted one machine... I wrote this down just in case someone still runs into problems with the Kiencect Service, try to get rid of the 3D Scan app and see if that helps.

    Monday, September 19, 2016 2:42 PM
  • 3D Scan???? Was it running in the background for some reason?

    Usually things malfunction when some other application that wants the sensor is active.

    Maybe that particular laptop has a weird usb controller and it doesn't play well with the Kinect service. Orr....for some reason your hardware+drivers is doing some weird thing to disrupt Kinect Service(perhaps on a gpu level instead of usb). I can't think of anything else at the moment.

    Monday, September 19, 2016 2:57 PM
  • I know right???!!!

    3D Scan app at one point was launching automatically after the Kinect Service was disconnected and reconnected. It was taking over the sensor at that point. I don't think we ever launched that app before. Anyways, things are under control now.

    Thanks a lot.

    Monday, September 19, 2016 3:18 PM
  • It's been a while since I have been dealing with this issue and I just wanted to share with you my situation and see what your feedback is. We are working with 4 high-end laptops and one desktop PC and two kinect sensors. As of today it looks like the problem with the sensor disconnecting and then quickly reconnecting could be due to sensor malfunction rather than driver issues or power management options. I have tried pretty much all sorts of power settings and run the sensors with different machines and the disconnection issue has always been quite unpredictable. Again, I think it is mostly due to a specific sensor that is not working properly. Over the next weeks I will run more testing and keep you updated.
    Friday, January 27, 2017 4:16 PM