locked
Wheres my Data at? (External DB connection not showing up in DataSources) RRS feed

  • Question

  • Hi,

    I have an external DB connectionstring defined in web.config for my ASP.NET auth witch i use for my membershipproviders. I want to use other tables from this connection, but the datasource is not visible in DataSources.

    How can I fix this problem so that I can use the allready existing connection? It would be a shame to have two connections to the same server.

    Monday, May 19, 2014 3:30 PM

All replies

  • Hi maflones,

    According to my experience, you need check the connection string on your side.

    Whether the connectionstring name is same with the connectionstring in the <provider> section.

    If you have any concern, please give your response.

    Regards

    Angie


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    • Marked as answer by Angie Xu Monday, May 26, 2014 1:20 AM
    • Unmarked as answer by maflones Wednesday, May 28, 2014 4:01 PM
    Thursday, May 22, 2014 9:49 AM
  • Hi,

    That is propably not the case here.

    When I add a new databaseconnection to DataSources the tables can be selected and used, but this connection is defined in web.config only. That is the only way i can get the membershipprovider to accept the ASP_NET tables properly.

    When i add the same tables in a new databaseconnection by "Add datasource" the proper way, it will not recognize these tables by their names, but rather rename them to "aspnet_Users1" instead of "aspnet_Users".

    And that is kinda annoying..

    Wednesday, May 28, 2014 4:07 PM