locked
Debugger issue in 2008 R2 RRS feed

  • Question

  • Not sure if this is the correct subforum, so please advise if necessary.

    I'm a fairly experienced SQL coder, but not much use when it comes to the admin side of things. Just installed the free version of Management Studio 2008 R2 and have connected to our database at our ISP from my home office.

    I can't even run a basic select statement without getting an message asking me to configure my firewall to open up TCP port 135 and UDP 4500/500. I opened those ports (do I need to reboot for them to really open? Dunno). One of the options on this message says I can cancel remote debugging, and when I do that, I get a second error message describing an inability to execute 'sp_enable_sql__debug' on the schema sys. It calls itself MS SQL Server Error 229. Googled to no avail.

    Now, I am able to return the top 1000 rows if I go through the object browser on the tables, but that's hardly helpful.

    I figure this has something to do with permissions, but I have no idea where to begin or what to look for. If there is something quick to do, that would be great. If I am going to need to get up to speed on some admin basics, could someone suggest a good resource? 

    Also, I need to know if there is a permissions setting that the ISP needs to grant me, or if I already have the capability of doing it myself.

    Thanks!

    Tuesday, February 1, 2011 11:14 AM

Answers

  • Hi,

    This could be because you are pressing the debug button (green 'Play' button) instead of the Execute button (with red exclamation mark). Debugging requires extra permissions which you don't seem to have.

    Debug is used to step through SQL code rather than just execute it.

    HTH

    Ben

    • Proposed as answer by WeiLin Qiao Thursday, February 3, 2011 2:45 AM
    • Marked as answer by WeiLin Qiao Wednesday, February 9, 2011 9:46 AM
    Wednesday, February 2, 2011 2:33 PM