none
Azure ServiceBus NuGet Package RRS feed

  • Question

  • I am trying to install this on a Visual Studio 2013 update 4 machine and getting an error that the Configuration Manager won't install because I am installing into a project that targets '.NETCore,Version=x4.51', but the package does not contain any assembly references or content files that are compatible with that framework.

    Should this work? Wondering what I am missing.

    I am just trying to get at ServiceBus queues from a windows store app.

    Thanks for any help you can provide.

    Friday, February 20, 2015 4:14 AM

All replies

  • The Service Bus client is actually targeted at 4.0 so this shouldn't be a problem. I think you need may need to do a VS Repair.
    Friday, February 20, 2015 6:57 PM
  • I think that is the wrong package for a Store app. What I am trying to do, is read/write to queues in a ServiceBus on Azure. I did find this packaged for messaging for managed apps, and can do what I want in a store app with this package. Thanks.

    https://www.nuget.org/packages/WindowsAzure.Messaging.Managed/

    There does not seem to be much doc for this subject at this time. Also, the doc is vague and conflicting. I did not see anything on the page for the ServiceBus package that said it would not work for a store app. But the configuration manager piece (needed for namespace management) won't install because of the .Net framework callout.

    Got my stuff going, can receive/send to Azure queues, so I am proceeding.

    Thanks again.

    Saturday, February 21, 2015 2:26 PM