none
Cannot be installed on systems with .net Framework lower than 2.0 RRS feed

  • Question

  • Hi

     

    Im trying to install a program and i get this error message..... "Cannot be installed on systems with .net Framework lower than 2.0"

     

    Im running on windows XP, Service Pack 3.  The current .net Framework installed is 4.0 (client profile + Extended)  I have uninstalled the .Net 4 framework both client & extended, i then restarted my laptop.  Once restarted i then redownloaded & installed the  .Net Framework 4.  Once i have done this i have tryed reinstalling the original program i want to install, again with faliure and the same above error message is displayed :-s

     

     

     

     

    Tuesday, August 30, 2011 3:19 PM

Answers

  • If that app specifically targets .NET Framework 2.0, installing 4.0 will not help. If the designers/developers of the app in question set it up to require a specific framework, it will not find and use a newer one.

    The framework version needed is part of the .NET Framework 2.0/3.0/3.5 setup. Although three "version numbers" are involved, this is all one framseork. 2,0 is the base. full. framework. 3.0 and 3.5 are extensions to 2.0.

    You'll need to install the whole thing. Fortunately, there is a cumulative update that will do the job for you:

    http://download.microsoft.com/download/2/0/e/20e90413-712f-438c-988e-fdaa79a8ac3d/dotnetfx35.exe

    Before you run this installer, please clean out your %temp% directory (that is the Temp directory you'll find under the user account you log on with to run the installer).

    Also, disable any AV/anti-malware/firewall software you have installed.

    Be sure to run the installer from your system administrator account.


    • Proposed as answer by Alexander Sun Thursday, September 1, 2011 9:07 AM
    • Edited by pvdg42 Friday, September 2, 2011 11:30 AM
    • Marked as answer by Alexander Sun Monday, September 5, 2011 2:34 AM
    Wednesday, August 31, 2011 4:43 AM