locked
Unable to start debugging. The system cannot find the file specified. RRS feed

  • Question

  • User366164 posted

    Visual Studio 2017. New C# "Blank App (Android)" - or any app. Yesterday everything ran fine. Today the build succeeds, the deploy succeeds, but when I try to debug I get "Unable to start debugging. The system cannot find the file specified." The log file is attached. I have tried using my physical device, the built-in Nougat emulator, and the Visual Studio emulators. The message is the same. I tried rebooting.

    Friday, March 9, 2018 4:56 PM

Answers

  • User278407 posted

    As Luminous_Dev figured out here:

    forums.xamarin.com/discussion/123640/xamlctask-error-on-new-cross-plat-solution

    make sure Mono Debugging for Visual Studio is enabled.

    Tools > Extensions and Updates> Mono Debugging for Visual Studio

    • Marked as answer by Anonymous Thursday, June 3, 2021 12:00 AM
    Monday, March 12, 2018 7:00 AM

All replies

  • User365835 posted

    having same issue after the vs2017 upgrade

    Saturday, March 10, 2018 11:32 AM
  • User278407 posted

    As Luminous_Dev figured out here:

    forums.xamarin.com/discussion/123640/xamlctask-error-on-new-cross-plat-solution

    make sure Mono Debugging for Visual Studio is enabled.

    Tools > Extensions and Updates> Mono Debugging for Visual Studio

    • Marked as answer by Anonymous Thursday, June 3, 2021 12:00 AM
    Monday, March 12, 2018 7:00 AM
  • User281760 posted

    Thank you ColtBauman - this solve my problem. Probably I accidentally deactivated it and then did not knew what the problem was.

    Thursday, March 29, 2018 8:20 AM
  • User272386 posted

    Thank you ColtBauman - this solve my problem as well, I had accidentally disabled as well, not knowing the consequences, VS popped up a message that Mono Debugging is making VS slow and i could disable it, so i did it and hence got into trouble. All is good now.

    Wednesday, May 9, 2018 10:41 AM
  • User24976 posted

    holy moley - just one more craziness to add to the Visual Studio update experience! Thanks for posting solution!! *Make sure you close/restart Visual Studio to realize the changes as with any extension. :smile: *

    Sunday, May 13, 2018 7:17 PM
  • User322157 posted

    @ColtBauman said: As Luminous_Dev figured out here:

    forums.xamarin.com/discussion/123640/xamlctask-error-on-new-cross-plat-solution

    make sure Mono Debugging for Visual Studio is enabled.

    Tools > Extensions and Updates> Mono Debugging for Visual Studio

    thank you very much.

    Tuesday, May 15, 2018 2:10 PM
  • User368675 posted

    Hello I have the same problem. I checked Mono Debugging for Visual Studio and found out that it is disabled. I enabled it and restarted VS 2017, and it is disabled again. I tried this several times (as administrator also) and can not enable Mono Debugging for Visual Studio. My version for VS 2017 is15.7.1 Thanks in advance.

    Thursday, May 17, 2018 6:35 AM
  • User368675 posted

    Repairing VS 2017 solved the problem. Mono Debugging is enabled now.

    Thursday, May 17, 2018 10:16 AM
  • User257861 posted

    @ColtBauman @epfirman The last time I had this problem I reinstalled visual studio to work again :-) This time I decided to try to find out what is happening. Thank you very much for this information!

    Thursday, May 31, 2018 9:38 PM
  • User322337 posted

    @ColtBauman said: As Luminous_Dev figured out here:

    forums.xamarin.com/discussion/123640/xamlctask-error-on-new-cross-plat-solution

    make sure Mono Debugging for Visual Studio is enabled.

    Tools > Extensions and Updates> Mono Debugging for Visual Studio

    Tks

    Friday, June 8, 2018 1:15 PM
  • User369699 posted

    @ColtBauman said: As Luminous_Dev figured out here:

    forums.xamarin.com/discussion/123640/xamlctask-error-on-new-cross-plat-solution

    make sure Mono Debugging for Visual Studio is enabled.

    Tools > Extensions and Updates> Mono Debugging for Visual Studio

    Thanks @ColtBauman

    Friday, June 22, 2018 9:28 PM
  • User369699 posted

    @ColtBauman said: As Luminous_Dev figured out here:

    forums.xamarin.com/discussion/123640/xamlctask-error-on-new-cross-plat-solution

    make sure Mono Debugging for Visual Studio is enabled.

    Tools > Extensions and Updates> Mono Debugging for Visual Studio

    Thanks @ColtBauman

    Friday, June 22, 2018 9:29 PM
  • User369949 posted

    @ColtBauman said: As Luminous_Dev figured out here:

    forums.xamarin.com/discussion/123640/xamlctask-error-on-new-cross-plat-solution

    make sure Mono Debugging for Visual Studio is enabled.

    Tools > Extensions and Updates> Mono Debugging for Visual Studio

    Worked for me idk, why that was disabled :'(

    Wednesday, June 27, 2018 12:46 PM
  • User167082 posted

    @ColtBauman said: As Luminous_Dev figured out here:

    forums.xamarin.com/discussion/123640/xamlctask-error-on-new-cross-plat-solution

    make sure Mono Debugging for Visual Studio is enabled.

    Tools > Extensions and Updates> Mono Debugging for Visual Studio

    Thanks. This solved my problem.

    Wednesday, June 27, 2018 1:24 PM
  • User368047 posted

    thanks, @ColtBauman, <3 <3

    Thursday, July 12, 2018 3:37 PM
  • User371821 posted

    I have 15.8.1 and it is not working

    Wednesday, August 22, 2018 1:02 AM
  • User368638 posted

    thanks mate it worked:)

    Wednesday, September 12, 2018 6:25 AM
  • User378321 posted

    @ColtBauman said: As Luminous_Dev figured out here:

    forums.xamarin.com/discussion/123640/xamlctask-error-on-new-cross-plat-solution

    make sure Mono Debugging for Visual Studio is enabled.

    Tools > Extensions and Updates> Mono Debugging for Visual Studio

    Thanks, very good. This is fix for me

    Thursday, October 4, 2018 7:52 AM
  • User31568 posted

    @ColtBauman said: As Luminous_Dev figured out here:

    forums.xamarin.com/discussion/123640/xamlctask-error-on-new-cross-plat-solution

    make sure Mono Debugging for Visual Studio is enabled.

    Tools > Extensions and Updates> Mono Debugging for Visual Studio

    @ColtBauman where can I find it in Visual Studio 2019?

    Can't find Tools > Extensions and Updates> Mono Debugging for Visual Studio

    Monday, June 10, 2019 12:35 AM
  • User309226 posted

    I'm using Visual Studio Enterprise 2017 version 15.9.15. I can't find Tools > Extensions and Updates> Mono Debugging for Visual Studio. Can anyone please help?

    Wednesday, October 16, 2019 3:24 AM
  • User393407 posted

    Same here, can't find Tools > Extensions and Updates> Mono Debugging for Visual Studio in Visual Studio Professional 2019 (Version 16.4.0). Can someone tell where this is please?

    Thursday, March 19, 2020 9:50 AM