locked
TextBox PlaceHolder

    Question

  • I have Windows 8.0 application which I upgraded to windows 8.1, and now I am trying to add Placeholder text to a textbox but it does not work!! the property is there but it does not work!!

            <TextBox Name="OrderNoTxt" PlaceholderText="Order #"  Width="400" Grid.Column="1" HorizontalAlignment="Left"  Grid.Row="2" Height="45" FontSize="20" InputScope="Number"/>

    if I start a new windows 8.1 app, the placeholder text in textbox works fine, but not on upgraded app from 8.0

    Is that a bug?


    Tariq

    Monday, March 17, 2014 3:10 PM

Answers

  • Hi Tariq,

    Sorry I can't reproduce, I created a textbox for win8.0 and retargeted the app to win8.1, set something in PlaceHolderText and everything works fine, can you share us your win8 textbox code? Or do I miss something?

    I use VS2012 Ultimate and VS2013 Ultimate.

    --James


    <THE CONTENT IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, WHETHER EXPRESS OR IMPLIED>
    Thanks
    MSDN Community Support

    Please remember to "Mark as Answer" the responses that resolved your issue. It is a common way to recognize those who have helped you, and makes it easier for other visitors to find the resolution later.

    Tuesday, March 18, 2014 3:12 AM
    Moderator
  • I tried too to create a test app and reproduce it, but I couldn't reproduce it which is disappointed, I will look closer at my Application to figure out what's wrong. The code is the same for both! thanks though and I will let u know.


    Tariq

    Tuesday, March 18, 2014 2:05 PM

All replies

  • Probably... is there any difference between the 8.0 and 8.1 control code?

    Matt Small - Microsoft Escalation Engineer - Forum Moderator
    If my reply answers your question, please mark this post as answered.

    NOTE: If I ask for code, please provide something that I can drop directly into a project and run (including XAML), or an actual application project. I'm trying to help a lot of people, so I don't have time to figure out weird snippets with undefined objects and unknown namespaces.

    Monday, March 17, 2014 7:07 PM
    Moderator
  • No the code is the same, probably it's a bug.

    thanks.


    Tariq

    Monday, March 17, 2014 7:49 PM
  • Hi Tariq,

    Sorry I can't reproduce, I created a textbox for win8.0 and retargeted the app to win8.1, set something in PlaceHolderText and everything works fine, can you share us your win8 textbox code? Or do I miss something?

    I use VS2012 Ultimate and VS2013 Ultimate.

    --James


    <THE CONTENT IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, WHETHER EXPRESS OR IMPLIED>
    Thanks
    MSDN Community Support

    Please remember to "Mark as Answer" the responses that resolved your issue. It is a common way to recognize those who have helped you, and makes it easier for other visitors to find the resolution later.

    Tuesday, March 18, 2014 3:12 AM
    Moderator
  • I tried too to create a test app and reproduce it, but I couldn't reproduce it which is disappointed, I will look closer at my Application to figure out what's wrong. The code is the same for both! thanks though and I will let u know.


    Tariq

    Tuesday, March 18, 2014 2:05 PM