none
Reportviewer is coming with two horizotal scrollbars and two vertical scrollbars RRS feed

  • Question

  • We are the reportviewer control that comes with the standard edition of visual studio 2005.

    The rendering is not the same in Firefox and I.E.

     In firefox reportviewer is coming with two horizotal scrollbars and two vertical scrollbars.

    it can be cured by two ways :

    1. using property AsyncRendering ="false"... but when i use this page nagivation buttons gets disable, even it gets distored in IE. (on using SizetoContent="true" in reportviewer report get started displayiing after leaving a huge gap at top even then page nagivation buttons gets disable. )
        



    2. i can use javascript through which i can change the property of the <div> , overflow:auto to overflow:visible on windows.onload event. (or i also works if i adds the property scrolling ="no" to the frame in which tht <div> is coming) ...... problem wid  this is : the duration within reports gets loaded in reportviewer and page is not loaded completely , during tht if i right click the reports it shows the double scrollbar for some fraction of time(since javascript runs on complete page load event). 


     is thereany otherway around..??
        
    Thursday, August 7, 2008 10:19 AM

All replies

  • yeah, same problem here.  I need async rendering, but I gotta figure out how to avoid the scroll bar issue.  It's not something I notice very often since I set my width and height to 100% and I use high resolutions, but I know some users have horrid resolution settings and complain about the scroll bar issue.
    Living my life at 123mph in 11.15 seconds
    Thursday, August 7, 2008 2:22 PM
  • As you have seen, there are a number of scrollbar issues like.  In our testing, we have seen the behavior vary based on the following items.  Adjusting these options on your page may help produce the desired output.

    1. AsyncRendering - Setting it to true uses a frame to display the report.  False does not.  This can obviously have a signifcant effect on the rendering.

    2. Browser - As you have seen, Firefox and IE have different behavior

    3. Percentage height - Specifying the height of the report viewer as a percentage rather than a fixed size (such as 400px) also can affect the scrollbars

    4. Doctype - Perhaps the biggest factor is the use of XHTML.  Often times, many of the scrollbar problems can be remedied by removing the <!DOCTYPE> tag from the beginning of the HTML file.

    Having said that, we are working on these issues and expect the next version of the report viewer to be a significant improvement in this area.

    Friday, August 8, 2008 8:15 PM
    Moderator
  • Hi.  The correct solution is to remove the overflow: auto style from the oReportDiv element inside the Report iframe using javascript.

    I have given the code I used to do this on my blog: http://beakdev.blogspot.ca/2012/04/double-scrollbars-in-reportviewer-for.html

    Monday, April 2, 2012 2:13 AM