none
configuring iis express failed with the following error unable to access the iis metabase

    Question

  • Hi everybody, 
    I have VS 2013 and I have recently updated my Windows 7 to Windows 10. Today I try to make new web site in VS doing the following: 

    file/new/website...

    Then when I choose whotever from the menu VS shows me pop-up message with following content:

    "configuring iis express failed with the following error:

    unable to access the iis metabase".

    1)I've already opened:

    ...System32\inetsrv\config

    and then:

    ...System32\inetsrv\config\Export.

    2) I also try to fix the problem by windows troubleshooter.

    3) Then I went into Control Panel -> Programs and Features -> Turn Windows Features on or off... inside that, I selected Internet Information Services -> Web Management Tools -> IIS 6 Management Compatibility -> IIS Metabase and IIS 6 configuration compatibility.

    4) I also set VS to be always opened as administrator.

    Although all these changes the problem still exists and I still receive the same error message.

    If anybody can help me I'll be gratefull.

    Thanks in advance!

    • Moved by Grady_Dong Tuesday, December 22, 2015 5:33 AM Visual Studio Related
    Monday, December 21, 2015 11:36 AM

Answers

  • Hi r_petrov,

    Please check whether you have checked "Use IIS Express for new file-based web sites and projects" under menu of Tools -> Options -> Projects and Solutions -> Web Projects.

    Then pleas turn off IIS and then turning it back on again which can help us reset the IISExpress settings.

    If still has this problem, please try repair your Visual Studio through Control Panel -> Programs -> Visual Studio 2013 -> Change -> Repair.

    In addition, please check the ActiveLog.xml under the path of %AppData%\Microsoft\VisualStudio\14.0. This file will log all operations when you operate Visual Studio.

    Best Regards,
    Weiwei

    Wednesday, December 23, 2015 6:54 AM
    Moderator

All replies

  • http://forums.iis.net/
    Monday, December 21, 2015 11:50 AM
  • Hi r_petrov,

    I thought this case is related to the visual studio more. Because the IIS Express is

    appended with Visual Studio. I will help you move this case to

    Visual Studio General Question forum for get better help.

    Best Regards,

    Wanjun Dong


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place. Click HERE to participate the survey.



    • Edited by Grady_Dong Tuesday, December 22, 2015 5:32 AM
    Tuesday, December 22, 2015 5:31 AM
  • Hi r_petrov,

    Please check whether you have checked "Use IIS Express for new file-based web sites and projects" under menu of Tools -> Options -> Projects and Solutions -> Web Projects.

    Then pleas turn off IIS and then turning it back on again which can help us reset the IISExpress settings.

    If still has this problem, please try repair your Visual Studio through Control Panel -> Programs -> Visual Studio 2013 -> Change -> Repair.

    In addition, please check the ActiveLog.xml under the path of %AppData%\Microsoft\VisualStudio\14.0. This file will log all operations when you operate Visual Studio.

    Best Regards,
    Weiwei

    Wednesday, December 23, 2015 6:54 AM
    Moderator