none
Retrieving the COM class factory for component with CLSID {F07EE002-902C-4F08-81D8-9296223CE482} failed due to the following error: 80040154 Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG)). RRS feed

  • Question

  • Hi,

    I have a console application and web API application. both have following code for referencing dll file. it is 32 bit dll file. I am doing development on 64 bit windows 10.when I remove Properties ---> Build --> unchecked Prefer 32 bit. It works in Console Application. It is disabled in web api. how can I resolve this permenantly.

    Console code

    Altova.MapForceServer.Server objMFs = new Altova.MapForceServer.Server();

    I got mentioned error form this line both applications.

    Thanks

    Thursday, March 30, 2017 5:55 AM

Answers

  • i got the solution from myself. wasted a lot time.

    Tools > Options > Projects and Solutions> Web Projects

    Check "Use the 64 bit version of IIS Express for web sites and projects"

    • Marked as answer by _Jeevan_ Wednesday, April 5, 2017 10:31 AM
    Wednesday, April 5, 2017 10:30 AM

All replies

  • Hello,

    Consider asking in the product support forum.

    https://www.altova.com/forum/default.aspx?g=topics&f=29


    Please remember to mark the replies as answers if they help and unmark them if they provide no help, this will help others who are looking for solutions to the same or similar problem. Contact via my Twitter (Karen Payne) or Facebook (Karen Payne) via my MSDN profile but will not answer coding question on either.
    VB Forums - moderator
    profile for Karen Payne on Stack Exchange, a network of free, community-driven Q&A sites

    Thursday, March 30, 2017 12:32 PM
    Moderator
  • So does it work in 32bit console app?  64bit console app?  What about in IIS if you set "Enable 32-Bit Applications" on the Application Pool?

    David


    Microsoft Technology Center - Dallas
    My blog

    Thursday, March 30, 2017 1:42 PM
  • No, It works only platform target x64 bit. how can i enable Enable 32-Bit Applications using iis express (VS)
    Friday, March 31, 2017 6:22 AM
  •  I am getting support since 3 days.So far they couldn't give a real solution.
    Friday, March 31, 2017 6:42 AM
  • i got the solution from myself. wasted a lot time.

    Tools > Options > Projects and Solutions> Web Projects

    Check "Use the 64 bit version of IIS Express for web sites and projects"

    • Marked as answer by _Jeevan_ Wednesday, April 5, 2017 10:31 AM
    Wednesday, April 5, 2017 10:30 AM