none
.Net 4.0 microsoft.vsa.dll RRS feed

  • Question

  • I have noticed that the Microsoft.Vsa.dll is installed with .Net framework 4.0 on machines that I use for development but on a regular machine it is not there.

    The machine I noticed it missing on happens to be Server 2008 R2.

    Is there a certain framework deployment I need to use to have that install with the framework?

    I know the library is obsolete but it seems to be there sometimes but not others?

    Thanks for any insight.

    Sue

    Thursday, March 8, 2012 3:00 PM

All replies

  • Hello Sue,

    As far as I know that the .NET Framework 4.0 is not included on Windows Server 2008 R2 machine. And I think in order to use it, you need to install it manually. You can get the .NET Framework 4.0 on the site: http://www.microsoft.com/download/en/details.aspx?id=17851

    Please also take look at this article which may be helpful to you:

    http://msdn.microsoft.com/en-us/library/5a4x27ek.aspx

    Thanks.


    Vicky Song [MSFT]
    MSDN Community Support | Feedback to us

    Friday, March 9, 2012 6:42 AM
    Moderator
  • I had installed .NET Framework 4.0.  That was not my question.

    The library Microsoft.Vsa.dll (which is obsolete) is not on my Server 2008 R2 machine in the C:\Windows\Microsoft.NET\Framework\v4.0.30319 directory.
    I do see it on my other machines that just so happen to have development environments on them.  This may or may not be a reason that the Microsoft.Vsa.dll is present.

    So is there a distibution of .NET framework that includes the Microsoft.Vsa.dll library.  Why is it on some installations and not others?
    Temporarily I moved that library over to the Server and it works for us but that is not a good solution.  I need to know which distribution(s) include this.

    Monday, March 12, 2012 2:10 PM
  • Hello Sue,

    As far as I know that the Microsoft.Vsa.dll comes from the .NET Framework 4.0. And do you mean that even though you have installed .NET Framework 4.0 on the Server 2008 R2 machine you still can't find the Microsoft.Vsa.dll assembly in the C:\Windows\Microsoft.NET\Framework\v4.0.30319 folder? You can use the .NET Framework Setup Verfication Utility to verify whether your .NET Framework 4.0 is installed successfully.

    Thanks.


    Vicky Song [MSFT]
    MSDN Community Support | Feedback to us

    Wednesday, March 14, 2012 7:14 AM
    Moderator
  • I ran the utility after removing the 3 files I manually added. It says that Verification succeeded for product .NET Framework 4 Full.

    So the Microsoft.Vsa.dll file is missing.  The verification tool says my install succeeded.
    I'm not sure what to read into that exactly.

    And while we're trying to figure out where this file is coming from and what installed it into C:\Windows\Microsoft.NET\Framework\v4.0.30319 to begin with we're going to want to know where the 64-bit version of this file is because it is conspicuously missing on 64-bit machines that have the file.

    Wednesday, March 14, 2012 7:19 PM
  • Hello Sue,

    I just have a x64 machine with x64 operation system, and I can find the Microsoft.Vsa.dll in the path C:\Windows\Microsoft.NET\Framework\v4.0.30319. And I think once you have installed .NET Framework 4.0 successfully, you should get Microsoft.Vsa.dll assembly shown in the above path.

    So sorry that I can't reproduce your issue, please open one new feedback on the Microsoft Connect site here:

    https://connect.microsoft.com/VisualStudio/feedback/CreateFeedback.aspx

    Thanks.


    Vicky Song [MSFT]
    MSDN Community Support | Feedback to us

    Saturday, March 17, 2012 7:33 AM
    Moderator
  • Ok so you found the file.

    Which distribution wrote that out there?

    I have successfully installed .NET 4.0 no question about that.

    This machine is just a deployment machine and as such does not have any dev tools or other items like that on there.  I suspect (but could be wrong) that something else like Visual Studio installation wrote that file out there.  As I say this file is always present on my development machines.

    My point about the Microsoft.Vsa.dll and 64 bit is it is NOT found in  C:\Windows\Microsoft.NET\Framework64\v4.0.30319.

    If Microsoft.Vsa.dll is a part of the standard framework and was installed as a part of the regular framework I would find it in both Framework and Framework64.  This still leaves me in the same spot. 
    Where is this file coming from?  Why is there not 64 bit version?  Why is it not installed in some versions of the framework?

    Monday, March 26, 2012 1:58 PM
  • I am having this same issue but I have never seen the Vsa DLLs installed with .NET 4.0 anywhere. Of course they are always installed with .NET 2.0.

    So what is the solution here?  Can I run a .NET 4.0 app with the .NET 2.0 Vsa DLLs assuming I copy the DLLs to my application's bin folder?

    How about answering the original question (now 3.5 years old) about which .NET 4.0 Framework install actually HAS the Vsa DLLs?



    • Edited by Dave5562 Friday, October 2, 2015 3:25 PM
    Friday, October 2, 2015 3:24 PM
  • In case someone still has the question in 2017...

    I had to compile a legacy app (originally written for .NET 2.0) with .NET 4.6. The app happens to also reference Microsoft.Vsa.dll assembly, which was not found on my brand-new Windows 10 dev box.  I had to install .net framework 3.5 SP1 (which is known to include .NET 2 and .NET 3) to make the app compile in VS 2015.

    Thursday, June 22, 2017 8:51 PM