none
Need logs if your device hasn't updated to the latest IoTCore version RRS feed

  • General discussion

  • Hello Insiders,

    We need your help. We are seeing some sporadic issues where it appears that devices are not updating to the latest build.

    How to check the current build number on your device using Windows IoT Dashboard:

    If you don’t already have Windows 10 IoT Core Dashboard, then please download and install it from here . On the "My devices" page in Windows IoT Dashboard, you will find the build number of your device in the “OS” column.

    We have two ways to collect logs and file feedback.

    • If you have set your “Diagnostic and usage data” setting to fullfollowing this link (on your desktop PC connected to your IoT core devices), then please follow the instructions listed in step 1 below. Logs will be copied automatically when you provide feedback using the IoTDashboard.
    • If you haven’t set your Diagnostic and usage data setting to full (on your desktop PC connected to your IoT core devices), then logs need to be copied manually. Please follow the instructions listed in step 2 below.

     

    1. Filing Feedback and copying logs Automatically:

     

    • Launch the Windows 10 IoT Core Dashboard.
    • On the "My devices" page in Windows IoT Dashboard, right click on your device.
    • Click on “Send feedback”. You may be prompted to enter your credentials.

    • You will get the following UI. Please ensure that the "Attach logs" checkbox is checked.

    • Click "Launch Feedback Hub".
    • Check the “Problem” radio button.
    • Enter the detail description (e.g., repro steps) of the issue in the feedback hub and submit your feedback.
    • Click on “Post feedback” button at the bottom.

    2. Filing Feedback and copying logs manually:

    • Launch the Windows 10 IoT Core Dashboard.
    • On the "My devices" page in Windows IoT Dashboard, right click on your device. You will be shown a context menu. 
    • Choose "Open Network share".
    • Enter your credentials when prompted.
    • The folder  \\<device_IP>\c$ will be opened for you.
    • Please copy the following two files (ReportingEvents.Log and UpdateHistory.xml) and two folders (Logs and NonETWLogs) to a local folder on your computer.

    \\<device_IP>\c$\Data\ProgramData\SoftwareDistribution\ReportingEvents.log
    \\<device_IP>\c$\Windows\ImageUpdate\UpdateHistory.xml
    \\<device_IP>\c$\Data\ProgramData\USOShared\Logs\
    \\<device_IP>\c$\Data\SystemData\NonETWLogs

    • Please zip all the files of your local folder into one zip file. This will save time when attaching the logs to your feedback.
    • On the "My devices" page in Windows IoT Dashboard, right click on your device.
    • Click on “Send feedback”. You may be prompted to enter your credentials.
    • Check the “Problem” radio button and enter the detail description (e.g., repro steps) of the issue in the feedback hub (as shown below). 
    • Click "Attach a file".
    • You will get a folder browser dialog. Attach the log files you copied from the device.  

    Thursday, July 14, 2016 12:36 AM
    Moderator

All replies

  • it was not possible to attach a file as my feedback hub does not present the "attach a file" option, only screenshot...

    windows version 1607 build 14393.5
    feedback hub version 1.3.1741.0 (updated 7/20/2016)
    Tuesday, July 26, 2016 11:49 AM
    Moderator
  • Tuesday, July 26, 2016 12:00 PM
    Moderator
  • my RPi2 does not upgrade from build 14376 to build 14393.

    in Feedback Hub, I don't have the possibility to upload log-/zip- files, I don't have that option - only screenshots are possible.

    Thursday, July 28, 2016 11:36 AM
  • What version of Windows & feedback hub are you running on your PC? 
    Tuesday, August 2, 2016 5:26 PM
    Moderator
  • I am stuck on 10586 with a RPI 2 B

    pi no longer shows up in the IoT dashboard.

    I do have access to the web interface.

    Can I get the error logs from the web interface?

    There are many of these in Debugging:

    Report signature

    • ClientVersion : 10.0.10586.0
    • Win32HResult : 80246002
    • UpdateID : 4A28DAC1-2650-4CF2-8A3E-3381D8DB7A84
    • Scenario : Download
    • RevisionID : 200
    • IsManaged : 0
    • LastError : 0
    • CallerAppID : UpdateOrchestrator
    • ServiceUsed : {7971F918-A847-4430-9279-4A52D1EFE18D}
    • MiscField2 : 0

    EventTime

    ‎8‎/‎24‎/‎2016‎ ‎9‎:‎47‎:‎28‎ ‎PM

    Link to Watson bucket

    126965803701

    FriendlyEventName

    Windows Update installation problem

    AppName

    Host Process for Windows Services

    AppPath

    C:\Windows\System32\svchost.exe

    Thursday, August 25, 2016 11:22 AM
  • @wavemaster00 you would need to run a powershell script to collect logs

    please check the posting from IoTGirl from Thursday, August 04, 2016 11:25 PM for the script

    https://social.msdn.microsoft.com/Forums/en-US/6a2f990e-ff02-46a9-91dd-54a53fcfa431/rpi3-wont-update-to-flight-14393?forum=WindowsIoT

    Thursday, August 25, 2016 11:29 AM
    Moderator
  • Never used powershell.

    Can I wipe the SD card and start from scratch with the newest version?

    Thursday, August 25, 2016 11:51 AM
  • sure ... i would use the dashboard to install
    Thursday, August 25, 2016 11:52 AM
    Moderator
  • My apologies for bailing out on the troubleshooting.

    Driving to a store to buy myself an extra sd card and installing the new preview was much more time efficient.

    Used the dashboard install as per your suggestion and that worked very well.

    Device still does not show up in the dashboard. Oh well.

    Thanks for the help.

     
    Friday, August 26, 2016 12:15 PM
  • glad you have it working

    is the pc with the dashboard in the same network segment with no router between?

    Friday, August 26, 2016 1:20 PM
    Moderator
  • I installed Windows 10 IoT Core yesterday on a Raspberry PI 3. The build was downloaded from the Internet using the Windows 10 IoT Core Dashboard. I didn't notice which build was installed, but a few hours later I noticed that the monitor showed the gears working on installing a new update. Then after I while it is running 10.0.14393.187.

    I also have a Raspberry Pi running 10.0.14393.67. I thought I should be able to upgrade this to the newest version as well and invoked "Check for updates" from the Device Portal. But, it stated "Your device is up to date". Is it really running the latest version or why can't it update to .187?

    Saturday, October 1, 2016 2:05 PM
  • Hi Olaf,

    Likely it is already downloading .187 and just waiting for all of the steps to complete before applying the update.

    Sincerely,

    IoTGirl

    Monday, October 3, 2016 5:42 AM
    Moderator
  • My organization prevents me setting my feedback options in the settings panel. Is there also an other way to send you the zip file?
    Friday, November 4, 2016 1:33 PM
  • Hi Polychaeta,

    It looks like that you can't change your diagnostic and user data settings. In that case, you can follow the step 2 (copying logs manually) listed above.

    Thanks!

    Friday, November 4, 2016 4:46 PM
    Moderator
  • Hi Zeeshan Furqan,

    negative, when trying step 2, I zip the files and then I also have to right click the device and select feedback. This opens the Feedback Hub App. I am not able to submit a new feedback, the page "New Feedback" is locked. It wants me to adapt settings which my organization prevents me of doing so. Shall I provide screenshots (unfortunately they will be german)?

    So I want to provide you with files, but I can't! Any Ideas?

    Poly

    Saturday, November 5, 2016 10:29 AM
  • Hi Poly,

    Do you have the ability to provide a temporary read-only internet share that Zeeshan could reach to copy the files?  If you provide that link, once Zeeshan has download the files you can edit your post and remove the link and take down the temporary location.

    Sincerely,

    IoTGirl


    Monday, November 7, 2016 5:15 AM
    Moderator
  • Sure! Get it here!

    Keep me posted if I can remove the file... Thanks

    Tuesday, November 8, 2016 7:25 PM
  • Hi Polychaeta,

    We have your file! You are hitting:

    The update failed with Disk full error 0x80070070

    ERROR_DISK_FULL

    There is not enough space on the disk.

     

    Can you ask Poly to check the SD card to see if any partition is full or close to full?

    Sincerely,

    IoTGirl

    Tuesday, November 8, 2016 9:18 PM
    Moderator
  • Oh - yeah it is possible i clogged the disk with some big sized files. Or the disk is to0 small as well. Thank you for pointing me on that. However, I never encountered an "Out of space" message after the update failure - maybe that would be a "feature" worth implementing...?


    • Edited by polychaeta Saturday, November 12, 2016 7:20 PM grammar
    Saturday, November 12, 2016 7:20 PM
  • Hi Polychaeta,

    You would have encountered the message if you would have reviewed the log files.  IoT Core is not guaranteed to have a UI so these logs are really the correct place for that data.

    Sincerely,

    IoTGirl

    Sunday, November 13, 2016 10:33 PM
    Moderator
  • FYI 1. Filing Feedback and copying logs Automatically: does not work, it only opens the feedback hub app in subcategory Windows 10 IoT Core but without to open a new feedback or attaching of logs ?

    and its still not possible to attach logs (reported Tuesday, July 26, 2016 6:20 PM...), no such option exists

    so if you want logs you should provide us a way ...




    Tuesday, February 28, 2017 12:19 AM
    Moderator
  • If I wanted to side load the Feedback Hub from somewhere, is there a location that I could download it. Corporate policy has blocked the Windows Store, so I am unable to download to my host machine.

    Thanks in advance!

    Cheers

    John

    Monday, March 6, 2017 1:14 PM
  • @JohnDr you should consult your corporate IT department to get access to FeedbackHub App
    Monday, March 6, 2017 3:03 PM
    Moderator
  • Done that. Awaiting feedback. Not optimistic.
    Monday, March 6, 2017 3:08 PM
  • It's official, can't access the Windows Store to get access to the Feedback Hub. Does any one know where I can download this from to side-load?
    Wednesday, March 8, 2017 2:50 PM
  • @JohnDr Feedback Hub App is only available through Windows Store, your admin would not be happy if you would have other options ;) can you negotiate at least he installs the app as it looks like your job requires it?

    Wednesday, March 8, 2017 3:02 PM
    Moderator
  • Is this the same feedback mechanism that's built in to windows from 10.0.14271, as mentioned here: https://docs.microsoft.com/en-us/windows/uwp/monetize/launch-feedback-hub-from-your-app - we also have to wait for corporate IT to roll out the new image (no timescale at present) as I'm on 10586. I can see it from their point of view in that they couldn't simply open up the store, but they could make an exception for a development machine to have an app side loaded. If I could find an official version to install from, then I could get our local IT to install it.
    Thursday, March 9, 2017 7:48 AM
  • @JohnDr the Feedback Hub App require at least 14361.0




    Thursday, March 9, 2017 10:08 PM
    Moderator
  • Sorry for inundating your box. The only two RPi boards that I have dedicated for Win10 IoT Core did not boot after I confirmed the restart from the automatic upgrade. Back to rebuilding the SDcards, I guess, is the only option on the table. Rgds.
    Monday, March 20, 2017 7:56 PM
  • Hi Baq,

    You state "did not boot after I confirmed the restart from the automatic upgrade".  You should not have to intervene in this process. The device will reboot when the update has been applied.  If you force a reboot early, you may remove power while the device is still accessing the SD Card which can cause corruption. All of my devices have booted successfully post update but I do not interrupt them at any point.

    Sincerely,

    IoTGirl  

    Monday, March 20, 2017 9:44 PM
    Moderator
  • 2015 v1.2 RPi3 B (ScanDisk Extreme 32 GB) Windows v10.0.x IoT > BUILD 15051.0 is not updating, build 16176 is that latest, correct?

    Thank you, might anyone have any suggestion(s) why it is not updating?

    Rich L. Maynard, Jr.

    www.richmaynard.com -- hosted at present via Raspbian (typically online: M-Th 24/7, F-Su ONLINE with Windows IoT)


    | Rch~

    Monday, June 5, 2017 12:10 AM
  • Hi Rich,

    There can be any number of reasons but the logs described here should help diagnose the issue.  FYI my devices are RETAIL 15063.297 and INSIDER 16193.1001 as of today.

    Sincerely,

    IoTGirl

    Monday, June 5, 2017 4:53 PM
    Moderator
  • From time to time my devices (all Raspberry Pi 3) seems to have a Problem for updating Windows 10 IoT Core. On the device portal -> Windows Update, i get "Last update failed.". Even if i check for updates, i then get last update failed. After setting up the device from scratch, it works again. This is very disappointing. Is there a way to reset the state or something else?
    Tuesday, April 24, 2018 2:54 PM
  • @andy-dev

    i have merged your question with an already existing thread

    please use Feedback Hub to report issues

    br
    Andre

    Tuesday, April 24, 2018 3:02 PM
    Moderator
  • @Andre Marschalek

    Thank you. I have already reported the issue in the feedback hub. I had this problem already a few months ago, there I had to reinstall Windows 10 IoT Core. For testing this is not a huge problem, but for devices which are running in a production evironement, this is critical.

    Tuesday, April 24, 2018 3:47 PM
  • @andy-dev 

    i also had update issues like you describe but those are solved since q4 last year, since that time all insider updates worked without issues so feedback hub is your best bet

    Tuesday, April 24, 2018 6:46 PM
    Moderator
  • @andy-dev 

    i also had update issues like you describe but those are solved since q4 last year, since that time all insider updates worked without issues so feedback hub is your best bet

    That sounds good, but i don't use insider builds on my devices, so this should not happen on stable releases. What exactly is the current available non insider build? The changelog provided on msdn does show only build 16299, but not the exact version.
    Tuesday, April 24, 2018 8:11 PM
  • Feedback hub is still the best place to record such issues as, unlike MSDN, it creates an issue in a TFS Database that can be researched directly by the Windows team. Also through that method, they can follow up with you individually should they need more details.
    Wednesday, April 25, 2018 12:54 AM
    Moderator
  • Ok i have added my issue there.
    Wednesday, April 25, 2018 3:17 PM